Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox won't stop prompting me for master password

  • 2 trả lời
  • 1 gặp vấn đề này
  • 7 lượt xem
  • Trả lời mới nhất được viết bởi jscher2000

more options

Hello,

Long-time Firefox user here. I'm running Firefox (version 75.0, auto-updates enabled) on a Windows 10 (Version 10.0.18362 Build 18362) desktop PC. I'm using the built-in Firefox password manager, although as a general practice I do not log into it using my master password unless absolutely needed (for example, to check my email or Slack). For the vast majority of the general browsing I do, I stay logged out of my accounts.

This has worked just fine for years. However, lately Firefox keeps prompting me to enter my master password, and won't stop prompting me for my password while I'm browsing. Oftentimes I'll randomly receive the prompt, often on sites that should not be asking for a password, such as a blank New Tab or sites that don't have any associated data in my password manager.

What's frustrating is that, when I close the prompt, Firefox will immediately re-prompt me again to enter my master password, despite me not wanting to log in (or on some sites, not having an account or even a login page). It will keep repeating this prompt incessantly, sometimes for 5-6 times before going away briefly, only to reoccur when I navigate to a new site.

My browser is configured to be a bit more privacy-conscious, and I'm wondering if this may be causing this behavior. In Options > Privacy and Security, I've set Custom blocking for the following items: - Cookies (all third-party sites) - Tracking content (in all windows) - Cryptominers - Fingerprinters I have also set my browser to delete cookies and site data upon closure.

I am using the following plugins, with auto-updates enabled: uBlock Origin HTTPS Everywhere Privacy Badger Decentraleyes Cookie Autodelete Firefox Mult-Account Containers Facebook Container

I've searched the support forums for help on this topic and found the two articles below. However, after trying the offered solutions, neither fixed the underlying behavior. Also note that I am not using any third-party antivirus solutions, like ESET Internet Security and Avast, which have been known to cause similar issues with the Firefox password manager. Here are the articles I found: https://support.mozilla.org/en-US/kb/firefox-keeps-asking-me-master-password (I tried these steps and still had the same behavior happen) https://support.mozilla.org/en-US/questions/1176785 (this just disables the Password Manager, something I ideally would not have to do to stop this behavior)

Can anyone provide any insight into why Firefox keeps doing this? I love Firefox but lately it's become a drag to use because of this. Thanks all.

Tất cả các câu trả lời (2)

more options

Hi andre.tom, I've noticed something odd with Firefox 75 myself. I think Firefox only used to prompt for the Master Password on a site where you've saved a login if the page had login fields. Now it seems it may prompt even on pages from the site that do not have login fields. I wasn't able to replicate this problem in a clean profile, so a setting or some historical data also might be involved, as well as change in Firefox 75.

You and I are not the only people who've noticed, here are a couple other recent threads:

I realize it's not an appealing workaround, but if you very rarely use the Password Manager (Lockwise) you can disable it by unchecking the box on the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type login and Firefox should filter to the "Logins and Passwords" section. Then you can uncheck the box for "Ask to save logins and passwords for websites".

You'll need to check it once again to re-enable Lockwise.

more options

As a footnote, at startup the Master Password prompt may randomly appear in an unrelated window, but that doesn't happen after I initially dismiss that, so this sounds kind of suspicious:

andre.tom said

However, lately Firefox keeps prompting me to enter my master password, and won't stop prompting me for my password while I'm browsing. Oftentimes I'll randomly receive the prompt, often on sites that should not be asking for a password, such as a blank New Tab or sites that don't have any associated data in my password manager.