Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How do I set Flash to click-to-run in Mozilla Firefox? Flash does not appear in the "Add-ons" list

  • 12 trả lời
  • 2 gặp vấn đề này
  • 1139 lượt xem
  • Trả lời mới nhất được viết bởi jscher2000

more options

The articles in the Help section say to click on the menu on the right of the Firefox window, then select "Add-ons". The Flash extension should appear and I can set it to "click-to-run". The problem is that the Flash extension isn't there. I have Firefox 75.0 . Thanks

Giải pháp được chọn

Hi Stuart, it should be under Plugins, not Extensions. Maybe that was a typo, but if you have a flash extension that could be an unofficial product instead of the real Adobe Flash plugin.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (12)

more options

Please reply to xxxxxxxxx@xxxxx.xxx

(email address removed by moderator; please do not post personal information on a public website)

Được chỉnh sửa bởi cor-el vào

Hữu ích?

more options

You can download the latest NPAPI Flash plugin for Firefox on this page.

Make sure to remove checkmarks for including unwanted additional software.

Hữu ích?

more options

I clicked on the link and downloaded the app but it still doesn't appear in my Add-ons list

Hữu ích?

more options

With the last Firefox upgrade, some plugins are no longer enabled until you enable it.

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A

On the left side of the page, select Plugins.

Also:

https://support.mozilla.org/en-US/forums/support-forum-contributors/713656 Filed a Bug Report - Users complaining of removing Always Allow for flash player

Hữu ích?

more options

You have not read my original statement of the problem. In it I said that the Flash Add-on DOES NOT APPEAR IN THE LIST.

The first answer told me how to download the latest NPAPI Flash plugin for Firefox. In my response to cor-el I said that I followed his/her instructions and the Add-on still did not appear.

Now you seem to be AGAIN telling me how to find the Add-on. IT'S NOT THERE.

This method of resolving problems with Firefox seems NOT to work. I'll save your time. Forget the question - it's obvious that nobody knows the answer.

Hữu ích?

more options

Normally it works like this:

(A) Install Flash player for Firefox using a download from Adobe's site -- the installer lists Shockwave Flash as an available plugin in the Windows Registry

(B) At startup, Firefox finds Flash listed in the Windows Registry and adds it to the Plugins list on the Add-ons page (the other two you usually find there are OpenH264 and Widevine)

- - - - -

In the old days when Flash was more common, we had numerous threads about why Firefox might not detect or enable Flash, so I'll paste from one of those:

If the Flash plugin is not listed on the Add-ons page:

Check for the Plugin DLL in the Usual Location

In 64-bit Firefox on 64-bit Windows 10 that should be here:

C:\Windows\System32\Macromed\Flash

and the file would be named NPSWF64_32_0_0_363.dll (unless there is a newer version with something different instead of 363).

If you do not have that file: The installer isn't working for some reason.

- - - -

If you have the correct physical file in the usual location, but Firefox does not discover it or has lost track of it:

Firefox discovers the location of the Flash plugin from an entry its installer creates in the Windows Registry. (I'm going to assume that entry still exists...)

One possible reason for an installed plugin not to appear on the Add-ons page is if Firefox has been set NOT to scan the registry for plugins. Another is that Firefox's settings file storing plugin data has become corrupted. Here are the steps to check those possibilities:

Confirm that Firefox is scanning the registry for plugins

Firefox finds the Flash plugin from a registry entry. Some users have the scanning turned off for some reason. Here's how to check and fix that:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button accepting the risk.

(B) In the filter box in the page, type or paste scan and pause while the list is filtered

(C) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default

If you changed this setting, exit and restart Firefox to trigger another scan.

If you check the Add-ons page, Plugins section again, can you find "Shockwave Flash" there with the current version number?

If Firefox is set to scan but still does not find Flash and list it on the Add-ons page...

Remove Firefox's plugin registry file

Sometimes the pluginreg.dat file becomes corrupted. You can remove it and have Firefox re-scan for plugins.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button to launch a new File Explorer window showing your settings files.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginregOLD.dat

Start Firefox back up again.

When you return to the Add-ons page, is "Shockwave Flash" finally listed?

Được chỉnh sửa bởi jscher2000 vào

Hữu ích?

more options

Thanks for your lengthy and complete response. I managed to verify everything (the right files were there and everything was as it should be) until I got to this point:

"In the first table on the page, click the "Open Folder" button to launch a new File Explorer window showing your settings files.

Leaving that window open, switch back to Firefox and Exit, either:

   "3-bar" menu button > "power" button
   File menu > Exit"

When I clicked on the Open Folder button it took me to the Task Manager file that was beside the button : C:\ProgramData\Mozilla\updates\308046B0AF4A39CB . I could not figure out how to open a new folder.

Also, I checked the "3-bar" menu for a "power" button. I couldn't find one. If I want to use the File menu > Exit option are you referring to the tab in Task Manager or someplace else.

Hữu ích?

more options

Hi Stuart, sorry about that, I updated my post after you got the email notification, since it was for a pre-57 version of Firefox. The first table on the Troubleshooting Information page now has multiple "Open Folder" buttons. The one you need is on the row that starts with "Profile Folder". Starting in Firefox 57, the main menu has words again, so the word Exit is next to the power button. (The File menu is on the optional menu bar. You can tap the Alt key or F10 to display the bar temporarily when needed.)

Hữu ích?

more options

I think we are making headway but I am not there yet. I'm also not sure that this is worth all of the time you are spending with me (although I very much appreciate it).

I got as far as renaming the file and exiting Firefox. When it loaded and I went to the 3-bar menu button, then to "add-ons". Flash was not there.

I went back to the registry and checked for the "pluginreg.dat" file. Both the "pluginreg.dat" file and the "pluginregOLD.dat" files were there.

I can live with things the way they are. After December 31st when Flash is no longer supported in Chrome (which I use only for the Calendar, Translater, Google Maps and Google Contacts), I just want to make sure that I have HTML5 and that Flash doesn't preempt HTML5.

Have I been leading everyone on a wild goose chase because I wasn't specific about why I was having the problem? I sincerely hope not.

Hữu ích?

more options

Hmm, does your Add-ons page, Plugins panel, show the other two plugins that Firefox generally shows post-installation? I'm puzzled why Flash is not showing up there.

Anyway, if Flash is secretly installed somewhere in Firefox, Firefox should show an icon in the address bar when a site calls for it. For example, on Adobe's test page at https://helpx.adobe.com/flash-player.html

It is possible for companies that manage Firefox installations to modify how Flash permissions work using a Policy. You can see whether your Firefox has any policies installed by typing or pasting about:policies in the address bar and pressing Enter to submit that to load the Policies page.

Hữu ích?

more options

WOW ! I went to get the names of the other two files and there, under Extensions, was the Shockwave Flash plug-in. It wasn't there after I rebooted and restarted Firefox but it's there now and set to "Ask to Activate". Thanks for your perseverance and for sharing your detailed knowledge. Take care and stay safe.

PROBLEM SOLVED !

Stuart

Hữu ích?

more options

Giải pháp được chọn

Hi Stuart, it should be under Plugins, not Extensions. Maybe that was a typo, but if you have a flash extension that could be an unofficial product instead of the real Adobe Flash plugin.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.