Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

When copying text it doesn't preserve the white spacing, how can I change the setting to include white spacing instead of the default of <1>?

  • 5 trả lời
  • 1 gặp vấn đề này
  • 150 lượt xem
  • Trả lời mới nhất được viết bởi Perry

more options

When copying text, it defaults any spacing between characters to 1 space. I need to preserve the spacing due to programming and parsing those spaces.

Giải pháp được chọn

Hello Perry,

Maybe you could ask "erosman", the author of the
"Copy PlainText 1.10" extension that you have installed ?

https://addons.mozilla.org/en-US/firefox/addon/copy-plaintext/

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (5)

more options

Hi Perry, Firefox puts two formats (at least) on the clipboard. Plain text preserves extra spaces; HTML does not. So what you get from the clipboard depends on the format preferred by the receiving program.

For example, this paragraph will paste with extra spaces in a form field (textarea) but in a rich text editor, the spaces might be removed because the browser or other program preferentially uses the HTML.

Note: Firefox 64 is no longer supported. Currently, we support Firefox 74.0 and the Extended Support Release of Firefox 68. The foregoing is based on Firefox 74.0.

more options

Jscher...thanks... but I've already tried that method of copying...by selecting the area...right click ...copy as plain text... and putting it into my dev environment of Intellij or into a notepad document, it still removes the white spaces... I'll take a snip so you can see before and after....

it appears either the interface of mozilla isn't recognizing the white space... it works with google chrome and that recognizes the white space in my logs...but mozilla doesnt recognize it... I was hoping it was a setting or configuration that isn't allowing white space recognition ... any other suggestions?

Được chỉnh sửa bởi Perry vào

more options

Giải pháp được chọn

Hello Perry,

Maybe you could ask "erosman", the author of the
"Copy PlainText 1.10" extension that you have installed ?

https://addons.mozilla.org/en-US/firefox/addon/copy-plaintext/

more options

Perry said

I've already tried that method of copying...by selecting the area...right click ...copy as plain text...

Oh, I assumed you were using the built-in "Copy" function. I think McCoy has spotted the problem.

more options

I believe that extension worked... if I "copy plain text"...the auto trim feature within Mozilla removes excess white space...while the simple "copy" does not... thanks again for your help....I appreciate it a lot...

Được chỉnh sửa bởi Perry vào