Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

disabling bookmarks history

  • 5 trả lời
  • 1 gặp vấn đề này
  • 42 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I have a problem, i ve been searching everywhere but nothing about this. I want to disable this bookmarks history in this menu icon near ublock icon>library>bookmarks and here is whole list of last added bookmarks. This activity stream in about config do not work with this. I dont have any folder with these in bookmarks settings, the only place where i can find this list is here. Is there any way to delete this and to stop firefox collecting history of every bookmarks i add there?

Giải pháp được chọn

You can hide the Recently Bookmarked section in the Library menu with code in userChrome.css.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* hide Recently Bookmarked */
#panelMenu_recentBookmarks,#panelMenu_bookmarksMenu {
 display:none !important;
}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a plain text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

See also:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (5)

more options

here is a screenshot of this thing, ive erased most urls but there is a whole list to the bottom

more options

As far as I know, you cannot remove the "Recently Bookmarked" list from the Bookmarks section of the Library menu.

Do you share your computer with other people, is that why it's a problem?

more options

Giải pháp được chọn

You can hide the Recently Bookmarked section in the Library menu with code in userChrome.css.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* hide Recently Bookmarked */
#panelMenu_recentBookmarks,#panelMenu_bookmarksMenu {
 display:none !important;
}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a plain text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

See also:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

more options

Thank you very much it worked! 1st time there was no change so i checked this 2nd link you posted and for some reason when i typed userprof 1st and then this toolkit stuff it appeared on false. I changed it again and this time it worked fine. After change now its just like i wanted, bookmarks history is gone. I hope it wont interfere with bookmarks in any other way?

more options