X
Nhấn vào đây để đến phiên bản di động của trang web.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Diễn đàn trợ giúp

when you open a new tab switch to it is not working i have tick it but it still does not work

Được đăng

when i click to open a new link it opens on the same tab it wont open a new tab automatically i have to keep pressing ctrl to open a new tab can you help me please thank you

when i click to open a new link it opens on the same tab it wont open a new tab automatically i have to keep pressing ctrl to open a new tab can you help me please thank you

Giải pháp được chọn

thank you for your reply i have now sorted out the problem i whent to about:config set browser tabs loadbookmarksin tabs i have set that to true new tabs is now working thank you for your help

Đọc câu trả lời này trong ngữ cảnh 0
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 32.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0

Thông tin chi tiết

McCoy
  • Top 10 Contributor
625 giải pháp 6000 câu trả lời
Được đăng

johnhammond1958 said

when i click to open a new link it opens on the same tab it wont open a new tab automatically i have to keep pressing ctrl to open a new tab can you help me please thank you

Hello john,

Having checked "When you open a link in a new tab, switch to it immediately" means that the tab in question will open immediately.

When you uncheck that option, you will have to click on the tab to open it.

Either way : you still have to press Ctrl if you don't want the link to open in the same tab you're on.

''johnhammond1958 [[#question-1280763|said]]'' <blockquote> when i click to open a new link it opens on the same tab it wont open a new tab automatically i have to keep pressing ctrl to open a new tab can you help me please thank you </blockquote> Hello john, Having checked "''When you open a link in a new tab, switch to it immediately''" means that the tab in question will open immediately. When you uncheck that option, you will have to click on the tab to open it. Either way : you still have to press Ctrl if you don't want the link to open in the same tab you're on.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

i have unticked it still have the same problem when i open youtube it switches to a new tab automatically if i click Google it shows on the same tab this has only started when the new update 73.0.1 came down

i have unticked it still have the same problem when i open youtube it switches to a new tab automatically if i click Google it shows on the same tab this has only started when the new update 73.0.1 came down
Bài viết này có hữu ích với bạn không?
Trích dẫn
avalon2 0 giải pháp 7 câu trả lời
Được đăng

I have the opposite problem. I'm using FF 72 on one Mac and FF 73 on another (and FF 48 on another but that's not really relevant to this question). On both I have disabled the settings in Preferences to "when you open a link to a new tab switch to it immediately" so when I "Open Link in New Tab" that I can continue browsing and open multiple links from a page (such as Google search) to review soon, but not right now. I works as designed for the #72 but is totally ignored for the 73 on all but one or two websites. Updating to a Firefox above #73 is not a good fix for me because some of my Extension Buttons on the Toolbar disappear. Any ideas on how I can fix this?

I have the opposite problem. I'm using FF 72 on one Mac and FF 73 on another (and FF 48 on another but that's not really relevant to this question). On both I have disabled the settings in Preferences to '''"when you open a link to a new tab switch to it immediately"''' so when I "Open Link in New Tab" that I can continue browsing and open multiple links from a page (such as Google search) to review soon, but not right now. I works as designed for the #72 but is totally ignored for the 73 on all but one or two websites. Updating to a Firefox above #73 is not a good fix for me because some of my Extension Buttons on the Toolbar disappear. Any ideas on how I can fix this?
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
625 giải pháp 6000 câu trả lời
Được đăng

johnhammond1958 said

i have unticked it still have the same problem when i open youtube it switches to a new tab automatically

Let me see if I understand this correctly : You have unchecked the option "When you open a link in a new tab, switch to it immediately", but in YouTube the video starts to play imediately ? That should only happen when you click on a link without pressing the Ctrl key.

if i click Google it shows on the same tab this has only started when the new update 73.0.1 came down

Again: this should only happen if you don't press the Ctrl key when you click on a link (see my first post).

Can you confirm that in both cases you don't hold the Ctrl key ?

''johnhammond1958 [[#answer-1293491|said]]'' <blockquote> i have unticked it still have the same problem when i open youtube it switches to a new tab automatically </blockquote> Let me see if I understand this correctly : You have unchecked the option "When you open a link in a new tab, switch to it immediately", but in YouTube the video starts to play imediately ? That should only happen when you click on a link ''without'' pressing the Ctrl key. <blockquote> if i click Google it shows on the same tab this has only started when the new update 73.0.1 came down </blockquote> Again: this should only happen if you don't press the Ctrl key when you click on a link (see my first post). Can you confirm that in both cases you don't hold the Ctrl key ?
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
625 giải pháp 6000 câu trả lời
Được đăng

@ avalon2 :

I would like to ask you the same question : do you press the Ctrl (or Cmd) key when you click on a link ?

If not, then would you please take a look at this article :

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

@ avalon2 : I would like to ask you the same question : do you press the Ctrl (or Cmd) key when you click on a link ? If not, then would you please take a look at this article : https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

thank you for your help i have solved the problem i had to go to about:config set browser tabs loadbookmarksin tabs to true it now opens new tab i am very grateful for your help

thank you for your help i have solved the problem i had to go to about:config set browser tabs loadbookmarksin tabs to true it now opens new tab i am very grateful for your help
Bài viết này có hữu ích với bạn không?
Trích dẫn

Giải pháp được chọn

thank you for your reply i have now sorted out the problem i whent to about:config set browser tabs loadbookmarksin tabs i have set that to true new tabs is now working thank you for your help

thank you for your reply i have now sorted out the problem i whent to about:config set browser tabs loadbookmarksin tabs i have set that to true new tabs is now working thank you for your help
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
625 giải pháp 6000 câu trả lời
Được đăng

johnhammond1958 said

thank you for your help i have solved the problem i had to go to about:config set browser tabs loadbookmarksin tabs to true it now opens new tab i am very grateful for your help

    I'm so glad that you got it to work - well done !

''johnhammond1958 [[#answer-1293780|said]]'' <blockquote> thank you for your help i have solved the problem i had to go to about:config set browser tabs loadbookmarksin tabs to true it now opens new tab i am very grateful for your help </blockquote> &nbsp; &nbsp; I'm so glad that you got it to work - well done !
Bài viết này có hữu ích với bạn không?
Trích dẫn
avalon2 0 giải pháp 7 câu trả lời
Được đăng

McCoy said "I would like to ask (Avalon2) the same question : do you press the Ctrl (or Cmd) key when you click on a link ?"

I customarily right click the mouse and choose "open link in new tab." Per your suggestion I Ctrl-Clicked and chose the same "open link in new tab" from the context (?) menu. (Cmd-clicks don't seem to apply but since Ctrl does, that comes as no surprise.) I get the same behavior from Ctrl-click as I do for Right-click. Namely, in Firefox 72 the focus is not forcibly moved to the new tab, but in Firefox 73 the focus still changes to the newly opened tab.

I read your suggested article. My settings/preferences on this matter do seem to save. That is, I do not check "when you open a link to a new tab switch to it immediately." If I restart the browser (and even the whole computer) and then check, the preference after restart is still unchecked as it was before. And the glitch/problem still occurs.

I have further tested by checking the "when you open a link to a new tab switch to it immediately" box, restarting, and it is also saved there. (In FF 73 there is no performance change, in FF 72 the preference change does make the tabs work as the check box directs.) After that restart and seemingly saved change, I switch back to having "when you open a link to a new tab switch to it immediately" being unchecked again. The original behavior is still there. So I restart again and get the same results as before. (I.e., my hope that toggling the setting back and forth might fix it all doesn't fix it.)

I initiated the Refresh option (as suggested by your suggested article) on the FF 73 iMac, set the preference, and got the same behavior. (Since that did not work, to save time I reinstalled the previous non-Refreshed copy from my Time Machine backup rather than reset all my extensions and re-Customize my Toolbar buttons.) I did not try to Refresh the FF 72 (on a MacMini) because it isn't broken.

Thanks for your advice and for your reference to that article, by the way :)

'''''McCoy''' [[#answer-1293765|'''said''']]'' '''"I would like to ask (Avalon2) the same question : do you press the Ctrl (or Cmd) key when you click on a link ?"''' I customarily right click the mouse and choose "open link in new tab." Per your suggestion I Ctrl-Clicked and chose the same "open link in new tab" from the context (?) menu. (Cmd-clicks don't seem to apply but since Ctrl does, that comes as no surprise.) I get the same behavior from Ctrl-click as I do for Right-click. Namely, in Firefox 72 the focus is not forcibly moved to the new tab, but in Firefox 73 the focus still changes to the newly opened tab. I read your suggested article. My settings/preferences on this matter do seem to save. That is, I do not check "when you open a link to a new tab switch to it immediately." If I restart the browser (and even the whole computer) and then check, the preference after restart is still unchecked as it was before. And the glitch/problem still occurs. I have further tested by checking the "when you open a link to a new tab switch to it immediately" box, restarting, and it is also saved there. (In FF 73 there is no performance change, in FF 72 the preference change does make the tabs work as the check box directs.) After that restart and seemingly saved change, I switch back to having "when you open a link to a new tab switch to it immediately" being unchecked again. The original behavior is still there. So I restart again and get the same results as before. (I.e., my hope that toggling the setting back and forth might fix it all doesn't fix it.) I initiated the Refresh option (as suggested by your suggested article) on the FF 73 iMac, set the preference, and got the same behavior. (Since that did not work, to save time I reinstalled the previous non-Refreshed copy from my Time Machine backup rather than reset all my extensions and re-Customize my Toolbar buttons.) I did not try to Refresh the FF 72 (on a MacMini) because it isn't broken. Thanks for your advice and for your reference to that article, by the way :)
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17846 giải pháp 161535 câu trả lời
Được đăng

Note that browser.tabs.loadBookmarksInTabs only applies to open a bookmark.

There is a similar pref named browser.search.openintab for opening search results when you use the separate search bar on the Navigation Toolbar.

There are some prefs, accessible via the about:config page, to control focus if you click a link (open link in background or foreground). You can toggle the default action by holding the Shift key down when you left-click or middle-click a link.

  • browser.tabs.loadInBackground (normal links)
  • browser.tabs.loadDivertedInBackground (javascript and external links)
  • browser.tabs.loadBookmarksInBackground (bookmarks)
  • browser.search.context.loadInBackground
Note that browser.tabs.loadBookmarksInTabs only applies to open a bookmark. There is a similar pref named browser.search.openintab for opening search results when you use the separate search bar on the Navigation Toolbar. There are some prefs, accessible via the about:config page, to control focus if you click a link (open link in background or foreground). You can toggle the default action by holding the Shift key down when you left-click or middle-click a link. * browser.tabs.loadInBackground (normal links) * browser.tabs.loadDivertedInBackground (javascript and external links) * browser.tabs.loadBookmarksInBackground (bookmarks) * browser.search.context.loadInBackground
Bài viết này có hữu ích với bạn không?
Trích dẫn
Engku Hasmizan 0 giải pháp 3 câu trả lời
Được đăng

Ok.Thanks you.

Ok.Thanks you.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.