X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

As of 73.0 (for Mac at least) I can't press the Clear Now button in the "Clear Recent History..." dialog box with the return key.

Được đăng

After bringing up the "Clear Recent History..." dialog box, I always used to hit return to press the Clear Now button, but now that I've updated to 73.0, it doesn't accept the return key to dismiss it.

After bringing up the "Clear Recent History..." dialog box, I always used to hit return to press the Clear Now button, but now that I've updated to 73.0, it doesn't accept the return key to dismiss it.

Giải pháp được chọn

Firefox normally shows a focus ring around the currently selected element. Are you able to tab through all check boxes and buttons because on Mac tab focus might behave differently.

You can check this pref on the about:config page and possibly modify its value.

  • accessibility.tabfocus = 7

See also:

  • System Preferences -> ”Use keyboard navigation to move focus between controls” (Full Keyboard Access)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Đọc câu trả lời này trong ngữ cảnh 1
Trích dẫn

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:73.0) Gecko/20100101 Firefox/73.0

Thông tin chi tiết

cor-el
  • Top 10 Contributor
  • Moderator
17865 giải pháp 161655 câu trả lời
Được đăng

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"
Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History). *https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history *https://support.mozilla.org/en-US/kb/common-myths-about-private-browsing *Options/Preferences -> Privacy & Security<br>Firefox will: "Use custom settings for history" *remove checkmark: [ ] "Always use Private Browsing mode"
Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

Thanks for the response, but that's not the case. I don't have "Always use Private Browsing mode" turned on, and as I wrote, it was working fine for years until I did the 73.0 update this morning.

Thanks for the response, but that's not the case. I don't have "Always use Private Browsing mode" turned on, and as I wrote, it was working fine for years until I did the 73.0 update this morning.
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17865 giải pháp 161655 câu trả lời
Được đăng

Câu trả lời hữu ích

Can you set focus to that button (e.g. via the Tab key) as that would be required to be able to activate the Clear Now button via Enter or Space ?

Does this work if you click the button with the mouse ?

Can you set focus to that button (e.g. via the Tab key) as that would be required to be able to activate the Clear Now button via Enter or Space ? Does this work if you click the button with the mouse ?
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

There's no focus control (I tabbed a bunch and saw no visual change, plus I did tab-return tab-return tab-return a lot as well just to be sure it's not happening without any kind of indication, to no avail.)

On the Mac, a blue button has always indicated it's the focus (see attached), and hitting return always presses a blue button until now.

There's no focus control (I tabbed a bunch and saw no visual change, plus I did tab-return tab-return tab-return a lot as well just to be sure it's not happening without any kind of indication, to no avail.) On the Mac, a blue button has always indicated it's the focus (see attached), and hitting return always presses a blue button until now.
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17865 giải pháp 161655 câu trả lời
Được đăng

Giải pháp được chọn

Firefox normally shows a focus ring around the currently selected element. Are you able to tab through all check boxes and buttons because on Mac tab focus might behave differently.

You can check this pref on the about:config page and possibly modify its value.

  • accessibility.tabfocus = 7

See also:

  • System Preferences -> ”Use keyboard navigation to move focus between controls” (Full Keyboard Access)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Firefox normally shows a focus ring around the currently selected element. Are you able to tab through all check boxes and buttons because on Mac tab focus might behave differently. You can check this pref on the <b>about:config</b> page and possibly modify its value. *accessibility.tabfocus = 7 See also: *System Preferences -> ”Use keyboard navigation to move focus between controls” (Full Keyboard Access) You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

Thanks – the config change worked. Not really sure why it had stopped working once I updated to 73.0, but this seems to have fixed it. Oddly, the focus is not on the Clear Now button (see below) but hitting the return key still presses the button.

Thanks – the config change worked. Not really sure why it had stopped working once I updated to 73.0, but this seems to have fixed it. Oddly, the focus is not on the Clear Now button (see below) but hitting the return key still presses the button.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.