X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox is filling in a form field incorrectly

Được đăng

When I go to a particular online forum and reply to a post, some of the form that appears, is automatically filled out. One of the fields copies the Re: filed from the post I am responding to. That information appears correctly for about a second and then it is replaced by wording that was used by me in this field long ago and it is incorrect. If I delete it, put my cursor into that field and press the down button I see the offending entry, I highlight it and then delete it. However, it appears again the next time I answer a post. This problem occurs only in Firefox, not in other browsers. I am using Windows 10 64 bit.

When I go to a particular online forum and reply to a post, some of the form that appears, is automatically filled out. One of the fields copies the Re: filed from the post I am responding to. That information appears correctly for about a second and then it is replaced by wording that was used by me in this field long ago and it is incorrect. If I delete it, put my cursor into that field and press the down button I see the offending entry, I highlight it and then delete it. However, it appears again the next time I answer a post. This problem occurs only in Firefox, not in other browsers. I am using Windows 10 64 bit.

Giải pháp được chọn

It almost sounds like a write permissions issue. Are your new form entries ever saved?

You can try moving or renaming formhistory.sqlite in the root of your profile folder. You can see if the issue persists after a new one is created. Easy way to your profile is to enter in the address bar about:profiles or about:support and use the buttons to open your profile directory.

You might also try starting Firefox in its Safe Mode: Menu → Restart with Add-ons Disabled

In the event we don't find a solution soon, an extension i used to love is https://addons.mozilla.org/en-US/firefox/addon/form-history-control/ which, since the new extensions API, keeps an entirely separate form database which will not alter the native FF form history. It also gives you a lot more options and flexibility.

If you are very adventurous, you can always mount your formhistory.sqlite (or a copy) in DB Browser for SQLite (or portable) and see what is happening or manually remove an offending entry.

Đọc câu trả lời này trong ngữ cảnh 1
Trích dẫn

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

Thông tin chi tiết

crankygoat
  • Top 25 Contributor
40 giải pháp 471 câu trả lời
Được đăng

Giải pháp được chọn

It almost sounds like a write permissions issue. Are your new form entries ever saved?

You can try moving or renaming formhistory.sqlite in the root of your profile folder. You can see if the issue persists after a new one is created. Easy way to your profile is to enter in the address bar about:profiles or about:support and use the buttons to open your profile directory.

You might also try starting Firefox in its Safe Mode: Menu → Restart with Add-ons Disabled

In the event we don't find a solution soon, an extension i used to love is https://addons.mozilla.org/en-US/firefox/addon/form-history-control/ which, since the new extensions API, keeps an entirely separate form database which will not alter the native FF form history. It also gives you a lot more options and flexibility.

If you are very adventurous, you can always mount your formhistory.sqlite (or a copy) in DB Browser for SQLite (or portable) and see what is happening or manually remove an offending entry.

It almost sounds like a write permissions issue. Are your new form entries ever saved? You can try moving or renaming formhistory.sqlite in the root of your profile folder. You can see if the issue persists after a new one is created. Easy way to your profile is to enter in the address bar about:profiles or about:support and use the buttons to open your profile directory. You might also try starting Firefox in its Safe Mode: Menu → Restart with Add-ons Disabled In the event we don't find a solution soon, an extension i used to love is https://addons.mozilla.org/en-US/firefox/addon/form-history-control/ which, since the new extensions API, keeps an entirely separate form database which will not alter the native FF form history. It also gives you a lot more options and flexibility. If you are very adventurous, you can always mount your formhistory.sqlite (or a copy) in DB Browser for SQLite (or portable) and see what is happening or manually remove an offending entry.
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

Thanks for your help crankygoat. When I used safe mode the problem didn't occur so I disabled addons one by one and found that LastPass was the issue.

Thanks for your help crankygoat. When I used safe mode the problem didn't occur so I disabled addons one by one and found that LastPass was the issue.
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
590 giải pháp 5672 câu trả lời
Được đăng

hockey31 said

Thanks for your help crankygoat. When I used safe mode the problem didn't occur so I disabled addons one by one and found that LastPass was the issue.

Hello hockey31,

Would you be so kind as to mark "crankygoat's" post as Chosen Solution ?

It's the "Solved the problem" button to the right of his post.

Thank you in advance !

''hockey31 [[#answer-1281229|said]]'' <blockquote> Thanks for your help crankygoat. When I used safe mode the problem didn't occur so I disabled addons one by one and found that LastPass was the issue. </blockquote> Hello hockey31, Would you be so kind as to mark "crankygoat's" post as Chosen Solution ? It's the "Solved the problem" button to the right of his post. Thank you in advance !
Bài viết này có hữu ích với bạn không?
Trích dẫn
crankygoat
  • Top 25 Contributor
40 giải pháp 471 câu trả lời
Được đăng

Ah, you might be able to edit it using whatever functions LastPass provides. It may keep it's own database and not hook into Firefox's. (I don't even know if applications and extensions can do that anymore.)

Ah, you might be able to edit it using whatever functions LastPass provides. It may keep it's own database and not hook into Firefox's. (I don't even know if applications and extensions can do that anymore.)
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

When I found that LastPass was the issue, I went to their forum and found that my issue was being experienced by others and so LastPass patched it in October of 2019. My version, for some reason, was older. Automatic update is supposed to be the default. So, once I updated the problem went away.

Thanks for your help crankygoat.

When I found that LastPass was the issue, I went to their forum and found that my issue was being experienced by others and so LastPass patched it in October of 2019. My version, for some reason, was older. Automatic update is supposed to be the default. So, once I updated the problem went away. Thanks for your help crankygoat.
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
590 giải pháp 5672 câu trả lời
Được đăng

@ hockey31 :

I noticed that you marked your own post as Chosen Solution instead of "crankygoat's" post ...... (?)

In case you want to rectify it : You can click on the "Undo" button to the right of your post and then mark "crankygoat's" post (the one that suggested Safe Mode).

@ hockey31 : I noticed that you marked your own post as Chosen Solution instead of "crankygoat's" post ...... (?) In case you want to rectify it : You can click on the "Undo" button to the right of your post and then mark "crankygoat's" post (the one that suggested Safe Mode).
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.