Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Chủ đề này đã đóng và được lưu lại. Vui lòng hỏi một câu hỏi mới nếu bạn cần giúp đỡ.

Unable to change Japanese font, changes in "Languages and Appearance" not reflected.

  • 3 trả lời
  • 3 gặp vấn đề này
  • 503 lượt xem
  • Trả lời mới nhất được viết bởi tkg670

more options

Hello,

I noticed a few hours ago that my Google search in Japanese was now displayed in an ugly font I have no memory of (could not identify it, attached a screenshot just in case).

I tried to change my settings for Japanese in Languages and Appearance, but no matter what, this unknown font remains the apparent default on sites such as SUMO and google.com.

I just refreshed Firefox to no avail.

Am I not looking in the right place?

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (3)

more options

Giải pháp được chọn

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

more options

Thanks a bunch! I did not know about the Font tab in the Inspector. That allowed me to identify that weird font as Microsoft YaHei, a Chinese language font; no wonder it looked so off.

The next thing that intrigued me is that YaHei was set as the Sans-serif font for simplified Chinese, not Japanese; a bit of testing confirmed it was the parameter used to render the text I was looking at.

Turns out I needed to add Japanese to the list of "Choose your preferred language for displaying pages", which initially only contained English. the parameters for the Japanese language were then properly reflected. I guess Firefox defaulted to simplified Chinese to render Japanese text then.

Mystery solved, thank you very much!

more options

Hey guys I was having the same problem as MattP and found this thread. I still can't get to fix mine though.

So I used the Chosen Solution's method to find out which font is messing up. Then I used MattP's method of adding Korean(the font im having trouble with) to the list of "Choose your preferred language for displaying pages", but nothing would change.

What should I do now? How can I change the font or the parameter used for rendering?

PS - even the texts on the Tabs are displayed with the same ugly font.