X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Some fonts not displaying correctly

Được đăng

Hi all,

On some sites (I think it has something to do possibly with code snippets because these always display incorrectly) Firefox is showing this illegible font as per the screenshot. I've also attached a Chrome screenshot to show how it should be displaying. I have not been able to find a fix online for this. I have done the suggestions of clearing cache, checking font settings etc that I could find in the options, but made no difference. Please could anyone help? It's driving me mad because I can't make out the font at all!

Michael.

Hi all, On some sites (I think it has something to do possibly with code snippets because these always display incorrectly) Firefox is showing this illegible font as per the screenshot. I've also attached a Chrome screenshot to show how it should be displaying. I have not been able to find a fix online for this. I have done the suggestions of clearing cache, checking font settings etc that I could find in the options, but made no difference. Please could anyone help? It's driving me mad because I can't make out the font at all! Michael.
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

OK after deleting a couple of hundred fonts and still not getting anywhere, I finally waxed it by deleting the courier new (which looks like it was corrupted), downloading a fresh version of courier new, installing, deleting cache and restarting firefox..... And it's back and I can read it..... Man, that was a mission and a few hours of my life that I won't be getting back again ;)

Đọc câu trả lời này trong ngữ cảnh 0
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 32.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

Thông tin chi tiết

FredMcD
  • Top 10 Contributor
4344 giải pháp 61095 câu trả lời
Được đăng

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1 ------------- Many site issues can be caused by corrupt cookies or cache. '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}
Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

Hi Fred, all those settings you suggest are already in place and cache has been cleared. Yet the fonts still look bizarre as per the previous screenshots.

Hi Fred, all those settings you suggest are already in place and cache has been cleared. Yet the fonts still look bizarre as per the previous screenshots.
Bài viết này có hữu ích với bạn không?
Trích dẫn
FredMcD
  • Top 10 Contributor
4344 giải pháp 61095 câu trả lời
Được đăng

I called for more help.

Please provide a public link (no password) that we can check out. No Personal Information Please !

I called for more help. Please provide a public link (no password) that we can check out. '''No Personal Information Please ! '''
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17774 giải pháp 160790 câu trả lời
Được đăng

This looks like there is some monospace font being used for these elements.

What font does the font Inspector show for this element ?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

This looks like there is some monospace font being used for these elements. What font does the font Inspector show for this element ? You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/Examine_and_edit_HTML You can check in the <b>Rules</b> tab in the right panel in the Inspector what font-family is used for selected text. You can check in the <b>Font</b> tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/Edit_fonts
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17774 giải pháp 160790 câu trả lời
Được đăng

I checked the website and they use font-family: Courier, monospace; for CODE and PRE tags. That is likely causing this problem. You can remove the quite old Courier font from the Windows Fonts folder (i.e. uninstall this specific Courier font, you can leave Courier New) to prevent Firefox from using this font and take a better looking monospace font instead.

I checked the website and they use <b>font-family: Courier, monospace;</b> for CODE and PRE tags. That is likely causing this problem. You can remove the quite old Courier font from the Windows Fonts folder (i.e. uninstall this specific Courier font, you can leave Courier New) to prevent Firefox from using this font and take a better looking monospace font instead.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Hi Cor-el, thank you for your reply. It's odd because a few days ago the same site was displaying the fonts perfectly on Firefox as per Chrome. If I delete the Courier font then it will remove it across the board, which seems like the wrong way to go since the font is displaying fine in Chrome and Opera. There must be something going pete tong inside Firefox?

Hi Cor-el, thank you for your reply. It's odd because a few days ago the same site was displaying the fonts perfectly on Firefox as per Chrome. If I delete the Courier font then it will remove it across the board, which seems like the wrong way to go since the font is displaying fine in Chrome and Opera. There must be something going pete tong inside Firefox?
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Weirdly I've just inspected the same site in Chrome and it serves up:

font-family: "Lucida Grande" , "Lucida Sans Unicode" , Verdana, Tahoma, Arial, sans-serif;

Weirdly I've just inspected the same site in Chrome and it serves up: font-family: "Lucida Grande" , "Lucida Sans Unicode" , Verdana, Tahoma, Arial, sans-serif;
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

And I can't find any monospace font in my windows font folder!

And I can't find any monospace font in my windows font folder!
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17774 giải pháp 160790 câu trả lời
Được đăng

Did you verify that Firefox is using this Courier font ?

You may have accidentally zoomed web page(s). Reset the page zoom on pages that cause problems.

  • View -> Zoom -> Reset (Ctrl+0/Command+0 (zero))

Does it make a difference if you enable hardware acceleration ?

Did you verify that Firefox is using this Courier font ? You may have accidentally zoomed web page(s). Reset the page zoom on pages that cause problems. *<b>View -> Zoom -> Reset</b> (Ctrl+0/Command+0 (zero)) *https://support.mozilla.org/en-US/kb/how-do-i-use-zoom Does it make a difference if you enable hardware acceleration ?
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Hi Cor-el, the zoom reset makes no difference. Nor does enabling hardware acceleration. Do I need to restart the browser after enabling?

Hi Cor-el, the zoom reset makes no difference. Nor does enabling hardware acceleration. Do I need to restart the browser after enabling?
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17774 giải pháp 160790 câu trả lời
Được đăng

The font information you posted above is used for normal text on the website. The monospace font is used for content in <pre> and <code> tags.

The font information you posted above is used for normal text on the website. The monospace font is used for content in &lt;pre&gt; and &lt;code&gt; tags.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Giải pháp được chọn

OK after deleting a couple of hundred fonts and still not getting anywhere, I finally waxed it by deleting the courier new (which looks like it was corrupted), downloading a fresh version of courier new, installing, deleting cache and restarting firefox..... And it's back and I can read it..... Man, that was a mission and a few hours of my life that I won't be getting back again ;)

OK after deleting a couple of hundred fonts and still not getting anywhere, I finally waxed it by deleting the courier new (which looks like it was corrupted), downloading a fresh version of courier new, installing, deleting cache and restarting firefox..... And it's back and I can read it..... Man, that was a mission and a few hours of my life that I won't be getting back again ;)
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.