X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Why can't omn.ja be deleted so the one-click search is disabled?

Được đăng

When I type an existing bookmark into the address line I no longer see it pop up immediately. Rather I see whatever the one-click search engine chooses. I want to be able to type a few characters and get my bookmark without having to select it from the options provided.

When I type an existing bookmark into the address line I no longer see it pop up immediately. Rather I see whatever the one-click search engine chooses. I want to be able to type a few characters and get my bookmark without having to select it from the options provided.

Giải pháp được chọn

You can force bookmark results by starting with a '*' and a space.

You can possibly use code in userChrome.css to hide the first visit line in the drop-down.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#urlbar-results #urlbarView-row-0 {display:none !important}

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

Đọc câu trả lời này trong ngữ cảnh 0
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 32.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

Thông tin chi tiết

evhenry
  • Top 25 Contributor
  • Administrator
32 giải pháp 178 câu trả lời
Được đăng

You would have to name your bookmarks as keywords. The closest you can get to this functionality (hiding the search with options) is going to about:Config and setting

  • keyword.enabled to false
  • browser.fixup.alternate.enabled to false

but even if you name your bookmarks as keywords (say you named youtube subscriptions to "yout" you'll still have to arrow down before hitting enter.

Unless I'm misunderstanding the behavior you're seeking?

You would have to name your bookmarks as keywords. The closest you can get to this functionality (hiding the search with options) is going to about:Config and setting * keyword.enabled to false * browser.fixup.alternate.enabled to false but even if you name your bookmarks as keywords (say you named youtube subscriptions to "yout" you'll still have to arrow down before hitting enter. Unless I'm misunderstanding the behavior you're seeking?
Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

Thank you for your response, but I have some bookmarks saved as the full URL, for example, en.wikipeda.org. Prevously, that is until the latest update, if I type en. the full URL populated the address bar.

Thank you for your response, but I have some bookmarks saved as the full URL, for example, en.wikipeda.org. Prevously, that is until the latest update, if I type en. the full URL populated the address bar.
Bài viết này có hữu ích với bạn không?
Trích dẫn
evhenry
  • Top 25 Contributor
  • Administrator
32 giải pháp 178 câu trả lời
Được đăng

Câu trả lời hữu ích

I believe as you continue to use your bookmarks it'll populate the full URL like you want it to, a setting might've changed slightly with this update. I might be misremembering something I looked at earlier though

I believe as you continue to use your bookmarks it'll populate the full URL like you want it to, a setting might've changed slightly with this update. I might be misremembering something I looked at earlier though
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17671 giải pháp 159861 câu trả lời
Được đăng

Giải pháp được chọn

You can force bookmark results by starting with a '*' and a space.

You can possibly use code in userChrome.css to hide the first visit line in the drop-down.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#urlbar-results #urlbarView-row-0 {display:none !important}

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

You can force bookmark results by starting with a '*' and a space. *https://support.mozilla.org/en-US/kb/address-bar-autocomplete-firefox You can possibly use code in userChrome.css to hide the first visit line in the drop-down. Add code to the <b>userChrome.css</b> file below the default @namespace line. <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #urlbar-results #urlbarView-row-0 {display:none !important} </nowiki></pre> ---- *https://www.userchrome.org/what-is-userchrome-css.html *https://www.userchrome.org/how-create-userchrome-css.html In Firefox 69 and later you need to set this pref to true on the <b>about:config</b> page to enable userChrome.css and userContent.css in the chrome folder. *toolkit.legacyUserProfileCustomizations.stylesheets = true *https://www.userchrome.org/firefox-changes-userchrome-css.html
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.