X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

When I upload an image, Firefox does not show jpg in Windows Explorer dialogue

Được đăng

When a web interface offers image upload options, Firefox 70.0.1 on Windows 10 does not offer up any regular jpg or jpeg file extensions. All I get by default is that weird jfif format, together with png. What's that all about, and how can I fix it?

Image uploads work fine if I choose to display "all files", but something's amiss with the filtering there.

On a related note, Firefox used to save regular jpg images in its own Save Image As dialogue as jfif files too. I had to teach it to do this in jpg instead. Might be a related issue?

When a web interface offers image upload options, Firefox 70.0.1 on Windows 10 does not offer up any regular jpg or jpeg file extensions. All I get by default is that weird jfif format, together with png. What's that all about, and how can I fix it? Image uploads work fine if I choose to display "all files", but something's amiss with the filtering there. On a related note, Firefox used to save regular jpg images in its own Save Image As dialogue as jfif files too. I had to teach it to do this in jpg instead. Might be a related issue?
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Did you search the MIME database entry for content-type image/jpeg to check what file extension is set there like I posted above and that is also mentioned in the article you linked ?

  • HKEY_CLASSES_ROOT\MIME\Database\Content Type\
Đọc câu trả lời này trong ngữ cảnh 1
Trích dẫn

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Thông tin chi tiết

cor-el
  • Top 10 Contributor
  • Moderator
17582 giải pháp 159077 câu trả lời
Được đăng

Câu trả lời hữu ích

This could be a problem with the Windows Registry.

You can inspect the MIME database key with the registry editor (regedit.exe) and do a search for that MIME type (file extension) via Ctrl+F. Be cautious with editing the registry as there is NO UNDO possible: all changes are applied immediately. You can export key(s) in the registry editor before making changes. You can check specific file extension keys (e.g. .jpg) in the registry with the registry editor.

  • HKEY_CLASSES_ROOT\.xxx

You can check a possibly linked MIME type in the MIME Database registry key.

  • HKEY_CLASSES_ROOT\MIME\Database\Content Type\
This could be a problem with the Windows Registry. You can inspect the MIME database key with the registry editor (regedit.exe) and do a search for that MIME type (file extension) via Ctrl+F. Be cautious with editing the registry as there is NO UNDO possible: all changes are applied immediately. You can export key(s) in the registry editor before making changes. You can check specific file extension keys (e.g. .jpg) in the registry with the registry editor. * HKEY_CLASSES_ROOT\.xxx You can check a possibly linked MIME type in the MIME Database registry key. * HKEY_CLASSES_ROOT\MIME\Database\Content Type\
Bài viết này có hữu ích với bạn không? 2
Trích dẫn

Người tạo câu hỏi

Thanks co-rel, I've had a look at the registry editor, but I don't know enough about it. There is an entry for .jpg and another one for .jpeg, and the entries look the same for .jfif. I'm assuming that's set correctly, since Windows itself recognizes .jpg files as images and opens the appropriate tool. So does Internet Exploder.

Firefox however does not, so I'm wondering if the problem lies with it, rather than Windows. Please check the attached image and let me know if the entry I have for .jpg is correctly associated.

The only time I've played with it was when I setup Firefox to never save images as .jfif. Lucky for us I took some notes on how I did it here: https://wpguru.co.uk/2019/06/how-to-switch-from-jfif-to-jpeg-on-drag-and-drop-in-windows-10/

Thanks co-rel, I've had a look at the registry editor, but I don't know enough about it. There is an entry for .jpg and another one for .jpeg, and the entries look the same for .jfif. I'm assuming that's set correctly, since Windows itself recognizes .jpg files as images and opens the appropriate tool. So does Internet Exploder. Firefox however does not, so I'm wondering if the problem lies with it, rather than Windows. Please check the attached image and let me know if the entry I have for .jpg is correctly associated. The only time I've played with it was when I setup Firefox to never save images as .jfif. Lucky for us I took some notes on how I did it here: https://wpguru.co.uk/2019/06/how-to-switch-from-jfif-to-jpeg-on-drag-and-drop-in-windows-10/
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17582 giải pháp 159077 câu trả lời
Được đăng

Giải pháp được chọn

Did you search the MIME database entry for content-type image/jpeg to check what file extension is set there like I posted above and that is also mentioned in the article you linked ?

  • HKEY_CLASSES_ROOT\MIME\Database\Content Type\
Did you search the MIME database entry for content-type image/jpeg to check what file extension is set there like I posted above and that is also mentioned in the article you linked ? *HKEY_CLASSES_ROOT\MIME\Database\Content Type\
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

Sorry for the late reply, I've been living with the workaround to "show all file types" every time I had an upload to make, but they're plentiful and it got me depressed every time I did it. Thinking of your answer, I was brave enough to hunt for that key tonight, and to my surprise the image/jpeg file type was indeed associated with .jfif!

I duly corrected this, and now Firefox works just as I would expect it. Thank you so much for pointing me in the right direction!

Sorry for the late reply, I've been living with the workaround to "show all file types" every time I had an upload to make, but they're plentiful and it got me depressed every time I did it. Thinking of your answer, I was brave enough to hunt for that key tonight, and to my surprise the image/jpeg file type was indeed associated with .jfif! I duly corrected this, and now Firefox works just as I would expect it. Thank you so much for pointing me in the right direction!
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17582 giải pháp 159077 câu trả lời
Được đăng

You're welcome. Thanks for reporting back that this was an issue with the MIME database.

You're welcome. Thanks for reporting back that this was an issue with the MIME database.
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
vviktur 0 giải pháp 9 câu trả lời
Được đăng

Thanks for you reply...I am not comfortable with going into the registry. did so once before and ended up having to restore my computer.

Thanks for you reply...I am not comfortable with going into the registry. did so once before and ended up having to restore my computer.
Bài viết này có hữu ích với bạn không?
Trích dẫn
JoliePrincesskatana 0 giải pháp 1 câu trả lời
Được đăng

I had same issue.. only in Firefox (not Edge) this is the correct solution. HKEY_CLASSES_ROOT\MIME\Database\Content Type\ JPEG was set to .jfif. I changed it to .jpeg. Solution worked..Thanks

I had same issue.. only in Firefox (not Edge) this is the correct solution. HKEY_CLASSES_ROOT\MIME\Database\Content Type\ JPEG was set to .jfif. I changed it to .jpeg. Solution worked..Thanks
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.