Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Installed English Firefox, set language to English, right click options and "abrir menu" are still NOT in English, how do I get Firefox to be in English?

  • 12 trả lời
  • 1 gặp vấn đề này
  • 45 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I'm in Spain. Still learning Spanish. I have told Firefox to be in English. When I right click to open in a new page, everything is Spanish. When I click to download something, Spanish. It's like half and half. Seems like a glitch or error. Maybe there is no fix, because I've done virtually everything I've seen mentioned. Just installed what I thought was English Firefox, then re-downloaded AGAIN and I've still got Spanish in my menus and other areas. In the side menu I see "privacy protections", but everything below is Spanish. On the top menu, History is English, but Bookmarks says "anadir esta pagina a marcadores", then below that things are English.

Help?!?\

Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (12)

more options

When you go to the about:support page in Firefox and scroll to the very bottom in the Internationalization & Localization section (although I suppose it may not be English for you), take a screenshot of that table.

I've posted a screenshot of what mine looks like so that you can get a rough idea of what you are looking for, in case the menu isn't English.

NOTE: Firefox Screenshots doesn't work on this page, so you will need to take the screenshot using your operating system's screenshot tool.
more options

There are three English locales of desktop Firefox (US, British, and Canadian) at https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

If you downloaded Firefox at say www.mozilla.org then you may get a locale based on your location.

Được chỉnh sửa bởi James vào

more options

If I go to Firefox>about there is no option for a support page. It's all in English and says I'm up to date.

I tried the link above and I've definitely downloaded the app in English. But not all menus are in English. The main Firefox menu is Spanish, but all the others are English. My preferences tab is in Spanish, and when I click to download anything it's in Spanish.

When I click "preferencias" I'm taken to a page in English, where the option under "Language and Appearance" has English selected. But this seems to have no effect on the main Firefox menu, download options, and preference tab.

more options

Hello serfiss,

Would you please take a look at this bug report; especially the last three comments :

https://bugzilla.mozilla.org/show_bug.cgi?id=1564998

Maybe this will work for you too - worth a try .....

more options

Right click options are also in Spanish... Considering I've downloaded a new copy and reinstalled (it was set to English) and set my prefs to English I'm at a loss. This seems to be a glitch.

more options

^thanks for that tip, I do see a languages thing in add-ons, but no way to manually update, and not sure how to run that purge cache command on a Mac.

more options

serfiss said

^thanks for that tip, I do see a languages thing in add-ons, but no way to manually update,

If it is a language pack : does it have three horizontal dots in the right upper corner ? If so, please click on it - you should be able to find an option to manually update it ("Manage").

and not sure how to run that purge cache command on a Mac.

I'm a Windows person - haven't been able to find how to do that on Mac; I'm hoping someone else will come to your rescue ......

Maybe you can find something useful in these search results ......  ?

more options

I clicked manage, disabled and re-enabled. Didn't seem to do anything. I've just asked some IT nerd friends if they'd be willing to download the US installer and send it to me. maybe pirate bay has it. the only thing I can think it that I'm being flagged by my region and Mozilla doesn't know that there are native English speakers living in Spain

more options

serfiss said

I clicked manage, disabled and re-enabled. Didn't seem to do anything.

It should show you when the language pack was last updated (?)

I've just asked some IT nerd friends if they'd be willing to download the US installer and send it to me. maybe pirate bay has it.

Now you've lost me .... You said that you have installed the English version - you may have misconstrued Wesley Branton's post about typing in the address bar about:support and then scroll all the way down; it should show that you have indeed downloaded Firefox en-US version, using the first link, mentioned in James' post.



When you disabled that language pack (and then closed and restarted Firefox); that didn't make a difference ?

I'm asking, because that language pack just might be the culprit; there are several Spanish language packs - maybe you could try a different one ? (just a stab in the dark)

(edit : typo ... )

Được chỉnh sửa bởi McCoy vào

more options

You can check all installed language packs under on "about:addons -> Languages" and make sure they have been updated to the current release.

This can be caused by not refreshing data in the startup caches. Start Firefox once with the -purgecaches command line switch (make sure that Firefox is closed).

more options

It sounds like the same general area. I'm English living in Greece and using a Windwos 10 Lenovo PC bought in Greece. Everything comes up in English apart from Firefox, which is smack bang up to date.Despite going through all the options umpteen times, Firefox still comes up in Greek.

more options

You can find the full version of the current Firefox release (71.0) in all languages and all operating systems here: