Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Don't save new autofill addresses

  • 7 trả lời
  • 2 gặp vấn đề này
  • 24 lượt xem
  • Trả lời mới nhất được viết bởi Bentrepp

more options

I want Firefox to autofill my saved addresses, but I don't want it to automatically save new addresses.

I fill in all kinds of forms, with variations of my name, address, etc., and with other people's info. Firefox saves those variations and autofill becomes effectively unreliable, filled with dozens of erroneous entries, until I manually delete all but the three I want to keep.

It seems silly that there is one checkbox to control both the saving and the filling. Can we get a sub-setting where I can uncheck “save new addresses that I enter”? Or is there an about:config option for it?

Tất cả các câu trả lời (7)

more options

Use this setting to add, remove or change saved addresses in Firefox.

  1. Click the menu button and select Options.
  2.Click the Privacy & Security panel and scroll down to the Forms and                          Autofill section.
  3. Click the Saved Addresses… button.
  4.Choose one of the following: ...
  5. Click the x to save your changes and close the window.
more options

Thanks for replying, but I already do that often, and now I'm specifically asking for a way to not have to do that.

more options

Open Firefox. Click the Menu button. Click Preferences. Click Privacy & Security. Scroll down to Forms And Autofill. Click Saved Addresses. Select an address to delete and click Remove (Figure A).

If you want to edit an address, select the address and click Edit. In the address edit window (Figure B), edit the address accordingly. Once you've finished editing, click Save and you're done. How to disable Autofill

If you've inadvertently enabled Autofill and would rather not allow Firefox to store those addresses, delete them all from the Autofill Address window, close the window, and then uncheck the box for Forms And Autofill (Figure C).

more options

Thanks, but again, that's not what I'm asking.

I do want to fill forms with the existing saved addresses. I do not want to save any new addresses.

more options

I have this problem too.

I fill out a poorly designed job application with multiple sets of addresses, names, contact information and organizations to fill in. Firefox mistakenly puts some fields in the wrong box. Then I correct it. Then Firefox saves a new address with the corrections I made as if they are intended to go together and puts them together on better designed forms.

For example it puts the name of reference 1 in the box for reference 2, but puts the phone number of reference 1 and company in the correct box. Then Firefox saves the name of reference 2 in an address and company of reference 1.

On another thought, developers should work on a better auto fill from job applications, that can answer a few additional common questions and combines all my references and job information together. As someone actively searching for a job I spend over an hour a day putting standardized answers into standardized application forms.

more options

I agree that web developers could do a better job when they create online forms; poorly designed is the keyword there. Firefox does the best that it can when online forms don't follow the established W3C standards correctly. https://www.w3.org/WAI/tutorials/forms/

When I run into a situation like that I create a text file with the form 'answers' that I would need to submit on separate lines. Then I copy'n'paste the 'answers' one at a time from my text file into the online form.

more options

Its pathetic, and these poorly designed forms are usually made by a big name business software firm. It really makes me thing poorly of firms like IBM, and Oracle that they put out this junk, when the little HR software startups can blow them away in user friendliness.