Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Even with "Override the colors specified by the page with your selections above"set to "Never" in the Colors option, pages have white text on a white background

  • 11 trả lời
  • 1 gặp vấn đề này
  • 69 lượt xem
  • Trả lời mới nhất được viết bởi mozilla6

more options

When using a High Contrast Theme in Windows 10, some pages display white text on a white background. Even after setting "Override the colors specified by the page with your selections above" to "Never" in firefox's Options, Firefox seems to still rely on the system theme's color for text. I verified this by changing my text color to something else and the page followed suit. It doesn't happen on every single website, but a large amount of them are affected.

In the attached picture, I have Firefox open on the left while Chrome is on the right to display what the page SHOULD look like. Clearly, Chrome is doing something different and not relying on the system's defined color when it comes to rendering text.

Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (11)

more options

Hi TheGershon, There was a change in version 70 where:

Aliased theme properties have been removed, which may affect some themes

see also: Upcoming deprecations in Firefox 70 https://blog.mozilla.org/addons/2019/07/25/upcoming-deprecations-in-firefox-70/

more options

I don't think that's the issue, because it happens with the built-in Light and Default themes as well.

more options

Well, that's one possibility ruled out.

The only other thing that I can think of is another change in version 70: "Built-in Firefox pages now follow the system dark mode preference"

It says "Built-in" pages but that doesn't mean that you didn't find a bug.

You can disable that in about:config by toggling browser.in-content.dark-mode to false


There is another thread open which appears similar but hasn't been responded to: Cannot change colour of unvisited links Firefox 70 https://support.mozilla.org/en-US/questions/1271162

more options

Unfortunately, that doesn't seem to be the case either. Changing that flag didn't seem to have any effect. The thread you linked does seem to be stemming from the same problem though. One thing I should mention is that this didn't just start happening when 70 came out, it's been like this for as long as I've been using High Contrast Mode (several months ago)

more options

You did check the default colors in "Options/Preferences -> General" ?

Some websites only specify one of the colors and assume a default for other colors, so if the website doesn't specify the text color but sets a background color then you can get white text if that is your default text color.

more options

Not sure exactly which option you mean, but in the Colors menu I do have it set to black text and white backgrounds (the default colors). If what you're saying is the case then I think it would be beneficial for FF to implement a forced default text color like Chrome seems to do.

more options

I was about to post a new issue: How to override website styling so that visited page links show as a different color. But this post led me to the answer: Firefox has an dropdown "Override the colors specified by the page..." I set that to "Always" and, presto!, problem solved for the troublesome website.

more options

Note that you lose background images sometimes used to style buttons when you disable website colors and it can be hard to notice such lost buttons, so use this with care.

more options

cor-el said

Note that you lose background images sometimes used to style buttons when you disable website colors and it can be hard to notice such lost buttons, so use this with care.

Yes, that was quite frustrating because almost every other site I tried to browse became un-viewable/unusable. Is there an about:config setting to enforce only the visited link color to be overridden? Or is there a way to get the override to apply only to a specific site?

more options

You can use code in userContent.css to override the visited color, but that can have the same effect because you set a fixed background-color to elements that override the background-image specified by the website. You would need to set the visited color without using the !important flag, but at least this works on websites that do not specify a background color.

You can set a box-shadow instead to overcome this limitation.

You can set CSS rules in userContent.css per domain or per web page URL.

Using userContent.css is similar to using userChrome.css, see:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

more options

Thank you @cor-el !