X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Why is Firefox not showing youtube thumbnails?

Được đăng

I'm on 70.0 and Firefox for some reason stopped showing youtube thumbnails. Other browsers show them perfectly fine but since Firefox is my main browser I would appreciate some help with this problem.

I'm on 70.0 and Firefox for some reason stopped showing youtube thumbnails. Other browsers show them perfectly fine but since Firefox is my main browser I would appreciate some help with this problem.
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Uninstalling Firefox, deleting all my local data for it from my computer, and then restarting and reloading everything fixed the problem. I'd still like to find out what caused this.

Đọc câu trả lời này trong ngữ cảnh 0
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 32.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Thông tin chi tiết

My_Cheese_Is_Slippin'
  • Top 10 Contributor
83 giải pháp 871 câu trả lời
Được đăng

Hi hugocoisas, In the version 70 Release Notes: "Social tracking protection, which blocks cross-site tracking cookies from sites like Facebook, Twitter, and LinkedIn, is now a standard feature of Enhanced Tracking Protection. "

You can use Custom Privacy & Protection settings instead.

Hi hugocoisas, In the version 70 Release Notes: "Social tracking protection, which blocks cross-site tracking cookies from sites like Facebook, Twitter, and LinkedIn, is now a standard feature of Enhanced Tracking Protection. " You can use Custom Privacy & Protection settings instead.
Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

I added youtube to all exceptions but the problem remains.

I added youtube to all exceptions but the problem remains.
Bài viết này có hữu ích với bạn không?
Trích dẫn
My_Cheese_Is_Slippin'
  • Top 10 Contributor
83 giải pháp 871 câu trả lời
Được đăng

hugocoisas, I have to apologize - I REALLY misunderstood your question.

Try turning off Enhanced Tracking Protection: select the Shield icon at the left end of the address bar and move the slider to the left. Refresh the page.

If that doesn't help: Try disabling your extensions. You may need to restart Firefox.

hugocoisas, I have to apologize - I REALLY misunderstood your question. Try turning off Enhanced Tracking Protection: select the Shield icon at the left end of the address bar and move the slider to the left. Refresh the page. If that doesn't help: Try disabling your extensions. You may need to restart Firefox.
Bài viết này có hữu ích với bạn không?
Trích dẫn
ngandhi 1 giải pháp 4 câu trả lời
Được đăng

I'm having this issue too. Disabling enhanced tracking protections has not solved the problem.

I'm having this issue too. Disabling enhanced tracking protections has not solved the problem.
Bài viết này có hữu ích với bạn không?
Trích dẫn
My_Cheese_Is_Slippin'
  • Top 10 Contributor
83 giải pháp 871 câu trả lời
Được đăng

You can try Clearing Cookies and Site Data for that site by clicking on the padlock at the left end of the address bar and selecting Clear Cookies and Site Data... Note that this will log you out. Then Refresh the page.

You can try Clearing Cookies and Site Data for that site by clicking on the padlock at the left end of the address bar and selecting Clear Cookies and Site Data... Note that this will log you out. Then Refresh the page.
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
ngandhi 1 giải pháp 4 câu trả lời
Được đăng

I've already tried that as well, and I cleared my entire cache and data for firefox. Didn't do anything

I've already tried that as well, and I cleared my entire cache and data for firefox. Didn't do anything
Bài viết này có hữu ích với bạn không?
Trích dẫn
My_Cheese_Is_Slippin'
  • Top 10 Contributor
83 giải pháp 871 câu trả lời
Được đăng

You can try Firefox in it's Safe Mode. Safe Mode temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes) that might be causing problems. See: Troubleshoot Firefox issues using Safe Mode https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

You can try Firefox in it's Safe Mode. Safe Mode temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes) that might be causing problems. See: Troubleshoot Firefox issues using Safe Mode https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
ngandhi 1 giải pháp 4 câu trả lời
Được đăng

Starting in safe mode did not fix the problem either.

Starting in safe mode did not fix the problem either.
Bài viết này có hữu ích với bạn không?
Trích dẫn
My_Cheese_Is_Slippin'
  • Top 10 Contributor
83 giải pháp 871 câu trả lời
Được đăng

You can try the suggestion in this thread:

Youtube is acting weird https://support.mozilla.org/en-US/questions/1173622

Otherwise, you might have to consider Refreshing Firefox:

Refresh Firefox - reset add-ons and settings https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

You can try the suggestion in this thread: Youtube is acting weird https://support.mozilla.org/en-US/questions/1173622 Otherwise, you might have to consider Refreshing Firefox: Refresh Firefox - reset add-ons and settings https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings
Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

Unfortunately none of these have really worked yet. It's so weird because a couple of days ago it worked fine and it still works on the other browsers.

I didn't change anything in regards to firefox and I only installed the update when I was already trying to fix this issue.

Unfortunately none of these have really worked yet. It's so weird because a couple of days ago it worked fine and it still works on the other browsers. I didn't change anything in regards to firefox and I only installed the update when I was already trying to fix this issue.
Bài viết này có hữu ích với bạn không?
Trích dẫn
My_Cheese_Is_Slippin'
  • Top 10 Contributor
83 giải pháp 871 câu trả lời
Được đăng

Well, hold off on the Refresh suggestion. Some people end up having serious problems with it.

Besides, it might be something easier. If someone else knows..

If you're familiar with Profiles, you can create a new Profile to test with. That might give a better idea where the problem is.

Well, hold off on the Refresh suggestion. Some people end up having serious problems with it. Besides, it might be something easier. If someone else knows.. If you're familiar with Profiles, you can create a new Profile to test with. That might give a better idea where the problem is.
Bài viết này có hữu ích với bạn không?
Trích dẫn
ngandhi 1 giải pháp 4 câu trả lời
Được đăng

Giải pháp được chọn

Uninstalling Firefox, deleting all my local data for it from my computer, and then restarting and reloading everything fixed the problem. I'd still like to find out what caused this.

Uninstalling Firefox, deleting all my local data for it from my computer, and then restarting and reloading everything fixed the problem. I'd still like to find out what caused this.
Bài viết này có hữu ích với bạn không?
Trích dẫn
My_Cheese_Is_Slippin'
  • Top 10 Contributor
83 giải pháp 871 câu trả lời
Được đăng

So would I but, it's too late now. What else is weird is that I have Strict Content Blocking and other extensions at work - I'm even blocking youtube.com - and Youtube works fine for me. Go figure, huh.

Anyway, I'm glad that you got it working. Don't stay up too late binge-watching.

Browse Safe!

So would I but, it's too late now. What else is weird is that I have Strict Content Blocking and other extensions at work - I'm even blocking youtube.com - and Youtube works fine for me. Go figure, huh. Anyway, I'm glad that you got it working. Don't stay up too late binge-watching. Browse Safe!
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Yes! Uninstalling did the trick. Thank you all for the sugestions and for helping me solve this annoying problem.

Yes! Uninstalling did the trick. Thank you all for the sugestions and for helping me solve this annoying problem.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Agent 0 giải pháp 1 câu trả lời
Được đăng

Câu trả lời hữu ích

I've also been having this problem too. It only occurred very recently.

I've tried all sorts: Plugins, safe mode, Pi-hole config / disabling, DNS flushing, checking the inspector for hints....and then I realised that YouTube was serving webp for these thumbnails and I'd changed a setting that might be causing this.

In short, I didn't like that saving an imagine from Firefox was a webp a while back. I couldn't send them on WhatsApp via a browser as the format was unsupported.

I'd changed 2 settings in about:config

image.webp.enabled was set to false (default true) image.http.accept was set to "*/*" where the default was "image/webp,*/*" - all without the quotes

As soon as I changed these back, they instantly started working. I suspect a reinstall resets these, hence why that fixes it. I didn't realise that safe mode didn't change these values back to default.

Hopefully this may help others.

I've also been having this problem too. It only occurred very recently. I've tried all sorts: Plugins, safe mode, Pi-hole config / disabling, DNS flushing, checking the inspector for hints....and then I realised that YouTube was serving webp for these thumbnails and I'd changed a setting that might be causing this. In short, I didn't like that saving an imagine from Firefox was a webp a while back. I couldn't send them on WhatsApp via a browser as the format was unsupported. I'd changed 2 settings in about:config image.webp.enabled was set to false (default true) image.http.accept was set to "*/*" where the default was "image/webp,*/*" - all without the quotes As soon as I changed these back, they instantly started working. I suspect a reinstall resets these, hence why that fixes it. I didn't realise that safe mode didn't change these values back to default. Hopefully this may help others.
Bài viết này có hữu ích với bạn không? 2
Trích dẫn
Hollownerox 0 giải pháp 1 câu trả lời
Được đăng

Agent said

I'd changed 2 settings in about:config image.webp.enabled was set to false (default true) image.http.accept was set to "*/*" where the default was "image/webp,*/*" - all without the quotes As soon as I changed these back, they instantly started working. I suspect a reinstall resets these, hence why that fixes it. I didn't realise that safe mode didn't change these values back to default. Hopefully this may help others.

Thanks for this! Just changed these two settings in about:config and it immediately fixed the issue for me. Highly suggest others try this out before going for a full re-install.

''Agent [[#answer-1260768|said]]'' <blockquote> I'd changed 2 settings in about:config image.webp.enabled was set to false (default true) image.http.accept was set to "*/*" where the default was "image/webp,*/*" - all without the quotes As soon as I changed these back, they instantly started working. I suspect a reinstall resets these, hence why that fixes it. I didn't realise that safe mode didn't change these values back to default. Hopefully this may help others. </blockquote> Thanks for this! Just changed these two settings in about:config and it immediately fixed the issue for me. Highly suggest others try this out before going for a full re-install.
Bài viết này có hữu ích với bạn không?
Trích dẫn
imuniz 0 giải pháp 1 câu trả lời
Được đăng

This exact same problem also occurs to me. But just when I am logged in in YouTube. When I'm signed off I can see all thumbnails as normally.

The helpful answer from Agent above solved it! :)

This exact same problem also occurs to me. But just when I am logged in in YouTube. When I'm signed off I can see all thumbnails as normally. The helpful answer from Agent above solved it! :)

Được chỉnh sửa bởi imuniz vào

Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.