Search Support

When editing Google Docs the tab crashes after entering some characters. Safe Mode helps, but I cannot fix the issue without using Safe Mode

  • 6 trả lời
  • 2 gặp vấn đề này
  • 28 lượt xem
  • Trả lời mới nhất được viết bởi 100.percent.texan

more options

I am using Windows 10 Pro 1903, Firefox 69.0.3 (64-bit)

When I edit a document in Google Docs after entering some characters the tab crashes. If I stay on the same tab it stops to respond and after a few seconds it works again and all the characters I have entered appear. if i change to another tab and then back to the Google Docs tab then some round "reload" icon is shown, tab reloads and all is back to normal. When I change to about:performance when the Google Doc tab is hanging then it does not show up there anymore. After it is reloaded like 10 seconds later it appears again in about:performance.

When I start Firefox in Safe Mode then everything works fine and I cannot reproduce the issue. I then tried to narrow down the issue by disabling Hardware Acceleration, disabling all the extensions, plugins and making sure default theme is being used. But the issue was still there when I did not use Safe Mode.

I then created a new profile and after that did not help, I uninstalled Firefox, deleted the program files folder manually, reinstalled but the issue is still there. I also deleted all the Firefox System Add-Ons but still no success.

The issue happens with my normal Firefox in Private Mode, too.

How can I troubleshoot this further? What does Safe Mode do in addition to the things I have mentioned above?

Được chỉnh sửa bởi Martin vào

All Replies (6)

more options

hi, would you able to capture a performance profile when you reproduce this hang once and share it with us? https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem

more options

Here you go: https://perfht.ml/35vlvzC Profiler settings I left all in default. In Firefox HW acceleration, Addons, Plugins, Themes were disabled

more options

thank you - is there any difference in performance when you remove hitman pro alert from your system?

more options

I cannot remove HitMan it by myself. I have to talk to out IT department on Monday to see if they can remove it.

I did some more testing: After starting Firefox, the first time I produce the issue it seems to last the longest. And after I have reproduced it for about 6 times without restarting Firefox it does not appear anymore. Same behaviour with HW acceleration on and off. After restarting Firefox I can reproduce it again easily. Still in Safe Mode I cannot reproduce it no matter how hard I try.

more options

The issue does not appear anymore when I disable the feature "Exploit Mitigation" in Sophos Endpoint protection. I can reproduce it without any problems and it always behaves the same.

Được chỉnh sửa bởi Martin vào

more options

By disabling Hitman Pro Exploit Mitigation, the problem disappears. However, that is not really something I want to do. But it should point to what is causing the problem. Didn't have this problem back on Chrome. Further testing shows that I can disable, load the document, reinable and it works fine. Only have the problem if the document is loaded with Mitigation Enabled.

Further testing indicated that disabling Dynamic Heap Spray for Firefox only in the HitmanPro mitigation tab solved the problem. They are currently working to recreate on their end and hopefully provide a permanent solution.

Barry Lee

Được chỉnh sửa bởi 100.percent.texan vào