X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

bing opens no matter what need help

Được đăng

Bing opens every time I open up Firefox. I hate Bing and have searched everywhere for a way to get rid of it. I finally found in about:config there is a line which says browser.newtab.url modified string http://www.bing.com etc etc I reckon this might be the culprit, but I daren't alter anything because I don't know what I am doing. I did try "Reset" but it didn't make any difference, Bing reappeared. Any help welcome. Many thanks.

Bing opens every time I open up Firefox. I hate Bing and have searched everywhere for a way to get rid of it. I finally found in about:config there is a line which says browser.newtab.url modified string http://www.bing.com etc etc I reckon this might be the culprit, but I daren't alter anything because I don't know what I am doing. I did try "Reset" but it didn't make any difference, Bing reappeared. Any help welcome. Many thanks.

Giải pháp được chọn

pinapl4life said

this works for Mac right?

My post was for Mac, yes.

Đọc câu trả lời này trong ngữ cảnh 0
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

Duck Duck Go Privacy Essentials Privacy Badger Cookie Autodelete U Block Origin AdBlocker Ultimate

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Thông tin chi tiết

jimmybeanus 0 giải pháp 2 câu trả lời
Được đăng

Can't you just change home page in options? Unless I misunderstand your question.

Can't you just change home page in options? Unless I misunderstand your question.
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17534 giải pháp 158551 câu trả lời
Được đăng

The browser.newtab.url pref to set the new tab page via a pref hasn't been supported for quite some time in Firefox releases. Only an extension can change the new tab page.

Did you check the homepage setting ?

You can check that those pages aren't set as multiple homepages.

You can check the homepage setting.

Firefox supports multiple homepages separated by '|' (pipe) symbols.

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure nothing is appended after the path to the Firefox program.

The browser.newtab.url pref to set the new tab page via a pref hasn't been supported for quite some time in Firefox releases. Only an extension can change the new tab page. Did you check the homepage setting ? You can check that those pages aren't set as multiple homepages. You can check the homepage setting. *Options/Preferences -> Home: Home *https://support.mozilla.org/en-US/kb/how-to-set-the-home-page Firefox supports multiple homepages separated by '|' (pipe) symbols. You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure nothing is appended after the path to the Firefox program. *https://support.mozilla.org/en-US/kb/wrong-home-page-opens-when-i-start-firefox-how-fix
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

Thanks to both of you. Changing preferences on Home has worked. Totally overlooked this step but so glad I've finally kicked Bing into touch. Thanks again jimmybeanus and cor-el

Thanks to both of you. Changing preferences on Home has worked. Totally overlooked this step but so glad I've finally kicked Bing into touch. Thanks again jimmybeanus and cor-el
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
pinapl4life 0 giải pháp 9 câu trả lời
Được đăng

I've done this before, but it always ends up going back to bing after a week. (9-9) anyone know how to make it permanent?????

I've done this before, but it always ends up going back to bing after a week. (9-9) anyone know how to make it '''''permanent?????'''''
Bài viết này có hữu ích với bạn không?
Trích dẫn
pinapl4life 0 giải pháp 9 câu trả lời
Được đăng

i hate bing

i hate bing

Được chỉnh sửa bởi pinapl4life vào

Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8767 giải pháp 71704 câu trả lời
Được đăng

Hi pinapl4life, are you saying that once a week your Firefox home page setting gets changed from whatever page you selected (built-in, blank, or Custom URLs of your choice) to https://www.bing.com/ or is it some other change?

One way something could happen on a regular schedule like that is if a Scheduled Task (that's what they're called on Windows) is set up to do it. This could involve running other software that gets a kickback from Microsoft to send queries to Bing. Sometimes the URL of the query will point toward a particular culprit (look for extra parameters and, er, Google them).

Hi pinapl4life, are you saying that once a week your Firefox home page setting gets changed from whatever page you selected (built-in, blank, or Custom URLs of your choice) to https://www.bing.com/ or is it some other change? One way something could happen on a regular schedule like that is if a Scheduled Task (that's what they're called on Windows) is set up to do it. This could involve running other software that gets a kickback from Microsoft to send queries to Bing. Sometimes the URL of the query will point toward a particular culprit (look for extra parameters and, er, Google them).
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
pinapl4life 0 giải pháp 9 câu trả lời
Được đăng

it goes from Google (my usual) to Bing, and there is no scheduled settings. I always have to reset my settings, and it works. I also have to delete search browser in my Mac settings for "One-Click Search Engines"

it goes from Google (my usual) to Bing, and there is no scheduled settings. I always have to reset my settings, and it works. I also have to delete search browser in my Mac settings for "One-Click Search Engines"
Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8767 giải pháp 71704 câu trả lời
Được đăng

pinapl4life said

I also have to delete search browser in my Mac settings for "One-Click Search Engines"

Sounds like a malware infection, or at least a bad add-on. A popular scanning/cleaning tool for Mac users is: https://www.malwarebytes.com/mac/

Please also double-check:

(A) No new, unknown, or untrusted extensions (details below).

(B) No autoconfig files. This thread has an example of how to track that down: https://support.mozilla.org/questions/1256067

Extension Check

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

''pinapl4life [[#answer-1260452|said]]'' <blockquote> I also have to delete search browser in my Mac settings for "One-Click Search Engines" </blockquote> Sounds like a malware infection, or at least a bad add-on. A popular scanning/cleaning tool for Mac users is: https://www.malwarebytes.com/mac/ Please also double-check: (A) No new, unknown, or untrusted extensions (details below). (B) No autoconfig files. This thread has an example of how to track that down: https://support.mozilla.org/questions/1256067 '''''Extension Check''''' You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Command+Shift+a (Windows: Ctrl+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, or that you just do not remember installing or why? If in doubt, disable (or remove). Any improvement?
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
pinapl4life 0 giải pháp 9 câu trả lời
Được đăng

jscher2000 said

pinapl4life said
I also have to delete search browser in my Mac settings for "One-Click Search Engines"

Sounds like a malware infection, or at least a bad add-on. A popular scanning/cleaning tool for Mac users is: https://www.malwarebytes.com/mac/

Please also double-check:

(A) No new, unknown, or untrusted extensions (details below).

(B) No autoconfig files. This thread has an example of how to track that down: https://support.mozilla.org/questions/1256067

Extension Check

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

Thank you, i tried it. I will see if it works!! (i sure hope it does..)

''jscher2000 [[#answer-1260461|said]]'' <blockquote> ''pinapl4life [[#answer-1260452|said]]'' <blockquote> I also have to delete search browser in my Mac settings for "One-Click Search Engines" </blockquote> Sounds like a malware infection, or at least a bad add-on. A popular scanning/cleaning tool for Mac users is: https://www.malwarebytes.com/mac/ Please also double-check: (A) No new, unknown, or untrusted extensions (details below). (B) No autoconfig files. This thread has an example of how to track that down: https://support.mozilla.org/questions/1256067 '''''Extension Check''''' You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Command+Shift+a (Windows: Ctrl+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, or that you just do not remember installing or why? If in doubt, disable (or remove). Any improvement? </blockquote> Thank you, i tried it. I will see if it works!! (i sure hope it does..)
Bài viết này có hữu ích với bạn không?
Trích dẫn
pinapl4life 0 giải pháp 9 câu trả lời
Được đăng

this works for Mac right?

this works for Mac right?
Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8767 giải pháp 71704 câu trả lời
Được đăng

Giải pháp được chọn

pinapl4life said

this works for Mac right?

My post was for Mac, yes.

''pinapl4life [[#answer-1260478|said]]'' <blockquote> this works for Mac right? </blockquote> My post was for Mac, yes.
Bài viết này có hữu ích với bạn không?
Trích dẫn
pinapl4life 0 giải pháp 9 câu trả lời
Được đăng

ok so i did all that, but just now, google changed to yahoo?!?!?!? i have no idea why this happening!!! :0

ok so i did all that, but just now, google changed to yahoo?!?!?!? i have no idea why this happening!!! :0
Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8767 giải pháp 71704 câu trả lời
Được đăng

Hi pinapl4life, Firefox doesn't come with a Yahoo search plugin, so it's getting added on somehow. Same possible mechanism: malware or bad add-on.

Hi pinapl4life, Firefox doesn't come with a Yahoo search plugin, so it's getting added on somehow. Same possible mechanism: malware or bad add-on.
Bài viết này có hữu ích với bạn không?
Trích dẫn
pinapl4life 0 giải pháp 9 câu trả lời
Được đăng

jscher2000 said

Hi pinapl4life, Firefox doesn't come with a Yahoo search plugin, so it's getting added on somehow. Same possible mechanism: malware or bad add-on.

i deleted ALL of my add-ons... i will reset and try again...... if it goes wrong again i will try some sort of virus deleter

''jscher2000 [[#answer-1260857|said]]'' <blockquote> Hi pinapl4life, Firefox doesn't come with a Yahoo search plugin, so it's getting added on somehow. Same possible mechanism: malware or bad add-on. </blockquote> i deleted ALL of my add-ons... i will reset and try again...... if it goes wrong again i will try some sort of virus deleter
Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8767 giải pháp 71704 câu trả lời
Được đăng

pinapl4life said

jscher2000 said
Hi pinapl4life, Firefox doesn't come with a Yahoo search plugin, so it's getting added on somehow. Same possible mechanism: malware or bad add-on.

i deleted ALL of my add-ons... i will reset and try again...... if it goes wrong again i will try some sort of virus deleter

You didn't already run Malwarebytes the first time?!

''pinapl4life [[#answer-1260863|said]]'' <blockquote> ''jscher2000 [[#answer-1260857|said]]'' <blockquote> Hi pinapl4life, Firefox doesn't come with a Yahoo search plugin, so it's getting added on somehow. Same possible mechanism: malware or bad add-on. </blockquote> i deleted ALL of my add-ons... i will reset and try again...... if it goes wrong again i will try some sort of virus deleter </blockquote> You didn't already run Malwarebytes the first time?!
Bài viết này có hữu ích với bạn không?
Trích dẫn
pinapl4life 0 giải pháp 9 câu trả lời
Được đăng

jscher2000 said

pinapl4life said
jscher2000 said
Hi pinapl4life, Firefox doesn't come with a Yahoo search plugin, so it's getting added on somehow. Same possible mechanism: malware or bad add-on.

i deleted ALL of my add-ons... i will reset and try again...... if it goes wrong again i will try some sort of virus deleter

You didn't already run Malwarebytes the first time?!

no, because from what I saw, it had to be paid for. . .

''jscher2000 [[#answer-1260869|said]]'' <blockquote> ''pinapl4life [[#answer-1260863|said]]'' <blockquote> ''jscher2000 [[#answer-1260857|said]]'' <blockquote> Hi pinapl4life, Firefox doesn't come with a Yahoo search plugin, so it's getting added on somehow. Same possible mechanism: malware or bad add-on. </blockquote> i deleted ALL of my add-ons... i will reset and try again...... if it goes wrong again i will try some sort of virus deleter </blockquote> You didn't already run Malwarebytes the first time?! </blockquote> no, because from what I saw, it had to be paid for. . .
Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8767 giải pháp 71704 câu trả lời
Được đăng

Hi pinapl4life, for a one-time cleanup, you can use the free version (green button). The paid version runs persistently in the background like other security software.

Hi pinapl4life, for a one-time cleanup, you can use the free version (green button). The paid version runs persistently in the background like other security software.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.