X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Cannot open links containing mandrillapp.com

Được đăng

Hello. I understand mandrill or mailchimp is a service that some websites use for password resets/account activation/etc.. When I get emails of this type and the link goes to a mandrillapp.com address, Firefox will not open the website. Neither on home pc, home mac or work pc. None of the three has privacy setting of mine blocking mandrillapp.com, so I wonder why Firefox cannot open but other browsers do? Thanks.

Hello. I understand mandrill or mailchimp is a service that some websites use for password resets/account activation/etc.. When I get emails of this type and the link goes to a mandrillapp.com address, Firefox will not open the website. Neither on home pc, home mac or work pc. None of the three has privacy setting of mine blocking mandrillapp.com, so I wonder why Firefox cannot open but other browsers do? Thanks.
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 32.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Thông tin chi tiết

jscher2000
  • Top 10 Contributor
8761 giải pháp 71687 câu trả lời
Được đăng

Hi doug10, are you opening the link from a Firefox tab, or from an external application sending the link to Firefox as your default browser?

If you are opening it from within a Firefox tab, what happens when you click the link:

  • New tab opens, says Firefox can't find the server or page
  • New tab opens, remains blank
  • Nothing happens
  • Something else

Any difference if you use either:

  • right-click > Open Link in New Window
  • right-click > Open Link in New Private Window

I don't think Firefox's Content Blocking feature blocks links, although it may block scripts that are attached to links. Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking.

Otherwise, I would suspect an extension, but it's difficult to guess which one might be relevant.

Hi doug10, are you opening the link from a Firefox tab, or from an external application sending the link to Firefox as your default browser? If you are opening it from within a Firefox tab, what happens when you click the link: * New tab opens, says Firefox can't find the server or page * New tab opens, remains blank * Nothing happens * Something else Any difference if you use either: * right-click > Open Link in New Window * right-click > Open Link in New Private Window ---- I don't think Firefox's Content Blocking feature blocks links, although it may block scripts that are attached to links. Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: [[Content Blocking]]. Otherwise, I would suspect an extension, but it's difficult to guess which one might be relevant.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Thanks for the reply. If I open link from my email (Thunderbird), it opens a new tab in Firefox which will try to connect to the mandrill address for a while, then says it can't find page. Same if I copy the address directly into a new tab. But I think I know the issue now, Firefox says the connection is not secure when you click on info icon.

Odd, this mandrill/mailchimp service is used by a lot of websites for email verification, so it's obviously secure. How can I work around this given Firefox won't let me change a "not secure" setting? Thanks a lot. Doug

Thanks for the reply. If I open link from my email (Thunderbird), it opens a new tab in Firefox which will try to connect to the mandrill address for a while, then says it can't find page. Same if I copy the address directly into a new tab. But I think I know the issue now, Firefox says the connection is not secure when you click on info icon. Odd, this mandrill/mailchimp service is used by a lot of websites for email verification, so it's obviously secure. How can I work around this given Firefox won't let me change a "not secure" setting? Thanks a lot. Doug
Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8761 giải pháp 71687 câu trả lời
Được đăng

doug10 said

Thanks for the reply. If I open link from my email (Thunderbird), it opens a new tab in Firefox which will try to connect to the mandrill address for a while, then says it can't find page. Same if I copy the address directly into a new tab. But I think I know the issue now, Firefox says the connection is not secure when you click on info icon.

Can your Firefox connect to either of these pages:

Odd, this mandrill/mailchimp service is used by a lot of websites for email verification, so it's obviously secure.

Firefox is only indicating whether it can form a secure connection to the server, not whether the destination server is secure or not.

''doug10 [[#answer-1257735|said]]'' <blockquote> Thanks for the reply. If I open link from my email (Thunderbird), it opens a new tab in Firefox which will try to connect to the mandrill address for a while, then says it can't find page. Same if I copy the address directly into a new tab. But I think I know the issue now, Firefox says the connection is not secure when you click on info icon. </blockquote> Can your Firefox connect to either of these pages: * https://mandrill.com/ * https://mandrillapp.com/login/ <blockquote>Odd, this mandrill/mailchimp service is used by a lot of websites for email verification, so it's obviously secure. </blockquote> Firefox is only indicating whether it can form a secure connection to the server, not whether the destination server is secure or not.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

The first no problem; the second is the problem. Can I force Firefox to open this website thru settings? PS here's a link to a typical complaint about mandrillapp.com: https://discussions.apple.com/thread/8435056

The first no problem; the second is the problem. Can I force Firefox to open this website thru settings? PS here's a link to a typical complaint about mandrillapp.com: https://discussions.apple.com/thread/8435056
Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8761 giải pháp 71687 câu trả lời
Được đăng

Do you get this one:

Hmm. We’re having trouble finding that site. We can’t connect to the server at mandrillapp.com.

Or does it have other phrasing?


Could you check your connection settings here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. I suggest avoiding "Auto-detect" which can lead to a flaky connection.

You may also want to try "No proxy".

Any difference?


Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Do you get this one: '''Hmm. We’re having trouble finding that site. We can’t connect to the server at mandrillapp.com.''' Or does it have other phrasing? ---- Could you check your connection settings here: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''proxy'' and Firefox should filter to the "Settings" button, which you can click. The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. I suggest avoiding "Auto-detect" which can lead to a flaky connection. You may also want to try "No proxy". Any difference? ---- Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Thank you for all the info. I'll try it and revert!

Thank you for all the info. I'll try it and revert!
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.