X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

How to reduce the number of rows for "Recommended by Pocket"?

Được đăng

I love pocket, but there are WAY TOO MANY rows of it for me to even bother with. I need to be able to reduce this to one row so that my highlights are not 20 articles below it. I tried dismissing each one, but now I just have 6 rows of blank pocket cards.

I love pocket, but there are WAY TOO MANY rows of it for me to even bother with. I need to be able to reduce this to one row so that my highlights are not 20 articles below it. I tried dismissing each one, but now I just have 6 rows of blank pocket cards.

Giải pháp được chọn

any change when you set 'browser.newtabpage.activity-stream.discoverystream.enabled' to false and restart once?

Đọc câu trả lời này trong ngữ cảnh 2
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

None. Fresh install of Firefox 69.0 x64

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Thông tin chi tiết

Wesley Branton
  • Top 10 Contributor
594 giải pháp 5017 câu trả lời
Được đăng

You can adjust the rows of the Recommended By Pocket, Top Sites and Highlights sections in the Home section of the Firefox settings page.

Hope this helps.

You can adjust the rows of the Recommended By Pocket, Top Sites and Highlights sections in the '''Home''' section of the Firefox settings page. Hope this helps.
Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

I don't seem to have that option. Only a row # selection drop-down menu for "Top Sites" and "Highlights".

I don't seem to have that option. Only a row # selection drop-down menu for "Top Sites" and "Highlights".
Bài viết này có hữu ích với bạn không?
Trích dẫn
Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 giải pháp 10669 câu trả lời
Được đăng

Câu trả lời hữu ích

You can collapse sections by clicking the small downward facing arrow next to the name. This is a great way to quickly pull your "Highlights" section up without scrolling.

You can collapse sections by clicking the small downward facing arrow next to the name. This is a great way to quickly pull your "Highlights" section up without scrolling.
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

Thanks for that. A viable work around, but not much of a solution. I do appreciate it though. I contacted Pocket feedback about it as well as Firefox feedback.

Thanks for that. A viable work around, but not much of a solution. I do appreciate it though. I contacted Pocket feedback about it as well as Firefox feedback.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Wesley Branton
  • Top 10 Contributor
594 giải pháp 5017 câu trả lời
Được đăng

If you can't see that option in the settings page, you could also manually tweak that setting by doing the following:

  1. Type about:config in the Firefox address bar
  2. Bypass the warning (we'll be careful, I promise)
  3. Find the browser.newtabpage.activity-stream.section.topstories.rows preference
  4. Double click it to edit
  5. Change the number to how many rows you want to see

That should change it for you. Hope this helps.

If you can't see that option in the settings page, you could also manually tweak that setting by doing the following: #Type <code>about:config</code> in the Firefox address bar #Bypass the warning (we'll be careful, I promise) #Find the <code>browser.newtabpage.activity-stream.section.topstories.rows</code> preference #Double click it to edit #Change the number to how many rows you want to see That should change it for you. Hope this helps.
Bài viết này có hữu ích với bạn không?
Trích dẫn
StevenH928 0 giải pháp 2 câu trả lời
Được đăng

Neither option works any more. Row selector in Settings is missing. about:config solution doesn't work. Still have 7 rows of recommendations. This has only occurred after the 69 update.

Possible revenue stream for Mozzila?

Neither option works any more. Row selector in Settings is missing. about:config solution doesn't work. Still have 7 rows of recommendations. This has only occurred after the 69 update. Possible revenue stream for Mozzila?

Được chỉnh sửa bởi StevenH928 vào

Bài viết này có hữu ích với bạn không?
Trích dẫn
Wesley Branton
  • Top 10 Contributor
594 giải pháp 5017 câu trả lời
Được đăng

That setting should be working and the maximum rows that Pocket should use is only 4. It's possible that maybe some of your Pocket settings have become corrupted, so we can try resetting those.

Do the following:

  1. Enter about:config in the Firefox address bar
  2. Bypass the security warning
  3. Find enter browser.newtabpage.activity-stream.feeds.section.topstories in the search bar
  4. Right click browser.newtabpage.activity-stream.feeds.section.topstories.options and select Reset
  5. Right click browser.newtabpage.activity-stream.feeds.section.topstories.rec.impressions and select Reset
  6. Search for browser.newtabpage.activity-stream.section.topstories.rows
  7. Double click it to edit the value
  8. Change the number to 1
  9. Restart Firefox

Hope this helps.

That setting should be working and the maximum rows that Pocket should use is only 4. It's possible that maybe some of your Pocket settings have become corrupted, so we can try resetting those. Do the following: #Enter <code>about:config</code> in the Firefox address bar #Bypass the security warning #Find enter <code>browser.newtabpage.activity-stream.feeds.section.topstories</code> in the search bar #Right click <code>browser.newtabpage.activity-stream.feeds.section.topstories.options</code> and select '''Reset''' # Right click <code>browser.newtabpage.activity-stream.feeds.section.topstories.rec.impressions</code> and select '''Reset''' # Search for <code>browser.newtabpage.activity-stream.section.topstories.rows</code> #Double click it to edit the value #Change the number to <code>1</code> # Restart Firefox Hope this helps.
Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

Sorry. I found everything you were talking about but the settings are already at default, including the number of rows. I changed and reset them just in-case, but still no option.

Sorry. I found everything you were talking about but the settings are already at default, including the number of rows. I changed and reset them just in-case, but still no option.
Bài viết này có hữu ích với bạn không?
Trích dẫn
alex_mayorga
  • Top 25 Contributor
  • Moderator
366 giải pháp 2869 câu trả lời
Được đăng

Hi Jim!

Quite strange indeed!

Could you please upload a screen capture of the about:preferences#home page of your Firefox?

Does the same occur while Troubleshoot Firefox issues using Safe Mode?

Thanks!

Hi Jim! Quite strange indeed! Could you please upload a screen capture of the ''about:preferences#home'' page of your Firefox? Does the same occur while [[Troubleshoot Firefox issues using Safe Mode]]? Thanks!
Bài viết này có hữu ích với bạn không?
Trích dẫn
Wesley Branton
  • Top 10 Contributor
594 giải pháp 5017 câu trả lời
Được đăng

It appears that maybe this could be a bug. I filed a bug report (see bug 1581923) so that the developers can take a look at it.

It appears that maybe this could be a bug. I filed a bug report (see [https://bugzilla.mozilla.org/show_bug.cgi?id=1581923 bug 1581923]) so that the developers can take a look at it.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Screen shot below. I get the same exact thing both inside and outside of Safe Mode.

Screen shot below. I get the same exact thing both inside and outside of Safe Mode.
Bài viết này có hữu ích với bạn không?
Trích dẫn
philipp
  • Top 25 Contributor
  • Moderator
5306 giải pháp 23424 câu trả lời
Được đăng

Giải pháp được chọn

any change when you set 'browser.newtabpage.activity-stream.discoverystream.enabled' to false and restart once?

any change when you set 'browser.newtabpage.activity-stream.discoverystream.enabled' to false and restart once?
Bài viết này có hữu ích với bạn không? 2
Trích dẫn

Người tạo câu hỏi

YES, That worked! It reduced the number of rows to 1, and it gave me the option back in the home settings section.

Now I just have to work on my recommendations to fill in the empty article cards, but that is all on me and my reading activity.

Thank you all so much for your time, help, and patience!

YES, That worked! It reduced the number of rows to 1, and it gave me the option back in the home settings section. Now I just have to work on my recommendations to fill in the empty article cards, but that is all on me and my reading activity. Thank you all so much for your time, help, and patience!
Bài viết này có hữu ích với bạn không?
Trích dẫn
StevenH928 0 giải pháp 2 câu trả lời
Được đăng

philipp said

any change when you set 'browser.newtabpage.activity-stream.discoverystream.enabled' to false and restart once?

Oh my..... As simple as the old Tech Support standby of off/on. Simple solution is always the last one tried. Well done Philipp. 8)

''philipp [[#answer-1252860|said]]'' <blockquote> any change when you set 'browser.newtabpage.activity-stream.discoverystream.enabled' to false and restart once? </blockquote> Oh my..... As simple as the old Tech Support standby of off/on. Simple solution is always the last one tried. Well done Philipp. 8)
Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8695 giải pháp 71076 câu trả lời
Được đăng

philipp said

any change when you set 'browser.newtabpage.activity-stream.discoverystream.enabled' to false and restart once?

Hmm, that preference is set to false by default in the release build (dxr):

// These prefs control if Discovery Stream is enabled.
#ifdef NIGHTLY_BUILD
pref("browser.newtabpage.activity-stream.discoverystream.enabled", true);
#else
pref("browser.newtabpage.activity-stream.discoverystream.enabled", false);
#endif

But perhaps this is why mine is set to true:

app.normandy.startupRolloutPrefs.browser.newtabpage.activity-stream.discoverystream.enabled => true

''philipp [[#answer-1252860|said]]'' <blockquote> any change when you set 'browser.newtabpage.activity-stream.discoverystream.enabled' to false and restart once? </blockquote> Hmm, that preference is set to false by default in the release build ([https://dxr.mozilla.org/mozilla-release/source/browser/app/profile/firefox.js#1316 dxr]): <pre>// These prefs control if Discovery Stream is enabled. #ifdef NIGHTLY_BUILD pref("browser.newtabpage.activity-stream.discoverystream.enabled", true); #else pref("browser.newtabpage.activity-stream.discoverystream.enabled", false); #endif </pre> But perhaps this is why mine is set to true: <code>app.normandy.startupRolloutPrefs.browser.newtabpage.activity-stream.discoverystream.enabled => true </code>
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17479 giải pháp 157962 câu trả lời
Được đăng

See also lines #1251 (prefCache) and #1288, #1333 (hard coded: 21 items = 3-col x 7-row) in this file in the source code.

See also lines #1251 (prefCache) and #1288, #1333 (hard coded: 21 items = 3-col x 7-row) in this file in the source code. *https://dxr.mozilla.org/mozilla-release/source/browser/components/newtab/lib/DiscoveryStreamFeed.jsm
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.