X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox 69.0 Storing Cookies and Site data

Được đăng

- Running Firefox 69.0 on macOS 10.14.6 - The only extension installed and enabled is uBlock Origin 1.22.2 - In Privacy & Security, under "Content Blocking", "Custom" is selected, blocking Trackers, Cookies, Cryptominers, and Fingerprinters. - There are no Exceptions for any site. - "Do Not Track" signal set to Always. - "Storage" for Shockwave Flash 32.0 set to "Block all sites from storing information on this computer" in macOS System Preferences. - Prior to Firefox 69.0, noticed, at most, 2 KB of Cookies and Site Data being stored, even after closing/reopening. - Since upgrade to Firefox 69.0, noticing that up to 30 KB or more of Cookies and Site Data being stored, even after closing/opening.

- Running Firefox 69.0 on macOS 10.14.6 - The only extension installed and enabled is uBlock Origin 1.22.2 - In Privacy & Security, under "Content Blocking", "Custom" is selected, blocking Trackers, Cookies, Cryptominers, and Fingerprinters. - There are no Exceptions for any site. - "Do Not Track" signal set to Always. - "Storage" for Shockwave Flash 32.0 set to "Block all sites from storing information on this computer" in macOS System Preferences. - Prior to Firefox 69.0, noticed, at most, 2 KB of Cookies and Site Data being stored, even after closing/reopening. - Since upgrade to Firefox 69.0, noticing that up to 30 KB or more of Cookies and Site Data being stored, even after closing/opening.

Giải pháp được chọn

kennyfryatl said

Under History, "Always use private browsing mode" is checked - when I click on "Clear History...", "Time range to clear:" is Everything, and all boxes on the menu presented are checked.

With that setting, Firefox shouldn't store any cookies to disk. Any cookies needed for your private session are stored only in memory. So you shouldn't see several KB of cookies. Where is that showing up?

If I uncheck "Always use private browsing mode", I receive the prompt to restart Firefox to disable - when I restart Firefox, I am unable to navigate to any websites.

Hmm, that's strange. I wonder why? One difference between regular windows and private windows is that you can set extensions to run only in regular and not private windows. So maybe an add-on is causing problems with your connection in regular mode??

Đọc câu trả lời này trong ngữ cảnh 0
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 32.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:69.0) Gecko/20100101 Firefox/69.0

Thông tin chi tiết

jscher2000
  • Top 10 Contributor
8695 giải pháp 71066 câu trả lời
Được đăng

Hi kennyfryatl, what is your setting for Cookies under Content Blocking? Normally it will default to Third-party trackers:


There are other settings to manage what is carried over from session to session.

(1) Limit all cookies to current session only (with exceptions you set)

This is set in the Cookies and Site Data section with the "Delete cookies and site data when Firefox is closed" checkbox. It's not retroactive, so to clear existing cookies that have a future expiration date, you can use the Manage Data (select individual sites) or Clear Data (everything) button.

Use the Manage Permissions button to create or remove exceptions for sites where you want the cookie to survive from one session to the next.

(2) Flush all cookies without exception when closing Firefox

This is set in the History section. You first need to select "Firefox will: Use custom settings for history" to show the specific options.

After checking "Clear history when Firefox closes" the Settings button will be enabled so you can choose the specific items you want to flush at shutdown. (Please allow a little extra time after using Exit from the menu before shutting down your system.)

Hi kennyfryatl, what is your setting for Cookies under Content Blocking? Normally it will default to '''Third-party trackers''': <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-09-10-08-28-46-7cf53d.png" width="500"> ---- There are other settings to manage what is carried over from session to session. (1) Limit all cookies to current session only (with exceptions you set) This is set in the '''Cookies and Site Data''' section with the "Delete cookies and site data when Firefox is closed" checkbox. It's not retroactive, so to clear existing cookies that have a future expiration date, you can use the Manage Data (select individual sites) or Clear Data (everything) button. <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-09-10-08-34-00-d7194e.png" width="500"> Use the Manage Permissions button to create or remove exceptions for sites where you want the cookie to survive from one session to the next. (2) Flush all cookies without exception when closing Firefox This is set in the '''History''' section. You first need to select "Firefox will: Use custom settings for history" to show the specific options. After checking "Clear history when Firefox closes" the Settings button will be enabled so you can choose the specific items you want to flush at shutdown. (Please allow a little extra time after using Exit from the menu before shutting down your system.) <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-09-10-08-42-20-82f5e1.png" width="500">
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Hello, jscher2000 - thanks for your time in getting back to me, much appreciated!

Yes, under Cookies and Site Data, "Delete Cookies and Site Data when Firefox is closed" is checked - there are no Exceptions under "Manage Permissions...".

Under History, "Always use private browsing mode" is checked - when I click on "Clear History...", "Time range to clear:" is Everything, and all boxes on the menu presented are checked.

If I uncheck "Always use private browsing mode", I receive the prompt to restart Firefox to disable - when I restart Firefox, I am unable to navigate to any websites.

When I recheck "Always use private browsing mode", Firefox operates as it has to date.

Hello, jscher2000 - thanks for your time in getting back to me, much appreciated! Yes, under Cookies and Site Data, "Delete Cookies and Site Data when Firefox is closed" is checked - there are no Exceptions under "Manage Permissions...". Under History, "Always use private browsing mode" is checked - when I click on "Clear History...", "Time range to clear:" is Everything, and all boxes on the menu presented are checked. If I uncheck "Always use private browsing mode", I receive the prompt to restart Firefox to disable - when I restart Firefox, I am unable to navigate to any websites. When I recheck "Always use private browsing mode", Firefox operates as it has to date.
Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8695 giải pháp 71066 câu trả lời
Được đăng

Giải pháp được chọn

kennyfryatl said

Under History, "Always use private browsing mode" is checked - when I click on "Clear History...", "Time range to clear:" is Everything, and all boxes on the menu presented are checked.

With that setting, Firefox shouldn't store any cookies to disk. Any cookies needed for your private session are stored only in memory. So you shouldn't see several KB of cookies. Where is that showing up?

If I uncheck "Always use private browsing mode", I receive the prompt to restart Firefox to disable - when I restart Firefox, I am unable to navigate to any websites.

Hmm, that's strange. I wonder why? One difference between regular windows and private windows is that you can set extensions to run only in regular and not private windows. So maybe an add-on is causing problems with your connection in regular mode??

''kennyfryatl [[#answer-1250932|said]]'' <blockquote> Under History, "Always use private browsing mode" is checked - when I click on "Clear History...", "Time range to clear:" is Everything, and all boxes on the menu presented are checked.</blockquote> With that setting, Firefox shouldn't store any cookies to disk. Any cookies needed for your private session are stored only in memory. So you shouldn't see several KB of cookies. Where is that showing up? <blockquote>If I uncheck "Always use private browsing mode", I receive the prompt to restart Firefox to disable - when I restart Firefox, I am unable to navigate to any websites. </blockquote> Hmm, that's strange. I wonder why? One difference between regular windows and private windows is that you can set extensions to run only in regular and not private windows. So maybe an add-on is causing problems with your connection in regular mode??
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

jscher2000, thanks again for your help!

I agree with you, and I think it may be the uBlock Origin extension that is causing this glitch - when I checked its permissions in Firefox's Add-ons Manager, "Store unlimited amount of client-side data" is indicated.

jscher2000, thanks again for your help! I agree with you, and I think it may be the uBlock Origin extension that is causing this glitch - when I checked its permissions in Firefox's Add-ons Manager, "Store unlimited amount of client-side data" is indicated.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.