X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Website is displayed properly in private browsing mode, but not in regular Firefox mode

Được đăng

I noticed that there are some issues with certain websites in Firefox 68.0.2 (Mac OS X Sierra 10.12.6). Sites like LinkedIn are affected - entire pages don't load in a regular browser, but do load in a Private Window or in Chrome. Also, I teach at a university and the learning management system, Moodle, does not work properly unless I use a Private Window. (See the attached screenshot showing the home page with editing turned on in a regular window, above, and a private window, below. The Private window shows the Javascript-based "move" functionality, which disappears after the first second of a page load in a regular window.)

I tried all of the suggestions in this support thread--https://support.mozilla.org/en-US/questions/1170415--but none have worked: -- I disabled all add-ons and extensions -- I cleared all cache and cookies -- I switched to safe mode

I called my campus help desk and they walked me through changing the Content Blocking from Standard to Custom (I unchecked "Trackers") - still no luck.

Any thoughts would be appreciated!

Kevin

I noticed that there are some issues with certain websites in Firefox 68.0.2 (Mac OS X Sierra 10.12.6). Sites like LinkedIn are affected - entire pages don't load in a regular browser, but do load in a Private Window or in Chrome. Also, I teach at a university and the learning management system, Moodle, does not work properly unless I use a Private Window. (See the attached screenshot showing the home page with editing turned on in a regular window, above, and a private window, below. The Private window shows the Javascript-based "move" functionality, which disappears after the first second of a page load in a regular window.) I tried all of the suggestions in this support thread--https://support.mozilla.org/en-US/questions/1170415--but none have worked: -- I disabled all add-ons and extensions -- I cleared all cache and cookies -- I switched to safe mode I called my campus help desk and they walked me through changing the Content Blocking from Standard to Custom (I unchecked "Trackers") - still no luck. Any thoughts would be appreciated! Kevin
Đính kèm ảnh chụp màn hình
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

All plugins are disabled, but these are the only three plugins I have installed: OpenH264 Video Codec, Shockwave Flash, Google Widevine Content Decryption Module

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:68.0) Gecko/20100101 Firefox/68.0

Thông tin chi tiết

cor-el
  • Top 10 Contributor
  • Moderator
17467 giải pháp 157849 câu trả lời
Được đăng

The lower part of the screenshot shows the Shield in the location bar indicating that Content Blocking is active.

In current Firefox release you can set whether an extension is enabled in Private Browsing mode, so if it works in PB mode then this could be the problem. However in this case it should also work in Safe Mode or with all extensions disabled.

This can also be a problem with the cookies and the cache.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
The lower part of the screenshot shows the Shield in the location bar indicating that Content Blocking is active. In current Firefox release you can set whether an extension is enabled in Private Browsing mode, so if it works in PB mode then this could be the problem. However in this case it should also work in Safe Mode or with all extensions disabled. This can also be a problem with the cookies and the cache. You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.