X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox asks me to open chrome-extension:// with an application?

Được đăng

For example if I go to https://jsfiddle.net/01tpr8sd/, a dialogue will pop up asking me which application I'd like to use to handle this link, while it should have triggered the internal U2F implementation. I have tried starting Firefox in safe mode and resetting values that look relevant in about:config but neither of them helped.

It doesn't happen if I create a fresh new profile though, but I really want to avoid the hassle of backing up all the extension configurations... Please help, thanks a lot.

For example if I go to https://jsfiddle.net/01tpr8sd/, a dialogue will pop up asking me which application I'd like to use to handle this link, while it should have triggered the internal U2F implementation. I have tried starting Firefox in safe mode and resetting values that look relevant in about:config but neither of them helped. It doesn't happen if I create a fresh new profile though, but I really want to avoid the hassle of backing up all the extension configurations... Please help, thanks a lot.
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

It turned out that the reason why this happened was that I've got GTK_USE_PORTAL set for my Firefox. It wasn't related to profiles.

I've filed a ticket about this issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1575439

Đọc câu trả lời này trong ngữ cảnh 0
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 32.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (X11; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

Thông tin chi tiết

Eldar Value 4 giải pháp 45 câu trả lời
Được đăng
Try: https://blog.mozilla.org/security/2019/04/04/shipping-fido-u2f-api-support-in-firefox/ Hope it helps.
Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

Eldar Value said

Try: https://blog.mozilla.org/security/2019/04/04/shipping-fido-u2f-api-support-in-firefox/ Hope it helps.

Thanks for your reply but it didn't help. The dialogue showed up regardless of the value of this option (I actually switched it to true a long time ago). Btw security.webauth.u2f has been on by default from a recent version iirc (so was it in my fresh new Firefox profile) therefore I reckon it wasn't the culprit.

''Eldar Value [[#answer-1245532|said]]'' <blockquote> Try: https://blog.mozilla.org/security/2019/04/04/shipping-fido-u2f-api-support-in-firefox/ Hope it helps. </blockquote> Thanks for your reply but it didn't help. The dialogue showed up regardless of the value of this option (I actually switched it to true a long time ago). Btw security.webauth.u2f has been on by default from a recent version iirc (so was it in my fresh new Firefox profile) therefore I reckon it wasn't the culprit.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Eldar Value 4 giải pháp 45 câu trả lời
Được đăng

Frederick Zhang said

Eldar Value said
Try: https://blog.mozilla.org/security/2019/04/04/shipping-fido-u2f-api-support-in-firefox/ Hope it helps.

Thanks for your reply but it didn't help. The dialogue showed up regardless of the value of this option (I actually switched it to true a long time ago). Btw security.webauth.u2f has been on by default from a recent version iirc (so was it in my fresh new Firefox profile) therefore I reckon it wasn't the culprit.

Try to make new profile via about:profiles and set it to default. If its working, export your bookmarks from the old profile and import them to the new profile.

''Frederick Zhang [[#answer-1245536|said]]'' <blockquote> ''Eldar Value [[#answer-1245532|said]]'' <blockquote> Try: https://blog.mozilla.org/security/2019/04/04/shipping-fido-u2f-api-support-in-firefox/ Hope it helps. </blockquote> Thanks for your reply but it didn't help. The dialogue showed up regardless of the value of this option (I actually switched it to true a long time ago). Btw security.webauth.u2f has been on by default from a recent version iirc (so was it in my fresh new Firefox profile) therefore I reckon it wasn't the culprit. </blockquote> Try to make new profile via about:profiles and set it to default. If its working, export your bookmarks from the old profile and import them to the new profile.
Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

Eldar Value said

Frederick Zhang said
Eldar Value said
Try: https://blog.mozilla.org/security/2019/04/04/shipping-fido-u2f-api-support-in-firefox/ Hope it helps.

Thanks for your reply but it didn't help. The dialogue showed up regardless of the value of this option (I actually switched it to true a long time ago). Btw security.webauth.u2f has been on by default from a recent version iirc (so was it in my fresh new Firefox profile) therefore I reckon it wasn't the culprit.

Try to make new profile via about:profiles and set it to default. If its working, export your bookmarks from the old profile and import them to the new profile.

As mentioned in my question description, I've got several extensions of which the configurations don't get uploaded to my Firefox account and it's quite troublesome to copy/paste all of them. And I really want to know the reason why this happens otherwise I guess it's very likely for me to misconfigure something again in the future which causes the same issue.

''Eldar Value [[#answer-1245537|said]]'' <blockquote> ''Frederick Zhang [[#answer-1245536|said]]'' <blockquote> ''Eldar Value [[#answer-1245532|said]]'' <blockquote> Try: https://blog.mozilla.org/security/2019/04/04/shipping-fido-u2f-api-support-in-firefox/ Hope it helps. </blockquote> Thanks for your reply but it didn't help. The dialogue showed up regardless of the value of this option (I actually switched it to true a long time ago). Btw security.webauth.u2f has been on by default from a recent version iirc (so was it in my fresh new Firefox profile) therefore I reckon it wasn't the culprit. </blockquote> Try to make new profile via about:profiles and set it to default. If its working, export your bookmarks from the old profile and import them to the new profile. </blockquote> As mentioned in my question description, I've got several extensions of which the configurations don't get uploaded to my Firefox account and it's quite troublesome to copy/paste all of them. And I really want to know the reason why this happens otherwise I guess it's very likely for me to misconfigure something again in the future which causes the same issue.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Giải pháp được chọn

It turned out that the reason why this happened was that I've got GTK_USE_PORTAL set for my Firefox. It wasn't related to profiles.

I've filed a ticket about this issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1575439

It turned out that the reason why this happened was that I've got GTK_USE_PORTAL set for my Firefox. It wasn't related to profiles. I've filed a ticket about this issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1575439
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.