X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Preventing push notifications from auto disappearing in 4 seconds, win7 FF68.0.1 (64-bit)

JAB
Được đăng

Preventing push notifications from auto disappearing in 4 seconds, win7 FF68.0.1 (64-bit) When notifications show up, they auto disappear in like 4 seconds, basically useless if your not staring at your screen constantly. I even reinstalled and updated to the latest FF version from the esr version just to get notifications working, now realize they aren't of much use if they auto disappear before i can read them ! ?

Preventing push notifications from auto disappearing in 4 seconds, win7 FF68.0.1 (64-bit) When notifications show up, they auto disappear in like 4 seconds, basically useless if your not staring at your screen constantly. I even reinstalled and updated to the latest FF version from the esr version just to get notifications working, now realize they aren't of much use if they auto disappear before i can read them ! ?
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 32.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Thông tin chi tiết

McCoy
  • Top 10 Contributor
521 giải pháp 4895 câu trả lời
Được đăng

Câu trả lời hữu ích

Hello JAB,

Would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if aksed)

Type in the search bar and look for the preference :

dom.webnotifications.requireinteraction.enabled

and set its value to true (default value is false)

Then close and restart Firefox.

Does that work for you ?

Hello JAB, Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if aksed) Type in the search bar and look for the preference : '''dom.webnotifications.requireinteraction.enabled''' and set its value to '''true''' (default value is '''false''') Then close and restart Firefox. Does that work for you ?
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
JAB
Được đăng

Người tạo câu hỏi

Yes thankyou it does fix the problem.

Yes thankyou it does fix the problem.
Bài viết này có hữu ích với bạn không?
Trích dẫn
JAB
Được đăng

Người tạo câu hỏi

Nope my bad, it did work when first set, i see now this setting is still "true" but FF seems to be ignoring it.

Nope my bad, it did work when first set, i see now this setting is still "true" but FF seems to be ignoring it.
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
521 giải pháp 4895 câu trả lời
Được đăng

JAB said

Nope my bad, it did work when first set, i see now this setting is still "true" but FF seems to be ignoring it.

Bummer  !

Would you take a look at this preference :

dom.webnotifications.requireinteraction.count

The default value is "3" - change it to a higher number, like "60" (or whatever you want to experiment with)

Then :

dom.webnotifications.requireuserinteraction

and change its value to true.

Don't forget to close and restart Firefox after you've made a change, though.

Any luck ?

''JAB [[#answer-1244601|said]]'' <blockquote> Nope my bad, it did work when first set, i see now this setting is still "true" but FF seems to be ignoring it. </blockquote> Bummer ! Would you take a look at this preference : '''dom.webnotifications.requireinteraction.count''' The default value is "3" - change it to a higher number, like "60" (or whatever you want to experiment with) Then : '''dom.webnotifications.requireuserinteraction''' and change its value to '''true'''. Don't forget to close and restart Firefox after you've made a change, though. Any luck ?
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
JAB
Được đăng

Người tạo câu hỏi

Nope didn't fix the issue

Nope didn't fix the issue
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17421 giải pháp 157408 câu trả lời
Được đăng

This pref may not work with push notifications that use a service worker and that are possibly handled by the operating system instead of the builtin XUL notification. This pref might be more about web notifications that are shown when Firefox is running and you have a tab open.

  • Bug 862395 - Allow websites to control HTML5 Notification auto-closing [52]

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

This pref may not work with push notifications that use a service worker and that are possibly handled by the operating system instead of the builtin XUL notification. This pref might be more about web notifications that are shown when Firefox is running and you have a tab open. *[https://bugzilla.mozilla.org/show_bug.cgi?id=862395 Bug 862395] - Allow websites to control HTML5 Notification auto-closing [52] (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)

Được chỉnh sửa bởi cor-el vào

Bài viết này có hữu ích với bạn không?
Trích dẫn
JAB
Được đăng

Người tạo câu hỏi

So whats the point of posting this bug report ? is this confirming a bug exist or saying no bug exist and we're waiting for a fix ?? or....

This still doesn't fix notifications auto closing and still makes them useless.

So whats the point of posting this bug report ? is this confirming a bug exist or saying no bug exist and we're waiting for a fix ?? or.... This still doesn't fix notifications auto closing and still makes them useless.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.