X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox crashes

Được đăng

Firefox immediately goes to the crash report dialog about half the time I start it. When this happens it takes up to 15 times restarting it for it to actually start. I've tried a clean install and starting in safe mode but the same thing happens. The most recent crash report ID is bp-a433666b-c733-415f-940a-e29210190805. Can anyone help with this?

Firefox immediately goes to the crash report dialog about half the time I start it. When this happens it takes up to 15 times restarting it for it to actually start. I've tried a clean install and starting in safe mode but the same thing happens. The most recent crash report ID is bp-a433666b-c733-415f-940a-e29210190805. Can anyone help with this?

Giải pháp được chọn

In case anyone comes across this in the future, updating to firefox 69 fixed the problem.

Đọc câu trả lời này trong ngữ cảnh 0
Trích dẫn

Chi tiết hệ thống bổ sung

Ứng dụng

  • Firefox 68.0.1
  • Chuỗi đại diện người dùng: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/68.0.1/Linux/en-US/

Tiện ích mở rộng

  • Amazon.com 1.1 (amazondotcom@search.mozilla.org)
  • Bing 1.0 (bing@search.mozilla.org)
  • DuckDuckGo 1.0 (ddg@search.mozilla.org)
  • eBay 1.0 (ebay@search.mozilla.org)
  • Google 1.0 (google@search.mozilla.org)
  • Twitter 1.0 (twitter@search.mozilla.org)
  • Wikipedia (en) 1.0 (wikipedia@search.mozilla.org)
  • Fixed Zoom 2.1.5 ({a655a6b2-69a5-40de-a3b8-3f7f200c95a7}) (không hoạt động)
  • GNOME Shell integration 10.1 (chrome-gnome-shell@gnome.org) (không hoạt động)
  • GSConnect 6 (gsconnect@andyholmes.github.io) (không hoạt động)
  • Honey 11.3.5 (jid1-93CWPmRbVPjRQA@jetpack) (không hoạt động)
  • LastPass: Free Password Manager 4.29.0.4 (support@lastpass.com) (không hoạt động)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: Mesa DRI Intel(R) HD Graphics (Whiskey Lake 3x8 GT2)
  • adapterDeviceID: 0x3ea0
  • adapterDrivers:
  • adapterRAM: 3072MB
  • adapterVendorID: 0x8086
  • contentUsesTiling: False
  • crashGuards: []
  • driverDate:
  • driverVendor: mesa/i965
  • driverVersion: 19.1.3.0
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable-in-safe-mode', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable-in-safe-mode', u'message': u'Safe-mode is enabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'blocked-vendor-unsupported', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked-vendor-unsupported', u'message': u'Unsupported vendor', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'CairoUseXRender': 0, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: {u'key': u''}
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • targetFrameRate: 60
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowProtocol: x11
  • windowUsingAdvancedLayers: False

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Có
Jeremy Sanders 12 giải pháp 142 câu trả lời
Được đăng

Have you tried starting in Safe Mode?

Have you tried starting in Safe Mode?
Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

Jeremy Sanders said

Have you tried starting in Safe Mode?

Yes. The same thing happens when I try starting in safe mode. The crash report ID I gave is from when I tried starting in safe mode.

''Jeremy Sanders [[#answer-1243257|said]]'' <blockquote> Have you tried starting in Safe Mode? </blockquote> Yes. The same thing happens when I try starting in safe mode. The crash report ID I gave is from when I tried starting in safe mode.
Bài viết này có hữu ích với bạn không?
Trích dẫn
JohannHan 8 giải pháp 128 câu trả lời
Được đăng

Start Firefox in the terminal and see the report.

Start Firefox in the terminal and see the report.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

JohannHan said

Start Firefox in the terminal and see the report.

It doesn't seem to crash if I just run firefox with no parameters. If I run firefox %u like it is in the .desktop it gives the same behavior as I described in the original post. Here is a crash report when running firefox %u from the terminal bp-fb3f718a-3fc8-4c93-a253-686aa0190810. I assume that just deleting the %u from the .desktop file would solve the problem but I don't know if this would have any other unintended consequences. Also I would have to redo this every time firefox updates.

''JohannHan [[#answer-1243408|said]]'' <blockquote> Start Firefox in the terminal and see the report. </blockquote> It doesn't seem to crash if I just run firefox with no parameters. If I run firefox %u like it is in the .desktop it gives the same behavior as I described in the original post. Here is a crash report when running firefox %u from the terminal bp-fb3f718a-3fc8-4c93-a253-686aa0190810. I assume that just deleting the %u from the .desktop file would solve the problem but I don't know if this would have any other unintended consequences. Also I would have to redo this every time firefox updates.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

I don't know if this information helps, but I'm using the Gnome desktop. I tried disabling my gnome extensions but that didn't help the crashing either. Interestingly I tried another desktop (cinnamon) and did not get any crashing. Gnome cannot be the problem though because my other computer is running gnome also with no problems with firefox. I would really like to get this problem fixed.

I don't know if this information helps, but I'm using the Gnome desktop. I tried disabling my gnome extensions but that didn't help the crashing either. Interestingly I tried another desktop (cinnamon) and did not get any crashing. Gnome cannot be the problem though because my other computer is running gnome also with no problems with firefox. I would really like to get this problem fixed.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Giải pháp được chọn

In case anyone comes across this in the future, updating to firefox 69 fixed the problem.

In case anyone comes across this in the future, updating to firefox 69 fixed the problem.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.