X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

I can't uninstall Arabic from Firefox for MacOS

Được đăng

I installed Arabic on Firefox for Mac OS using: Preferences > Language and Appearance > Languages > Set Alternatives... > Select a language to add... > Arabic > Add.

Then I tried to remove it using: Preferences > Language and Appearance > Languages > Set Alternatives... > Arabic > Remove.

This only partially worked. Most of Firefox is now back in English, but Arabic still appears all over the place! Take a look at my menus: most of the menus appear in English, but the Firefox menu remains in Arabic!

I tried reinstalling Firefox, but even that didn't get rid of the Arabic.

How do I completely uninstall Arabic from Firefox?

Thanks in advance for saving me: I can't actually read Arabic, so if I can't get rid of it, I'm going to have to ditch Firefox and resort to, heaven help me, Chrome  :(

I installed Arabic on Firefox for Mac OS using: Preferences > Language and Appearance > Languages > Set Alternatives... > Select a language to add... > Arabic > Add. Then I tried to remove it using: Preferences > Language and Appearance > Languages > Set Alternatives... > Arabic > Remove. This only partially worked. Most of Firefox is now back in English, but Arabic still appears all over the place! Take a look at my menus: most of the menus appear in English, but the Firefox menu remains in Arabic! I tried reinstalling Firefox, but even that didn't get rid of the Arabic. How do I completely uninstall Arabic from Firefox? Thanks in advance for saving me: I can't actually read Arabic, so if I can't get rid of it, I'm going to have to ditch Firefox and resort to, heaven help me, Chrome :(
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

This is a bug in Firefox likely caused by not refreshing data in the startup caches.

Try to start Firefox once with the -purgecaches command line switch.


(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Đọc câu trả lời này trong ngữ cảnh 1
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 31.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0

Thông tin chi tiết

cor-el
  • Top 10 Contributor
  • Moderator
17418 giải pháp 157376 câu trả lời
Được đăng

Giải pháp được chọn

This is a bug in Firefox likely caused by not refreshing data in the startup caches.

Try to start Firefox once with the -purgecaches command line switch.


(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

This is a bug in Firefox likely caused by not refreshing data in the startup caches. Try to start Firefox once with the <b>-purgecaches</b> command line switch. *https://developer.mozilla.org/en-US/Command_Line_Options ---- *[https://bugzilla.mozilla.org/show_bug.cgi?id=1564998 Bug 1564998] - Half of interface in different language (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

That fixed the Arabic menus, thank you so much cor-el!

The last vestige of my Arabic experience is the weird text cursor I now get in all Firefox text entry fields: instead of a line, there's a weird point sticking out at the top.

Is this related to the Arabic? Any way I can get it back to the way it was before I foolishly tried installing another language?

Thanks!

That fixed the Arabic menus, thank you so much cor-el! The last vestige of my Arabic experience is the weird text cursor I now get in all Firefox text entry fields: instead of a line, there's a weird point sticking out at the top. Is this related to the Arabic? Any way I can get it back to the way it was before I foolishly tried installing another language? Thanks!
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17418 giải pháp 157376 câu trả lời
Được đăng

Câu trả lời hữu ích

That special caret is the bidi indicator that shows the text direction with a hook of at least 2px that you can switch via "Command + Shift + X" from left (LTR) to right (RTL).

The bidi indicator is shown if the have a bidi keyboard language installed.

That special caret is the bidi indicator that shows the text direction with a hook of at least 2px that you can switch via "Command + Shift + X" from left (LTR) to right (RTL). The bidi indicator is shown if the have a bidi keyboard language installed.

Được chỉnh sửa bởi cor-el vào

Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

Thanks, cor-el.

The "Command + Shift + X" switch from left (LTR) to right (RTL) works, but the bidi indicator won't go away, no matter what.

My locale is set to en-US, but still getting the bidi indicator.

I do still have Arabic installed. Is there any way to uninstall it? I've "removed" it in preferences, but there's no option to uninstall it; and even reinstalling Firefox from scratch doesn't get rid of it.

Wow, if I'd known the issues with switching languages in Firefox, I would never have touched this!

Any clues as to how to uninstall Arabic or get rid of that bidi indicator would be much appreciated!

Thanks, cor-el. The "Command + Shift + X" switch from left (LTR) to right (RTL) works, but the bidi indicator won't go away, no matter what. My locale is set to en-US, but still getting the bidi indicator. I do still have Arabic installed. Is there any way to uninstall it? I've "removed" it in preferences, but there's no option to uninstall it; and even reinstalling Firefox from scratch doesn't get rid of it. Wow, if I'd known the issues with switching languages in Firefox, I would never have touched this! Any clues as to how to uninstall Arabic or get rid of that bidi indicator would be much appreciated!
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17418 giải pháp 157376 câu trả lời
Được đăng

I think that this is about the keyboard layout. Did you never had this bidi caret previously?

You can check the bid prefs on the about:config page.

You can also check "Help -> Troubleshooting Information" (about:support) page to see what locale information Firefox detects.

I think that this is about the keyboard layout. Did you never had this bidi caret previously? You can check the bid prefs on the <b>about:config</b> page. You can also check "Help -> Troubleshooting Information" (about:support) page to see what locale information Firefox detects.
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

Setting bidi.browser.ui to false on the about:config page fixed it!

No, I'd never seen the bidi caret before. It looks like installing Arabic set this preference to true, and removing Arabic and switching back to English didn't set it back to the default false.

So I guess there's a series of bugs here. Not being able to uninstall Arabic (at least, I can't find a way to uninstall it!) is also not great. It shouldn't be so hard/impossible to reverse something so simple as switching a language.

Thank you for all your help, cor-el!

Setting bidi.browser.ui to false on the about:config page fixed it! No, I'd never seen the bidi caret before. It looks like installing Arabic set this preference to true, and removing Arabic and switching back to English didn't set it back to the default false. So I guess there's a series of bugs here. Not being able to uninstall Arabic (at least, I can't find a way to uninstall it!) is also not great. It shouldn't be so hard/impossible to reverse something so simple as switching a language. Thank you for all your help, cor-el!
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.