X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Did Not Connect: Potential Security Issue

Được đăng

Firefox is now displaying this error message with every site that IN FACT they have https connections.

Two things happened since last night.

1. I received a Firefox update last night. 2. I clicked on a link to a bogus news article that Malwarebytes stopped, yet Firefox was affected in that a false Microsoft tab opened and required task manager to kill the Firefox session.

Virus scans were clean.

But something was set in Firefox to automatically open to that tab, which, of course required Task Manager to terminate. Uninstalls, re-installs, blah, blah, blah I was able to stop Firefox from automatically opening to the offending web page.

However, I can not go to any web pages without getting the error warning :Did Not Connect: Potential Security Issue"

Any ideas? Is this a regedit thing? Would there be some entries under Firefox to delete? Is there a list of good things and therefore anything else would be worthy of deletion?

BTW, it is the latest version of Win10 Firefox as of 7/12/2019 and 7/13/2019.

Thoughts pertinent comments appreciated.

Firefox is now displaying this error message with every site that IN FACT they have https connections. Two things happened since last night. 1. I received a Firefox update last night. 2. I clicked on a link to a bogus news article that Malwarebytes stopped, yet Firefox was affected in that a false Microsoft tab opened and required task manager to kill the Firefox session. Virus scans were clean. But something was set in Firefox to automatically open to that tab, which, of course required Task Manager to terminate. Uninstalls, re-installs, blah, blah, blah I was able to stop Firefox from automatically opening to the offending web page. However, I can not go to any web pages without getting the error warning :Did Not Connect: Potential Security Issue" Any ideas? Is this a regedit thing? Would there be some entries under Firefox to delete? Is there a list of good things and therefore anything else would be worthy of deletion? BTW, it is the latest version of Win10 Firefox as of 7/12/2019 and 7/13/2019. Thoughts pertinent comments appreciated.
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

AdGuard and anything that may have come with Firefox as a default.

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Thông tin chi tiết

jscher2000
  • Top 10 Contributor
8579 giải pháp 70146 câu trả lời
Được đăng

Câu trả lời hữu ích

Hi JuliaandDave, this generally means that Firefox received a certificate which couldn't be verified as valid. So the server responding to your request might be an impostor. It's worth investigating why that is happening.

Does the error page show a code in capital letters (e.g., SEC_ERROR_SOMETHING)? Sometimes you may need to click an "Advanced" button or other button to access that information. The following article covers the usual causes of those codes: How to troubleshoot security error codes on secure websites.

Does that help in identifying the problem?

Hi JuliaandDave, this generally means that Firefox received a certificate which couldn't be verified as valid. So the server responding to your request might be an impostor. It's worth investigating why that is happening. Does the error page show a code in capital letters (e.g., SEC_ERROR_SOMETHING)? Sometimes you may need to click an "Advanced" button or other button to access that information. The following article covers the usual causes of those codes: [[How to troubleshoot security error codes on secure websites]]. Does that help in identifying the problem?
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

Thank you jsher2000.

The link you provided is describing my problem and I am getting the error " SEC_ERROR_UNKNOWN_ISSUER".

This problem is only affecting Firefox. Chrome and Edge are not affected.

I would like to get the problem cleared up as Firefox is my default browser.

This confuses me a bit, because I would think if it is a general problem all browsers would be affected.

I will try an uninstall and reinstall of Malewarebytes then check again.

Should that not work, I think my focus will turn back to a registry entry, but now sure what to look for.

I have some other things to take care of for now, so it might be later tonight (GMT-5) or even in the morning, but I will get back.

Thank you. Dave

Thank you jsher2000. The link you provided is describing my problem and I am getting the error " SEC_ERROR_UNKNOWN_ISSUER". This problem is only affecting Firefox. Chrome and Edge are not affected. I would like to get the problem cleared up as Firefox is my default browser. This confuses me a bit, because I would think if it is a general problem all browsers would be affected. I will try an uninstall and reinstall of Malewarebytes then check again. Should that not work, I think my focus will turn back to a registry entry, but now sure what to look for. I have some other things to take care of for now, so it might be later tonight (GMT-5) or even in the morning, but I will get back. Thank you. Dave
Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8579 giải pháp 70146 câu trả lời
Được đăng

Câu trả lời hữu ích

Thanks, Dave. If the article didn't ring any bells, one way to help us help you identify a possible "man in the middle" is to share the certificate information with us. Click the SEC_ERROR_UNKNOWN_ISSUER code and a new section should open with an encoded version of the certificate (gibberishy looking block). You can copy/paste that into a reply.

Thanks, Dave. If the article didn't ring any bells, one way to help us help you identify a possible "man in the middle" is to share the certificate information with us. Click the SEC_ERROR_UNKNOWN_ISSUER code and a new section should open with an encoded version of the certificate (gibberishy looking block). You can copy/paste that into a reply.
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

Okay jsher2000, maybe it was AdGuard that got slammed? I ran several very simple and common web searches and AdGuard is in all and all are blocked.

I will add an image and hope it come through.

Okay jsher2000, maybe it was AdGuard that got slammed? I ran several very simple and common web searches and AdGuard is in all and all are blocked. I will add an image and hope it come through.
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
jscher2000
  • Top 10 Contributor
8579 giải pháp 70146 câu trả lời
Được đăng

Hi JuliaandDave, whenever you want a "man in the middle" of your browsing to read (filter) your browsing, Firefox needs to be set up to trust the fake site certificates it needs to generate. Assuming you like having Adguard do that, their help article for the setup is here: https://kb.adguard.com/en/windows/solving-problems/connection-not-trusted Does that work?

Hi JuliaandDave, whenever you want a "man in the middle" of your browsing to read (filter) your browsing, Firefox needs to be set up to trust the fake site certificates it needs to generate. Assuming you like having Adguard do that, their help article for the setup is here: https://kb.adguard.com/en/windows/solving-problems/connection-not-trusted Does that work?
Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8579 giải pháp 70146 câu trả lời
Được đăng

Sorry, I just realized their steps are from before Firefox 56, so the Options page layout is obsolete. To open the Certificate Manager dialog now:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type cert and Firefox should filter to the "Certificates" section. Then you can click the "View Certificates..." button.

Sorry, I just realized their steps are from before Firefox 56, so the Options page layout is obsolete. To open the Certificate Manager dialog now: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''cert'' and Firefox should filter to the "Certificates" section. Then you can click the "View Certificates..." button.
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17346 giải pháp 156782 câu trả lời
Được đăng

Note that you can find Certificates at the bottom of the "Options/Preferences -> Privacy & Security" section.

Note that you can find Certificates at the bottom of the "Options/Preferences -> Privacy & Security" section.
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

jsher2000 and cor-el,

Thank you for those tips. Apologies for such a late reply, I have been a bit wrapped up with things and using another browser until this is resolve. Really want this resolved, because I am not a fan of that other browser.

Oddly enough, I can get to mozilla sites with Firefox, which I am doing now.

I will be pretty busy through the 26th, but will try to spend some time here and there trying to get this resolved.

Much appreciated.

Thank you.

jsher2000 and cor-el, Thank you for those tips. Apologies for such a late reply, I have been a bit wrapped up with things and using another browser until this is resolve. Really want this resolved, because I am not a fan of that other browser. Oddly enough, I can get to mozilla sites with Firefox, which I am doing now. I will be pretty busy through the 26th, but will try to spend some time here and there trying to get this resolved. Much appreciated. Thank you.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Wait a second.

Just for grins I did a google search and it worked!

I haven't done a thing.

Interestingly enough when I opened Firefox a little thing about content blocking popped up and I went through the 3 pages of info presented, made my comment above, then did my google search, which amazingly worked...?

Go figure.

Wait a second. Just for grins I did a google search and it worked! I haven't done a thing. Interestingly enough when I opened Firefox a little thing about content blocking popped up and I went through the 3 pages of info presented, made my comment above, then did my google search, which amazingly worked...? Go figure.

Được chỉnh sửa bởi JuliaandDave vào

Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.