X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Why are certain web pages I visit starting at the middle of page rather than at the top like normally?

Được đăng

I've been having an issue with Firefox for some time now, like when I load up a video on Youtube or look up pictures on Deviant Art, rather than the page being placed at the top point of the web page, instead it's been moved down the page, even though it's only slightly for Youtube but it's worse on Deviant Art. Like for some reason when I'm browsing, the pictures on the top of results load up at the top correctly but when I go down the results page and click on any picture, the page starts half way down passed the picture and near the comments. I don't think web pages are supposed to start from the middle of the webpage when you load it up.

I've been having an issue with Firefox for some time now, like when I load up a video on Youtube or look up pictures on Deviant Art, rather than the page being placed at the top point of the web page, instead it's been moved down the page, even though it's only slightly for Youtube but it's worse on Deviant Art. Like for some reason when I'm browsing, the pictures on the top of results load up at the top correctly but when I go down the results page and click on any picture, the page starts half way down passed the picture and near the comments. I don't think web pages are supposed to start from the middle of the webpage when you load it up.
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 32.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Thông tin chi tiết

FredMcD
  • Top 10 Contributor
4149 giải pháp 57940 câu trả lời
Được đăng

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Many site issues can be caused by corrupt cookies or cache. '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Well I tried all those, Safe Mode works without having the issue but as for clearing the cookies and cache, it didn't do a thing to resolve it and the Hardware Acceleration thing did nothing either.

Well I tried all those, Safe Mode works without having the issue but as for clearing the cookies and cache, it didn't do a thing to resolve it and the Hardware Acceleration thing did nothing either.
Bài viết này có hữu ích với bạn không?
Trích dẫn
FredMcD
  • Top 10 Contributor
4149 giải pháp 57940 câu trả lời
Được đăng

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17278 giải pháp 156200 câu trả lời
Được đăng

Try to start Firefox once with the -purgecaches command line switch.

Try to start Firefox once with the <b>-purgecaches</b> command line switch. *https://developer.mozilla.org/en-US/Command_Line_Options
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

FredMcD said

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link} Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A) In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox. Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them. If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Well I disabled all the addons and cleared the cookies and cache but it's still happening...

''FredMcD [[#answer-1236716|said]]'' <blockquote> It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective. </blockquote> Well I disabled all the addons and cleared the cookies and cache but it's still happening...
Bài viết này có hữu ích với bạn không?
Trích dẫn
FredMcD
  • Top 10 Contributor
4149 giải pháp 57940 câu trả lời
Được đăng

Give this a try; https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any settings.

Give this a try; https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right-click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any settings.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Doesn't seem to work. So I decided to try something out myself and that being resetting Firefox to default with no addons installed. At first it seemed to work as I try it out on Deviant Art in that websites old site format but sometimes this issue still happens but not all the time. Could it be an issue with Firefox itself?

Doesn't seem to work. So I decided to try something out myself and that being resetting Firefox to default with no addons installed. At first it seemed to work as I try it out on Deviant Art in that websites old site format but sometimes this issue still happens but not all the time. Could it be an issue with Firefox itself?
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17278 giải pháp 156200 câu trả lời
Được đăng

It is possible that the website sets focus to an element further down on the page.

Are you logged in to YouTube? Does this happen when you aren't logged in?

It is possible that the website sets focus to an element further down on the page. Are you logged in to YouTube? Does this happen when you aren't logged in?
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Yes it still happens when you're not logged into Youtube.

Yeah, it does sound like it's an element focus thing that automatically happens when you enter those web pages and it's annoying.

Yes it still happens when you're not logged into Youtube. Yeah, it does sound like it's an element focus thing that automatically happens when you enter those web pages and it's annoying.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.