X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

tinkercad doesn't work with ver 68

Được đăng

Tinkercad is broken with ver 68; worked with 67, no webgl settings changed between Firefox versions. Tinkercad hangs when loading a "project". Everything works on IE 11 and Chrome 75

Tinkercad is broken with ver 68; worked with 67, no webgl settings changed between Firefox versions. Tinkercad hangs when loading a "project". Everything works on IE 11 and Chrome 75
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 32.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; rv:68.0) Gecko/20100101 Firefox/68.0

Thông tin chi tiết

jscher2000
  • Top 10 Contributor
8583 giải pháp 70195 câu trả lời
Được đăng

Hi twspringer, I haven't used that tool myself.

What is involved in loading a project: is the site loading it from their cloud, or are you uploading it from your computer?

Also, I will mention "the usual":

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking.

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi twspringer, I haven't used that tool myself. What is involved in loading a project: is the site loading it from their cloud, or are you uploading it from your computer? Also, I will mention "the usual": If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally: '''Double-check content blockers:''' Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server). (A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: [[Content Blocking]]. (B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. '''Cache and Cookies:''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data" * (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data" * click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? '''Testing in Firefox's Safe Mode:''' In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

The generic solutions were all tried (I'm an ex-IBMer, been troubleshooting for 40 years). Believe it could be webgl-related because of the way the page 'hangs' (freezes) trying to display the items. Similar problem occurred in the past and Tinkercad (Autodesk) listed the Firefox webgl items that needed to be adjusted. Before I go tearing the graphics card/support apart, looking to see if anyone else had this occur after 68 went live. Working in 67 then not in 68 implies to me that something in 68 is suspect.

The generic solutions were all tried (I'm an ex-IBMer, been troubleshooting for 40 years). Believe it could be webgl-related because of the way the page 'hangs' (freezes) trying to display the items. Similar problem occurred in the past and Tinkercad (Autodesk) listed the Firefox webgl items that needed to be adjusted. Before I go tearing the graphics card/support apart, looking to see if anyone else had this occur after 68 went live. Working in 67 then not in 68 implies to me that something in 68 is suspect.
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
jscher2000
  • Top 10 Contributor
8583 giải pháp 70195 câu trả lời
Được đăng

Firefox 68 enabled WebRender, a new graphics engine, for additional users, but I thought it was only on Windows 10, not Windows 7. There is a preference to force-disable it, just in case it's running:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste webren and pause while the list is filtered

(3) Double-click the gfx.webrender.force-disabled preference to switch the value from false to true

This takes effect in your next session (after regular exit/restart of Firefox).

Firefox 68 enabled WebRender, a new graphics engine, for additional users, but I thought it was only on Windows 10, not Windows 7. There is a preference to force-disable it, just in case it's running: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''webren''' and pause while the list is filtered (3) Double-click the '''gfx.webrender.force-disabled''' preference to switch the value from false to true This takes effect in your next session (after regular exit/restart of Firefox).
Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

I also thought webrender didn't apply to Win7. I set force-disabled to true, restarted, and it didn't change things. I'll send this to Autodesk and see what they can find out, as they will have access to the files (projects) from the account to use as test cases.

I also thought webrender didn't apply to Win7. I set force-disabled to true, restarted, and it didn't change things. I'll send this to Autodesk and see what they can find out, as they will have access to the files (projects) from the account to use as test cases.
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.