Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

jigzone website won't "change cut" on puzzles but other browsers work fine.

  • 6 trả lời
  • 1 gặp vấn đề này
  • 605 lượt xem
  • Trả lời mới nhất được viết bởi fjgriff

more options

I have been using Jig zone website for years with Firefox. Recently I am unable to change the cut of the pieces. Everything else including "shuffle pieces" and "autosolve"on the website work fine. I am able to change the cut of the pieces using other browsers. I have been through help on their website without a solution to this issue. I think it is a Firefox issue since every other browser works fine.

Giải pháp được chọn

Hi Bob9754, this is how the style rule override works:

(1) Install a custom styling extension such as Stylus:

https://addons.mozilla.org/firefox/addon/styl-us/

(2) Open a puzzle on the site, and click the Stylus toolbar button and use the drop-down to start a new rule (see attached screenshot #1)

(3) In the editing window, paste this rule -- it clears out the value of the clip property for the table listing the cut types:

/* Override clip property on Change Cut table */
#rc .wn {
  clip: unset !important;
}

See attached screenshot #2

(4) Click Save to save the rule and then check the JigZone page to see whether it is working (see attached screenshot #3).


If you don't want to install a new extension for style rule overrides, you also can apply them using the optional userContent.css file. More info on that here: http://kb.mozillazine.org/UserContent.css

Đọc câu trả lời này trong ngữ cảnh 👍 3

Tất cả các câu trả lời (6)

more options

Hi Bob9754, sorry to hear about this problem. Do you think it started in Firefox 67, released earlier this month?

There is a style rule on the cut types table (the list that pops out) which seems to make it invisible in Firefox 67. I'm not sure why. If I go into the developer tools and remove the following, it works as designed:

#rc .wn {
  clip:rect(0px 600px 400px 0px);
  transition:clip 0.5s ease-out
}

Unfortunately, it's not very convenient for you to find and remove that rule, but you might be able to use an add-on to remove or override it. I'll have to think about that further. Meanwhile, if you haven't reported it to the site, could you let them know about this issue?

more options

Thank you jscher2000 for your response. It is possible that this did occur after the upgrade as the problem has arisen in the past few weeks. I will contact JigzZone.com and let them know what I have been experiencing along with your response.

more options

Giải pháp được chọn

Hi Bob9754, this is how the style rule override works:

(1) Install a custom styling extension such as Stylus:

https://addons.mozilla.org/firefox/addon/styl-us/

(2) Open a puzzle on the site, and click the Stylus toolbar button and use the drop-down to start a new rule (see attached screenshot #1)

(3) In the editing window, paste this rule -- it clears out the value of the clip property for the table listing the cut types:

/* Override clip property on Change Cut table */
#rc .wn {
  clip: unset !important;
}

See attached screenshot #2

(4) Click Save to save the rule and then check the JigZone page to see whether it is working (see attached screenshot #3).


If you don't want to install a new extension for style rule overrides, you also can apply them using the optional userContent.css file. More info on that here: http://kb.mozillazine.org/UserContent.css

more options

I want to thank you jscher2000 for your help. I would have never figured that out. That resolved the problem. I will mark it as solved. Thanks again.

more options

It worked.Thank you, thank you, thank you.Have peace at last and back to Firefox my fave.Safari good bye!

more options

Another big Thank You! I had decided to just give up on my JigZone habit, but every morning found myself clicking on the "Change Cut" button multiple times in hopes it was fixed. This solution was fast and easy. Forever grateful to people like jscher2000 who know this stuff!