X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Disable message Open executable files?

Được đăng

Hi. I need to open the jnlp file but each time it shows me the message "Open executable files? ..." How can I disable this message and open the executable file? Thank you! Thanks!

Hi. I need to open the jnlp file but each time it shows me the message "Open executable files? ..." How can I disable this message and open the executable file? Thank you! Thanks!

Giải pháp được chọn

cor-el said

It looks that another (hidden from about:config) pref got created to suppress the warning.
  • browser.download.skipConfirmLaunchExecutable = true

Yes, that works. Here's how I tested:

(0) Select and copy the new preference name:

browser.download.skipConfirmLaunchExecutable

(1) In a new tab, type about:config in the address bar and press Enter/Return. Click the button accepting the risk -- this change involves some risk.

(2) In the search box above the list, type or paste EXE and pause while the list is filtered

(3) Right-click a blank space and click New, then Boolean.

  • In the little dialog that comes up, paste the preference name and click OK.
  • Click true and then click OK. (If you do not get the options of true and false, you might not have selected Boolean, so cancel and start again.)

Now when you launch a .jnlp or other executable from the Downloads list, it should go straight to the system without the intervening confirmation dialog. Not the safest thing if you tend to download questionable files, but more convenient.

(4) To switch this off, to protect against accidentally running other kinds of executables, double-click the browser.download.skipConfirmLaunchExecutable preference to switch the value from true to false (then in the future, when this is needed, double-click to switch it to true)

Đọc câu trả lời này trong ngữ cảnh 2
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 32.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Thông tin chi tiết

McCoy
  • Top 10 Contributor
534 giải pháp 5035 câu trả lời
Được đăng

Hello maria516,

Would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

browser.download.manager.alertOnEXEOpen

and set its value to false

Then close and restart Firefox.

Does that work  ?

Hello maria516, Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''browser.download.manager.alertOnEXEOpen''' and set its value to '''false''' Then close and restart Firefox. Does that work ?
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
jscher2000
  • Top 10 Contributor
8695 giải pháp 71071 câu trả lời
Được đăng

Hi maria516, is the OK button working for you to launch the JNLP file -- you want to get rid of the extra step -- or is the OK button not working (or disabled)?

When I use Oracle's test file on this page, if I launch from the Downloads list, the file gets deleted, so that's a bit of a pain for testing.

Hi maria516, is the OK button working for you to launch the JNLP file -- you want to get rid of the extra step -- or is the OK button not working (or disabled)? <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-27-13-51-24-612cf8.png" width="500"> ''When I use Oracle's test file on [https://docs.oracle.com/javase/tutorial/deployment/webstart/deploying.html this page], if I launch from the Downloads list, the file gets deleted, so that's a bit of a pain for testing.''
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
534 giải pháp 5035 câu trả lời
Được đăng

Maria516, please ignore my previous post - "jscher2000" told me in a private message that the preference I asked you to toggle, has been disabled .....

Maria516, please ignore my previous post - "jscher2000" told me in a private message that the preference I asked you to toggle, has been disabled .....
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17478 giải pháp 157951 câu trả lời
Được đăng

Câu trả lời hữu ích

It looks that another (hidden from about:config) pref got created to suppress the warning.

  • browser.download.skipConfirmLaunchExecutable = true
It looks that another (hidden from about:config) pref got created to suppress the warning. *browser.download.skipConfirmLaunchExecutable = true *https://dxr.mozilla.org/mozilla-release/source/toolkit/components/downloads/DownloadUIHelper.jsm#115
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
jscher2000
  • Top 10 Contributor
8695 giải pháp 71071 câu trả lời
Được đăng

Giải pháp được chọn

cor-el said

It looks that another (hidden from about:config) pref got created to suppress the warning.
  • browser.download.skipConfirmLaunchExecutable = true

Yes, that works. Here's how I tested:

(0) Select and copy the new preference name:

browser.download.skipConfirmLaunchExecutable

(1) In a new tab, type about:config in the address bar and press Enter/Return. Click the button accepting the risk -- this change involves some risk.

(2) In the search box above the list, type or paste EXE and pause while the list is filtered

(3) Right-click a blank space and click New, then Boolean.

  • In the little dialog that comes up, paste the preference name and click OK.
  • Click true and then click OK. (If you do not get the options of true and false, you might not have selected Boolean, so cancel and start again.)

Now when you launch a .jnlp or other executable from the Downloads list, it should go straight to the system without the intervening confirmation dialog. Not the safest thing if you tend to download questionable files, but more convenient.

(4) To switch this off, to protect against accidentally running other kinds of executables, double-click the browser.download.skipConfirmLaunchExecutable preference to switch the value from true to false (then in the future, when this is needed, double-click to switch it to true)

''cor-el [[#answer-1225636|said]]'' <blockquote> It looks that another (hidden from about:config) pref got created to suppress the warning. *browser.download.skipConfirmLaunchExecutable = true </blockquote> Yes, that works. Here's how I tested: (0) Select and copy the new preference name: browser.download.skipConfirmLaunchExecutable (1) In a new tab, type '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk -- '''this change involves some risk'''. (2) In the search box above the list, type or paste '''EXE''' and pause while the list is filtered (3) Right-click a blank space and click New, then Boolean. * In the little dialog that comes up, paste the preference name and click OK. * Click true and then click OK. ''(If you do not get the options of true and false, you might not have selected Boolean, so cancel and start again.)'' Now when you launch a .jnlp or other executable from the Downloads list, it should go straight to the system without the intervening confirmation dialog. Not the safest thing if you tend to download questionable files, but more convenient. (4) To switch this off, to protect against accidentally running other kinds of executables, double-click the '''browser.download.skipConfirmLaunchExecutable''' preference to switch the value from true to false (then in the future, when this is needed, double-click to switch it to true)
Bài viết này có hữu ích với bạn không? 2
Trích dẫn

Người tạo câu hỏi

Thank you for you help, but this option in about:config in version Firefox 67 don't exist I need open the file many times and message is annoying for my work. I can't find a way to avoid it. Thanks!

Thank you for you help, but this option in about:config in version Firefox 67 don't exist I need open the file many times and message is annoying for my work. I can't find a way to avoid it. Thanks!
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
534 giải pháp 5035 câu trả lời
Được đăng

maria516 said

Thank you for you help, but this option in about:config in version Firefox 67 don't exist

Would you please read jscher2000's post again, especially (3); that preference is hidden, hence you have to select "Boolean".

(who said that computers will make your life easier ..... ?)

''maria516 [[#answer-1225707|said]]'' <blockquote> Thank you for you help, but this option in about:config in version Firefox 67 don't exist </blockquote> Would you please read jscher2000's post again, especially (3); that preference is hidden, hence you have to select "Boolean". (who said that computers will make your life easier ..... ?)
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

Thank you very much !!! I tried and there I could. Really thanks (jscher2000 and McCoy).

(who said that computers will make your life easier .....?)

... and one would think that yes, after closing so many messages
 ; )

Regards.

'''Thank you very much !!!''' I tried and there I could. '''Really thanks (jscher2000 and McCoy).''' (who said that computers will make your life easier .....?) ... and one would think that yes, after closing so many messages ; ) Regards.
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
534 giải pháp 5035 câu trả lời
Được đăng

I'm so glad that you got it right now - well done  !

I noticed that you marked my post as Chosen Solution, but it's jscher2000 who deserves the credits here ..... Would you be so kind as to rectify that Chosen Solution mark  ? You can do so by clicking on the "Undo" button to the right, and then mark jscher2000's post as such.

Thank you in advance, and sorry for putting you through all this trouble.

I'm so glad that you got it right now - well done ! I noticed that you marked my post as Chosen Solution, but it's jscher2000 who deserves the credits here ..... Would you be so kind as to rectify that Chosen Solution mark ? You can do so by clicking on the "Undo" button to the right, and then mark jscher2000's post as such. Thank you in advance, and sorry for putting you through all this trouble.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Carlos 1 giải pháp 2 câu trả lời
Được đăng

cor-el said

It looks that another (hidden from about:config) pref got created to suppress the warning.
  • browser.download.skipConfirmLaunchExecutable = true

Thank you, this works for me.

''cor-el [[#answer-1225636|said]]'' <blockquote> It looks that another (hidden from about:config) pref got created to suppress the warning. *browser.download.skipConfirmLaunchExecutable = true *https://dxr.mozilla.org/mozilla-release/source/toolkit/components/downloads/DownloadUIHelper.jsm#115 </blockquote> Thank you, this works for me.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.