X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

My Operating System is Windows 7, Why an I being told it is XP or Vista

Được đăng

I am running Windows 7, but I am being told by Mozilla that I cannot Update FireFox because XP & Vista area No longer being Supported  ! If my Operating System is Windows 7, Why does Mozilla think I am Running XP or Vista ?

I am running Windows 7, but I am being told by Mozilla that I cannot Update FireFox because XP & Vista area No longer being Supported ! If my Operating System is Windows 7, Why does Mozilla think I am Running XP or Vista ?

Giải pháp được chọn

I assume you do have Firefox 52.9.0 because otherwise there wouldn't be plugins listed other than Flash.

  • Help -> About Firefox

Did you check that you do not run Firefox in compatibility mode? You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

You can try this:

Đọc câu trả lời này trong ngữ cảnh 0
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 32.0 r0
  • 5.1.40416.0
  • VLC media player Web Plugin

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

Thông tin chi tiết

McCoy
  • Top 10 Contributor
473 giải pháp 4275 câu trả lời
Được đăng

Hello,

Your system details show this User agent :

"User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0 "

Would you do this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

privacy.resistFingerprinting

If the value is set to "true" - change it to false

If you had to change the value, then close and restart Firefox.

If that doesn't fix the problem - would you take a look at this article please :

https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

Hello, Your system details show this User agent : "User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0 " Would you do this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''privacy.resistFingerprinting''' If the value is set to "true" - change it to '''false''' If you had to change the value, then close and restart Firefox. If that doesn't fix the problem - would you take a look at this article please : https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
James
  • Top 25 Contributor
  • Moderator
1593 giải pháp 11222 câu trả lời
Được đăng

Câu trả lời hữu ích

4321tvsD said

I am running Windows 7, but I am being told by Mozilla that I cannot Update FireFox because XP & Vista area No longer being Supported  ! If my Operating System is Windows 7, Why does Mozilla think I am Running XP or Vista ?

Also another common reason for this is you could be running Firefox in Windows XP compatibility mode on Windows 7 for some reason.

https://support.microsoft.com/help/15078/windows-make-older-programs-compatible

''4321tvsD [[#question-1259444|said]]'' <blockquote> I am running Windows 7, but I am being told by Mozilla that I cannot Update FireFox because XP & Vista area No longer being Supported ! If my Operating System is Windows 7, Why does Mozilla think I am Running XP or Vista ? </blockquote> Also another common reason for this is you could be running Firefox in Windows XP compatibility mode on Windows 7 for some reason. https://support.microsoft.com/help/15078/windows-make-older-programs-compatible
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
James
  • Top 25 Contributor
  • Moderator
1593 giải pháp 11222 câu trả lời
Được đăng

Note if you want to use the current Release then download from www.mozilla.org/firefox/all/

If you were to do internal updates in the Firefox 52.9.0esr you have you would get updated to current 60.6.3esr and not current 66.0.5 Release.

Make sure you uncheck the Windows XP compatibility mode first if it was in use.

Note if you want to use the current Release then download from www.mozilla.org/firefox/all/ If you were to do internal updates in the Firefox 52.9.0esr you have you would get updated to current 60.6.3esr and not current 66.0.5 Release. Make sure you uncheck the Windows XP compatibility mode first if it was in use.
Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

I typed in privacy.resistFingerprinting, Nothing in the privacy. listings came up with resistFingerprinting ! So I Scrolled down the listings and there was no privacy.resistFingerprinting Listed there 1 Thanks Byron 1

I typed in privacy.resistFingerprinting, Nothing in the privacy. listings came up with resistFingerprinting ! So I Scrolled down the listings and there was no privacy.resistFingerprinting Listed there 1 Thanks Byron 1
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

I am not Computer Technical Enough to do these Functions ! I will take the Computer to the Tech down town ! Thanks for Your Offer to Help ! Byron !

I am not Computer Technical Enough to do these Functions ! I will take the Computer to the Tech down town ! Thanks for Your Offer to Help ! Byron !
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17278 giải pháp 156207 câu trả lời
Được đăng

Giải pháp được chọn

I assume you do have Firefox 52.9.0 because otherwise there wouldn't be plugins listed other than Flash.

  • Help -> About Firefox

Did you check that you do not run Firefox in compatibility mode? You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

You can try this:

I assume you do have Firefox 52.9.0 because otherwise there wouldn't be plugins listed other than Flash. * Help -> About Firefox Did you check that you do not run Firefox in compatibility mode? You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window. You can try this: *download the Firefox installer and save the file to the desktop<br>*https://www.mozilla.org/en-US/firefox/all/ *https://support.mozilla.org/en-US/kb/update-firefox-latest-version
Bài viết này có hữu ích với bạn không?
Trích dẫn
McCoy
  • Top 10 Contributor
473 giải pháp 4275 câu trả lời
Được đăng

4321tvsD said

I am not Computer Technical Enough to do these Functions !
I will take the Computer to the Tech down town !

Totally understandable - to the average user all of this must be abracadabra ......

Good luck  !

''4321tvsD [[#answer-1223040|said]]'' <blockquote> I am not Computer Technical Enough to do these Functions ! <BR>I will take the Computer to the Tech down town ! </blockquote> Totally understandable - to the average user all of this must be abracadabra ...... Good luck !
Bài viết này có hữu ích với bạn không?
Trích dẫn
FredMcD
  • Top 10 Contributor
4150 giải pháp 57941 câu trả lời
Được đăng

Shut down Firefox. Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Right click on Firefox.exe and select Properties. Now select Compatibility. Turn Off Run This Program In Compatibility Mode, and Run This Program As An Administrator.

Do the same for any Firefox shortcuts you have. Now restart Firefox.

'''Shut down Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. Windows: C:\Program Files C:\Program Files (x86) Right click on '''Firefox.exe''' and select '''Properties.''' Now select ''' Compatibility. ''' Turn Off '''Run This Program In Compatibility Mode,''' and '''Run This Program As An Administrator.''' Do the same for any Firefox shortcuts you have. Now restart Firefox.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.