X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

I´m using windows XP, running on an old computer (no money for a new). I use Firefox 52.0. My addons are deactivated and i can´t download them again. What now?

Được đăng

How can I reinstall this: "uBlock Origin Raymond Hill"

Thanks in advance for any help!

How can I reinstall this: "uBlock Origin Raymond Hill" Thanks in advance for any help!

Giải pháp được chọn

hi, sorry for this mishap! mozilla is considering in which way the problem should be addressed for users on legacy versions at the moment.

this would be an unofficial workaround i can offer in the meantime (basically the same steps that the automated hotfix was performing in the still supported versions of the browser):

=

(1) Download the fixed certificate

The updated necessary certificate is available for download at https://hg.mozilla.org/releases/mozilla-release/raw-file/tip/security/apps/addons-public-intermediate.crt

Go to the Options/Preferences page, Advanced section, Certificates panel, then click Certificate Manager. Make sure the Authorities tab is selected, then click Import. Find the file you downloaded and open it, then you should get a dialog - don't check any of the boxes, just click OK. Then you should see the new cert in the list in the Certificate Manager, as shown in Screenshot #1.

(2) Clear the time Firefox last re-verified

This will set Firefox up to check much sooner than it otherwise would check.

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste xpi- and pause while the list is filtered

(C) Right-click the app.update.lastUpdateTime.xpi-signature-verification preference and click Reset on the context menu

Screenshot #2 illustrates the expected result.

(3) Restart Firefox

You can exit Firefox normally, then start it up again. It should take a few seconds, but then your addons should turn back into an active state

Hopefully that will work for you.

Đọc câu trả lời này trong ngữ cảnh 0
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • GEPlugin
  • Google Update
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Shockwave Flash 15.0 r0
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Ứng dụng

  • Firefox 52.9.0
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/52.9.0/WINNT/de/

Tiện ích mở rộng

  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.10 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Kaspersky Protection 20.0.543.1053d-20190328170615 (light_plugin_F88CEF8523DE460F9FA1D6E48BF8D340@kaspersky.com) (không hoạt động)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (không hoạt động)
  • uBlock Origin 1.17.4 (uBlock0@raymondhill.net) (không hoạt động)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: NVIDIA GeForce 7900 GT/GTO
  • adapterDescription2:
  • adapterDeviceID: 0x0291
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 40001682
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: winmm
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 1-31-2013
  • driverDate2:
  • driverVersion: 6.14.13.783
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Direct3D11 not available on this computer', u'type': u'runtime'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D is not available on Windows XP', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: No; Failed to create H264 decoder
  • webgl2Renderer: WebGL creation failed: * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Exhausted GL driver caps.
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 7900 GT/GTO Direct3D9 vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 9

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Có
  • Có thể tiếp cận: Không
philipp
  • Top 25 Contributor
  • Moderator
5287 giải pháp 23361 câu trả lời
Được đăng

Giải pháp được chọn

hi, sorry for this mishap! mozilla is considering in which way the problem should be addressed for users on legacy versions at the moment.

this would be an unofficial workaround i can offer in the meantime (basically the same steps that the automated hotfix was performing in the still supported versions of the browser):

=

(1) Download the fixed certificate

The updated necessary certificate is available for download at https://hg.mozilla.org/releases/mozilla-release/raw-file/tip/security/apps/addons-public-intermediate.crt

Go to the Options/Preferences page, Advanced section, Certificates panel, then click Certificate Manager. Make sure the Authorities tab is selected, then click Import. Find the file you downloaded and open it, then you should get a dialog - don't check any of the boxes, just click OK. Then you should see the new cert in the list in the Certificate Manager, as shown in Screenshot #1.

(2) Clear the time Firefox last re-verified

This will set Firefox up to check much sooner than it otherwise would check.

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste xpi- and pause while the list is filtered

(C) Right-click the app.update.lastUpdateTime.xpi-signature-verification preference and click Reset on the context menu

Screenshot #2 illustrates the expected result.

(3) Restart Firefox

You can exit Firefox normally, then start it up again. It should take a few seconds, but then your addons should turn back into an active state

Hopefully that will work for you.

hi, sorry for this mishap! mozilla is considering in which way the problem should be addressed for users on legacy versions at the moment. this would be an unofficial workaround i can offer in the meantime (basically the same steps that the automated hotfix was performing in the still supported versions of the browser): === (1) Download the fixed certificate The updated necessary certificate is available for download at https://hg.mozilla.org/releases/mozilla-release/raw-file/tip/security/apps/addons-public-intermediate.crt Go to the Options/Preferences page, Advanced section, Certificates panel, then click Certificate Manager. Make sure the Authorities tab is selected, then click Import. Find the file you downloaded and open it, then you should get a dialog - don't check any of the boxes, just click OK. Then you should see the new cert in the list in the Certificate Manager, as shown in Screenshot #1. (2) Clear the time Firefox last re-verified This will set Firefox up to check much sooner than it otherwise would check. (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (B) In the search box above the list, type or paste xpi- and pause while the list is filtered (C) Right-click the '''app.update.lastUpdateTime.xpi-signature-verification''' preference and click Reset on the context menu Screenshot #2 illustrates the expected result. (3) Restart Firefox You can exit Firefox normally, then start it up again. It should take a few seconds, but then your addons should turn back into an active state Hopefully that will work for you.
Bài viết này có hữu ích với bạn không?
Trích dẫn
FredMcD
  • Top 10 Contributor
4220 giải pháp 58899 câu trả lời
Được đăng

It fixed the issue for my v54.


Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version 32.0.0171

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

It fixed the issue for my v54. ------------ '''Separate Security Issue:''' Update your Flash Player or remove it using these links; [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows] {web link} [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac] {web link} '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player '''Version 32.0.0171 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17407 giải pháp 157253 câu trả lời
Được đăng

There is a Legacy system extension coming or is already available to fix this issue for Firefox 52-60. See comment 52.

  • Bug 1549604 - ship legacy system add-ons to remediate armagadd-on 2.0
There is a Legacy system extension coming or is already available to fix this issue for Firefox 52-60. See comment 52. *[https://bugzilla.mozilla.org/show_bug.cgi?id=1549604#c52 Bug 1549604] - ship legacy system add-ons to remediate armagadd-on 2.0
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Thanks to everyone forthe help!

Thanks to everyone forthe help!
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17407 giải pháp 157253 câu trả lời
Được đăng

See comment 51 in bug 549604 for a link to install the legacy version of the hotfix extension to install the intermediate certificate.

There are still unresolved issues that prevent installing the legacy hotfix automatically, but a manual install should work.

See comment 51 in bug 549604 for a link to install the legacy version of the hotfix extension to install the intermediate certificate. *hotfix-update-xpi-signing-intermediate-bug-1548973-legacy@mozilla.org-1.1.2-signed.xpi *https://bugzilla.mozilla.org/show_bug.cgi?id=1549604#c51 There are still unresolved issues that prevent installing the legacy hotfix automatically, but a manual install should work.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.