Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Chủ đề này đã đóng và được lưu lại. Vui lòng hỏi một câu hỏi mới nếu bạn cần giúp đỡ.

For add ons get: Download failed. Please check your connection. message

  • 12 trả lời
  • 1 gặp vấn đề này
  • 5449 lượt xem
  • Trả lời mới nhất được viết bởi FIREFOXED

more options

My Adguard add on was disabled by Firefox about midnight May 3, 2019. Now when I try to install Adguard or any other add on I get the message, "Download failed. Please check your connection." The message occurs whether or not I am signed in to my Firefox account. My security package is Norton Online provided and updated through my ISP Earthlink. Thanks, in advance, for your attention to my problem.

Giải pháp được chọn

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

If you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (12)

more options

This is a problem with an expired intermediate certificate that is used to verify signed extensions that causes extensions to get disabled. This is being worked on.

See also:

At about 6:10 PST we received a report that a certificate issue for Firefox is causing add-ons to stop working and add-on installs to fail.
Our team is actively working on a fix. We will update as soon as we have more information.
  • Bug 1548973 - (armagadd-on-2.0) All extensions disabled due to expiration of intermediate signing cert

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options

I can't download any add-ons, instead I keep getting "Download failed. Please check your connection." error message despite which add-ons I try to download. My connection is fine. I see other people are having the same problem. Hope they get it fixed with the next update. Tom Szaller

more options

Giải pháp được chọn

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

If you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

more options

Adblock plus and i don't careabout cookies add ons stopped working. Tried to reinstalland get "Download failed. Please check your connection"

about:config settings

services.sync.prefs.sync.xpinstall.whitelist.required;true xpinstall.customConfirmationUI;true xpinstall.signatures.devInfoURL;https://wiki.mozilla.org/Addons/Extension_Signing xpinstall.signatures.required;false xpinstall.whitelist.required;true win 7 64 bit


Changing xpinstall.signatures.required;true to xpinstall.signatures.required;false worked on android phone

Được chỉnh sửa bởi FIREFOXED vào

more options

Chris Ilias said

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled
  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.
If you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.

Thanks for that Have checked allow run studies

more options

Hope they can do it for the next update. Thanks for your help. Tom Szaller

more options

I have noticed i have version 56 32 bit on a 64 bit system. I have updated to version 66.03 64 bit and have most of my addons that matter back. Adblock and I don't care about cookies for example. But i have lost Better Privacy. Is it true that clearing cache when closing the browser or history/clear recent history/cache removes the LSO's

Được chỉnh sửa bởi FIREFOXED vào

more options

FIREFOXED said

... i have lost Better Privacy. Is it true that clearing cache when closing the browser or history/clear recent history/cache removes the LSO's

I thought Firefox follows cookie settings and applies those to clearing Flash LSO's, but I haven't looked into it for a long time.

As you may know, Adobe maintains the online console on the old Macromedia site that lets you clear LSO's by site, so that is a manual workaround if needed:

https://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager07.html

(Flash needs to be enabled on the site, naturally.)

more options

I followed the method described, to allow Firefox to install and run studies, and this temporarily fixed the issue. After the issue was fixed I turned off Firefox's ability to run studies. After an hour or so, after I closed and then opened Firefox (v66) again, I had the same problem. So, I again allowed Firefox to install and run studies, shutdown Firefox then reopened it, but now the add-on issues have not gone away.

more options

Hi Bill, I'm sorry to hear the problem came back right away. After the study installs an extension, it stays active for a little while and then goes to the completed list. I don't think it's meant to have to run again, and I'm not sure what happened to disable your extensions a second time.

Could you try renaming your extension registry file to force Firefox to rebuild it? Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using any one of these three methods:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

First, make a backup of your extensions list. Scroll down the page to the Extensions heading and copy/paste the table that follows it somewhere like a text editor or word processing document.

Next, scroll back up to the first table on the page. On the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in File Explorer.

If you are a Mac user: click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder.

Leaving that window open, switch back to Firefox and Exit or Quit, either:

  • "3-bar" menu button > Exit / Quit
  • (Windows menu bar) File > Exit
  • (Mac menu bar) Firefox > Quit

Pause while Firefox finishes its cleanup, then right-click > Rename extensions.json to something like extensionsOLD.json (Firefox will ignore this file, but you will still have it if needed in the future).

Start Firefox back up again, and it should rediscover and re-verify your extensions. Any improvement?

more options

Yes. That got back my Extensions/Themes. If it happens again I know what to do. Thanks very much.

more options

Back to normal . Thanks Chris Ilias