Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

all my installed browser extensions where suddenly disabled and I cannot re-install them

  • 28 trả lời
  • 6 gặp vấn đề này
  • 289 lượt xem
  • Trả lời mới nhất được viết bởi notnats

more options

Just today Mozilla suddenly reported that several of my extensions where outdated and had been disabled. When I checked the 'legacy extension list' is showed every single extension as being unsigned, the list includes:

Add Block Plus IDM Integration module Malwarebytes browser extension

I have gone to the add on page and tried to install (or re-install) the latest version of each of these and it fails with the error "Download failed. Please check your connection." As I know my network connection is good, this is clearly bogus. So far all I have done otherwise is run a full virus scan with malwarebytes (and got nothing) and reboot just in case. Some searches on the web have turned up installation failures like i am getting, but most of them where a year ago or more and specific to a given add on. I haven't found anything on mass disabling all extensions.

Currently running version 66.0.3 (64 bit) of mozilla.

Thanks for any help you can provide, Eric Hough

Giải pháp được chọn

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (20)

more options

I found the answer to this, although it is not a fix - there is a bug currently logged in regards to all extensions being disabled for anyone whose system clock shows later than 6pm pacific time. But can be found at https://bugzilla.mozilla.org/show_bug.cgi?id=1548973

more options

(If you saw the bug, this isn't news to you)

The Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.)

I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon.

more options

It's worse than that. I was afraid that I had a virus so I uninstalled and then reinstalled Firefox. That made google my default search engine. I changed it back to Duck Duck Go, but Firefox won't allow me to go to Duck Duck Go. I can't even get to Mozilla.org (I'm on Chrome now). I can't get to Avast to restore my anti-virus extension. So, I've lost everything in my profile. I can find that in a backup and restore it, but this is incredibly disruptive. Doesn't Mozilla test such things before making a production release? I updated a few days ago, so this did not occur upon update. Right now, Firefox is completely useless.

more options

Hi stevengoldfield, are you getting an unsecure connection error on DDG and Mozilla? It may be the Avast WebShield. See: How to troubleshoot security error codes on secure websites.

more options

I restored my profile from backup and not only did I get everything back, my extensions are also back and enabled.

more options

jscher2000 said

Hi stevengoldfield, are you getting an unsecure connection error on DDG and Mozilla? It may be the Avast WebShield. See: How to troubleshoot security error codes on secure websites.

No, Avast was one of the extensions that was disabled by Firefox. After restoring my profile from backup, everything looks fine.

more options

stevengoldfield said

jscher2000 said
Hi stevengoldfield, are you getting an unsecure connection error on DDG and Mozilla? It may be the Avast WebShield. See: How to troubleshoot security error codes on secure websites.

No, Avast was one of the extensions that was disabled by Firefox. After restoring my profile from backup, everything looks fine.

Great to her you had a backup!

Also, Avast WebShield runs outside of Firefox as a proxy. It sees everything going in and out even if the extension is disabled.

more options

I spoke too soon. It looks like Avast was lost, and I get an error when I try to re-add it.

more options

Hi stevengoldfield, the problem with add-ons is caused by a certificate expiring. Currently, the only workaround is to roll your clock back to a time when the verification will pass (for example, set your Windows system date to the previous day). I'm not sure that's a good idea, but it's the only thing I've heard of so far.

more options

Now my only problem is that I'm unable to re-install the Avast Online Security extension.

more options

My extensions were all disabled again. I guess there was a delay. I rolled my clock back a day, but that had no effect.

more options

I was able to re-add Avast Online Security. Now, it is my only enabled extension. What a mess.

more options

I'm removing my extensions one at a time and re-adding them. So far, it's working, though they might be disabled again.

more options

I got about halfway through re-adding my extensions when all the rest became enabled again. very strange

more options

stevengoldfield said

I got about halfway through re-adding my extensions when all the rest became enabled again. very strange

Possibly an automatic update was triggered? (We haven't been given an explanation for what triggers either the disabling or the re-enabling.)

more options

All of my extensions are blocked. Cannot even download them. I have removed all except uBlock Orgin and Firebug. Please fix this.

more options

Hi ccvortex, a critical Add-on-related certificate expired (which obviously should not happen). As a result, all verifications for that certificate are failing.

The Add-ons team is working on a fix for this. Official updates are expected to be posted here:

https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047

Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal.

By the way, what version of Firefox still runs Firebug?

more options

Giải pháp được chọn

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

more options

Chris Ilias said

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled
  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.
I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.

No fix in place yet :-( I'm keeping my clock at May 2 until further notice.

more options

In about:studies, I see Completed studies

   hotfix-reset-xpi-verification-timestamp-1548973•Complete
   This study sets app.update.lastUpdateTime.xpi-signature-verification to 1556945257

However, I also read that there is a bug filed because of reports that this does not always fix the problem. I see that it is set to 1556830113 in about:config. I'm going to manually set it to that value. Then I'll reset the clock and see what happens. So far, so good.

Được chỉnh sửa bởi stevengoldfield vào

  1. 1
  2. 2