Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Why won't your so-called "awesome bar" work as a normal bar???

  • 23 trả lời
  • 1 gặp vấn đề này
  • 292 lượt xem
  • Trả lời mới nhất được viết bởi thestilow

more options

The address bar is a simple concept. You type an address in, you hit <Return>, and the browser takes you there.

Not in Firefox 66.0.3!

In 66.0.3 you type in an address (meanwhile the bar is giving you random crap to "help" you and there's no way to turn this off), you hit return, and....nothing!

The only way to actually go where you want to go is to type the address, *click or tab OUT of the bar*, and then *re-enter the bar*. Then and ONLY then will <Return> actually do something.

Based on other questions, this has happened before too.

Why can't you just have an address bar that works as an address bar?

Giải pháp được chọn

FIXED!!

Evidently around Firefox 64 or 65 is (probably) when the issue started.

I use CSS style sheets for the classic "tabs not on top" look plus a few other "classic" looks. I had not updated those files in a while so when the profile test (and "safe mode" test) seemed to point to the CSS sheets not working properly I checked the new ones out.

Turns out that new code had to be written for the "tabs not on top" look starting in Firefox 65, and there were some search and autocomplete stuff that were redone in 64.

So...the verdict is...Firefox did change *something*, which invalidated my CSS sheets, so I needed to update those.

Anyway, I downloaded the new versions, made my edits, and now everything seems to work properly.

Thanks everyone for the help!

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (20)

more options

Hello thestilow,

Would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

keyword.enabled and set its value to false

Then close and restart Firefox.

(this will disable searching from the address bar)


To disable all other bleep I think you are talking about :

Type in the search bar browser.urlbar.

Look for the preference :

browser.urlbar.maxRichResults

And set its value to 0 (= zero)

Then close and restart Firefox.

Should this not be what you want, then change the value back to 10 (= default)


In case you are also seeing this "Search with .... " :

Type in the address bar and look for the preference :

browser.urlbar.oneOffSearches and set its value to false

Then close and restart Firefox.


'Hope this helps ......

more options

See also this pref on the about:config page:

  • browser.urlbar.autoFill
more options

Enacted all of the above. The search crap went away, but the <Return> key still doesn't work unless I click/tab out or click the -> sign at the end of the line.

While I am somewhat conversant in the about:config page, none of the browser.urlbar entries looked like they would help with this (unless the key is an obscure one). And I don't know about enough about the structure to go poking around (in a reasonable amount of time).

more options

thestilow said

Enacted all of the above. The search crap went away, but the <Return> key still doesn't work unless I click/tab out or click the -> sign at the end of the line.

I did what McCoy listed and it works. As far as your [ENTER] (or RETURN) key... mine works. Make sure your cursor is not being 'focused' elsewhere. Otherwise, clicking the 'Enter/Go Right-Arrow' is not such a bad deal, yes/no?


~Pj

Được chỉnh sửa bởi Pj vào

more options

Yes, it's a bad deal. If I am typing, I don't want to have to reach for my mouse in order to execute; I'm going to hit <Enter>.

I use Firefox both at work and at home. At work the version is controlled by IT so it's one of the ESR releases. No problems with <Enter>. Additionally, creating a new tab with an address bar doesn't result in a "right-arrow" at the end of the bar...it's the down-caret. At home, with 66.0.3, clicking into the address bar produces a "right-arrow". No <Enter>. No bueno.

more options

The only threads I remember where Enter did not work involved completely disabling all of the four types of autocomplete suggestions, and as far as I can tell, that has been fixed by now.

I cannot think of any reason that moving focus out of and back into the address bar should make the Enter key work when it didn't work the first time. You would expect consistent behavior, so this is very odd.

Instead of changing focus, does it make any difference if you press the Esc key once to cancel the autocomplete drop-down and then press Enter?

Also, what was the last version where the address bar worked normally?

more options

I'm not sure about the last version, sorry. I allow updates automatically, so I don't pay attention. Which I should.

Escape before <Enter> does not work.

Behavior: 1. Create new tab (address bar shows "down-caret") 2. Verify cursor is blinking in address bar 3. Begin typing (down-caret immediately changes to green "right-arrow" 4. At this point I have to click off in some manner or click the right arrow. Interestingly, changing tabs will work. Also, Alt-Tab all the way around to the original tab (not actually changing tabs) also works. But hitting <Enter> immediately does NOT work.

more options

thestilow said

I'm not sure about the last version, sorry.

But probably at some point after the release of Firefox 66 on March 19, 2019?

If you haven't already, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Sorry for the late reply, but I've been busy and haven't really had time to check stuff out. I did *not* do a "safe mode" restart (yet), but I did have all my add-ons drop out because of the glitch in 66.0.3. Have since updated to 66.0.4 and no improvement.

more options

Oh, and it still didn't work in 66.0.3 with all the add-ons killed.

more options

In 66.0.4 safe mode, <Enter> seems to work fine on a new tab.

Is there a CSS code that affects this?

more options

Double-check 66.0.4 in "normal" mode, I have to click *somewhere* to get <Enter> to work. To include inside the bar. No click, no go.

more options

thestilow said

In 66.0.4 safe mode, <Enter> seems to work fine on a new tab.

But not when you already have a page loaded and you want to navigate the current tab to a different page.

Is there a CSS code that affects this?

Hmm, do you mean is it possible that something in a userChrome.css file could be causing this problem? I don't know. If I need a form field not to do something when a user presses Enter, I used to need a script. I can't recall any style rules that can do that.

more options

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

more options
  • sigh*

Turning off HW acceleration...no-go. Updating graphics drivers...no-go.

Still have the issue.

more options

I can't think of any setting to replicate the problem. Maybe there is some gunk in the program folder. For that we typically recommend:

Clean Reinstall

This takes about 5 minutes. It's not about your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data.

(A) Download a fresh installer for Firefox to a convenient location, either:

(B) Exit out of Firefox (if applicable).

If you use Microsoft Office, please change your default browser to Internet Explorer temporarily before the next step.

(C) Using Windows Explorer/My Computer (hold down the Windows key and press E to launch it), right-click > rename the program folder as follows (you might have one or both):

C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox

C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement at your next startup?

If you have intentionally introduced Autoconfig or policies.json to your current program folder, you will need to migrate them to the new folder manually, but preferably after testing.

more options

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

jscher2000...clean reinstall did not cure the issue.

cor-el...will have to try your suggestion another time.

more options

thestilow said

Behavior:
  1. Create new tab (address bar shows "down-caret").

  2. Verify cursor is blinking in address bar.

  3. Begin typing (down-caret immediately changes to green "right-arrow".

  4. At this point I have to click off in some manner or click the right arrow. Interestingly, changing tabs will work. Also, Alt-Tab all the way around to the original tab (not actually changing tabs) also works. But, hitting <Enter> immediately does NOT work.

So, after the last character is typed, you still have a blinking cursor. You press [Enter] and nothing happens. Is the cursor still there, blinking in the Address Bar?

Whether it's there or not, what happens when you press [Enter] and wait up until 2 minutes before doing anything else?


~Pj

more options

Pj said

So, after the last character is typed, you still have a blinking cursor. You press [Enter] and nothing happens. Is the cursor still there, blinking in the Address Bar?

Yes

Whether it's there or not, what happens when you press [Enter] and wait up until 2 minutes before doing anything else?

Nothing. Waited about 3 minutes.

  1. 1
  2. 2