Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Green screen on video, disabling hardware acceleration did not help

  • 7 trả lời
  • 2 gặp vấn đề này
  • 222 lượt xem
  • Trả lời mới nhất được viết bởi McCoy

more options

Hi, since a couple of days ago, I've had green screens appear on all videos that I attempt to play in Firefox. The audio still works fine, but there is no video. I have not installed or updated any add-ons recently. I do not have any problem viewing videos in other browsers (Chrome, Safari...) on the same machine.

Steps already taken: 1) Disabled hardware acceleration in Firefox preferences and restarted - no change 2) Set "webgl.disabled" to "true" in about:config and restarted - no change 3) Emptied cache and deleted cookie and restarted - no change

Any ideas appreciated, and happy to provide further details / logs if helpful

Giải pháp được chọn

mbimmler said

Wonder whether it's related to https://bugzilla.mozilla.org/show_bug.cgi?id=1546836 but I'm clearly out of my technical depth here..

You posted this while I was typing my suggestion to try to toggle that preference on the "about:conffig' page - had a look at that bug report and you're right.

Thank you for pointing that out  !

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (7)

more options

Wonder whether it's related to https://bugzilla.mozilla.org/show_bug.cgi?id=1546836 but I'm clearly out of my technical depth here..

more options

Hello mbimmler,

Would you please try this on the "about:config" page :

Type in the search bar :

media.wmf.dxva.

Search for the preference :

media.wmf.dxva.d3d11.enabled and set its value to false

Then close and restart Firefox.

Does that help  ?

more options

Thanks McCoy, but I don't appear to have the "media.wmf.dxva.d3d11.enabled" in my about:config - in fact, I don't have anything with "media.wmf" at all.

When filtering for "media.w", I only get preferences beginning with "media.webrtc", "media.wave", "media.webaudio", "media.webm", "media.webspeech" or "media.webvtt"

Best, Michael

Được chỉnh sửa bởi mbimmler vào

more options

Giải pháp được chọn

mbimmler said

Wonder whether it's related to https://bugzilla.mozilla.org/show_bug.cgi?id=1546836 but I'm clearly out of my technical depth here..

You posted this while I was typing my suggestion to try to toggle that preference on the "about:conffig' page - had a look at that bug report and you're right.

Thank you for pointing that out  !

more options

Thanks for confirming! Looks like they were able to fix it quite easily and in the time for 67b15 on Monday (?), so that should work again soon then :)

more options

Note that Windows Media Foundation (wmf) is only for Windows OS and not for Mac (the OP is on Mac) and Linux.

more options

cor-el said

Note that Windows Media Foundation (wmf) is only for Windows OS and not for Mac (the OP is on Mac) and Linux.

Thank you for pointing that out, cor-el.