X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

disable autoplay globally

Được đăng

Previously Firefox allowed for Autoplay to be disabled Globally, that is to say one setting in about:config disabled the functionality on all websites - no issues!

Now I have to apply the setting on a local basis, that is to say that I must first visit the website and be infuriated by an autoplay monstrosity before I am able to disable its functionality - whilst also wasting data as I am using a metered connection to access the web via desktop and laptop (rural location).

As someone who has previously donated to the cause, and has both the T-Shirt and Certificate to prove it, I am most disappointed by this change which seems to favour the individual websites more than the end consumer - without whom Firefox would not be what it is today!

Needless to say, I am most disappointed by this sudden and somewhat confusing change. I hope this shall be remedied in an upcoming release.

Yours sincerely,

Elliot J Knightall.

Previously Firefox allowed for Autoplay to be disabled Globally, that is to say one setting in about:config disabled the functionality on all websites - no issues! Now I have to apply the setting on a local basis, that is to say that I must first visit the website and be infuriated by an autoplay monstrosity before I am able to disable its functionality - whilst also wasting data as I am using a metered connection to access the web via desktop and laptop (rural location). As someone who has previously donated to the cause, and has both the T-Shirt and Certificate to prove it, I am most disappointed by this change which seems to favour the individual websites more than the end consumer - without whom Firefox would not be what it is today! Needless to say, I am most disappointed by this sudden and somewhat confusing change. I hope this shall be remedied in an upcoming release. Yours sincerely, Elliot J Knightall.

Giải pháp được chọn

Hi, the ability to disable autoplay globally is being rolled out gradually in Firefox 66 - which you have. So if you don't see the setting just now, it should become available soon in: 3-bar menu > Options > Privacy & Security > Permissions. Please see Allow or block media autoplay in Firefox

Thank you for your donations and support!

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Thông tin chi tiết

cor-el
  • Top 10 Contributor
  • Moderator
17539 giải pháp 158588 câu trả lời
Được đăng

Câu trả lời hữu ích

You can look at these prefs on the about:config page to see if these values work for you.

  • media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt]
  • media.autoplay.allow-muted = false
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you.

You can look at this extension.

You can look at these prefs on the about:config page to see if these values work for you. *media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt] *media.autoplay.allow-muted = false *media.autoplay.enabled.user-gestures-needed = false For user-gestures-needed you can try false and true to see what works for you. You can look at this extension. *Disable HTML5 Autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/

Người tạo câu hỏi

Thank you for your reply.

The settings you have provided are ineffectual for me under any conditions.

However after posting my concern I found the Add-on you have quoted and can confirm its effectiveness.

Again I thank you for your time and the reply, but I still sincerely hope that this matter is rectified internally in due course - either that or I downgrade to 59 which did work.

Thank you for your reply. The settings you have provided are ineffectual for me under any conditions. However after posting my concern I found the Add-on you have quoted and can confirm its effectiveness. Again I thank you for your time and the reply, but I still sincerely hope that this matter is rectified internally in due course - either that or I downgrade to 59 which did work.
Scribe 731 giải pháp 3482 câu trả lời
Được đăng

Giải pháp được chọn

Hi, the ability to disable autoplay globally is being rolled out gradually in Firefox 66 - which you have. So if you don't see the setting just now, it should become available soon in: 3-bar menu > Options > Privacy & Security > Permissions. Please see Allow or block media autoplay in Firefox

Thank you for your donations and support!

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Hi, the ability to disable autoplay globally is being rolled out gradually in Firefox 66 - which you have. So if you don't see the setting just now, it should become available soon in: 3-bar menu > Options > Privacy & Security > Permissions. Please see [[Allow or block media autoplay in Firefox]] Thank you for your donations and support! ''If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!''
cor-el
  • Top 10 Contributor
  • Moderator
17539 giải pháp 158588 câu trả lời
Được đăng

What Scribe posted above is merely a change to the media.autoplay.default pref and change the default from 0 (allowed) to 1 (blocked). If you modify the media.autoplay prefs like I posted above then you achieve the same result.

What Scribe posted above is merely a change to the media.autoplay.default pref and change the default from 0 (allowed) to 1 (blocked). If you modify the media.autoplay prefs like I posted above then you achieve the same result.
moz2u 1 giải pháp 105 câu trả lời
Được đăng

media.autoplay.default setting to 1 doesn't make any different to Yahoo Finance which seems determined to play their drivel no matter the setting. Its just an abomination that Mozilla has to be so spineless, so limp wristed, that they have to cower to the powers around them that so easily influence their decisions. You have to be a brain dead moron to want videos to play automatically. This is truly the boundary between functioning minds and people that no longer control any mental activity. There is nothing more distracting than stuff playing unnecessarily, taking your attention away from what you're trying to accomplish.

You think this isn't important? I can assure you it is. Because as the vast majority of our information is gleaned from the internet and text is and always will be the best way of disseminating information, having unwanted videos droning away, wasting bandwidth and distracting our attention is VERY important if you care about how society deals with its problems. Because that really is why we usually go online: To fix problems. Anything that interferes with that is a huge issue and needs to be addressed.

media.autoplay.default setting to 1 doesn't make any different to Yahoo Finance which seems determined to play their drivel no matter the setting. Its just an abomination that Mozilla has to be so spineless, so limp wristed, that they have to cower to the powers around them that so easily influence their decisions. You have to be a brain dead moron to want videos to play automatically. This is truly the boundary between functioning minds and people that no longer control any mental activity. There is nothing more distracting than stuff playing unnecessarily, taking your attention away from what you're trying to accomplish. You think this isn't important? I can assure you it is. Because as the vast majority of our information is gleaned from the internet and text is and always will be the best way of disseminating information, having unwanted videos droning away, wasting bandwidth and distracting our attention is VERY important if you care about how society deals with its problems. Because that really is why we usually go online: To fix problems. Anything that interferes with that is a huge issue and needs to be addressed.