Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox 65 UserChrome.css Not working

  • 2 trả lời
  • 1 gặp vấn đề này
  • 33 lượt xem
  • Trả lời mới nhất được viết bởi MarkusBorsy

more options

Hello, For quite a while I was using a custom UserChrome.css that removed minimize\maximize\close buttons from the tab bar. It looked like this:

/* Firefox userChrome.css */

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* Hide min, max, close in title bar */

  1. titlebar-min, #titlebar-max, #titlebar-close

{ display: none !important; }

/* Hide minimize, restore, close in full screen */

  1. minimize-button, #restore-button, #close-button

{ display: none !important; }

But after latest update (to Firefox 65 I believe) the app doesn't recognize the code in UserChrome.css.

I understand from Fx 65 change notes there were some changes to how Firefox parses css, isn't it?

What should I do to make UserChrome.css work?

I would appreciate any other method of removing minimize\maximize\close buttons from the tab bar if it isn't doable with UserChrome.css now.

EDIT: forum formatting doesn't show the code correctly. Here's pastebin: https://pastebin.com/1cBDgCJs

Được chỉnh sửa bởi MarkusBorsy vào

Tất cả các câu trả lời (2)

more options

The selectors for the buttons in the title bar were changed to class names.

.titlebar-min, .titlebar-max, .titlebar-close 

If you want to hide them all then best would be to hide the container.

.titlebar-buttonbox-container {display:none!important;}

The IDs for the window control buttons haven't changed and that code should still work. In that case you also can hide the container that has these buttons.

#window-controls {display:none!important;}
more options

cor-el said

If you want to hide them all then best would be to hide the container.
.titlebar-buttonbox-container {display:none!important;}

Thank you! This worked.

Also I've tried #window-controls - it didn't work.