Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Movie Trailers or Clips will not play on Metacritic

  • 24 trả lời
  • 2 gặp vấn đề này
  • 109 lượt xem
  • Trả lời mới nhất được viết bởi DeanA320

more options

Movie trailers will not auto-play after the 30 second intro ad.

After the ad the video remains blank.

This problem also exists when Firefox is restarted in safe mode.

Works fine when using other browsers such as Chrome or Edge!

Please look into this!

Giải pháp được chọn

Firefox 64.0 works now on Metacritic.

Thanks to all for taking time to help.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (20)

more options

Please provide a public link (no password) that we can check out. No Personal Information Please !


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

No this did not work. Same problem, ad video plays but then a blank black screen where the trailer should begin to play.

Computer restarted in safe mode networking.

Also tried with Firefox in safe mode.

P.S. don't see why computer restart in safe mode networking is required....Chrome and Edge works just fine!

Any other thoughts?

more options

DeanA320 said

don't see why computer restart in safe mode networking is required

If the problem goes away, that tells us one thing. If it does not, that tells us something else.

FredMcD said

Please provide a public link (no password) that we can
check out. No Personal Information Please !
more options
more options

I had no problem with the player. The first clip ran fine. Then the 2nd, 3rd . . . .

https://www.youtube.com/html5 YouTube Test Page: What video does this browser support

more options

Strange!

I'm at total loss for words!

I just checked my wife's laptop and Firefox plays the metacritic vids...only because her Firefox is 62.0.3 and is not up to date.

My Firefox is up-to date 63.0.1 (as of November 8, 2018)

What's going on?

Được chỉnh sửa bởi DeanA320 vào

more options

I called for more help.

more options

See also:


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console about what content is blocked

Được chỉnh sửa bởi cor-el vào

more options

Thank-you!

I appreciate your help very very much!

It's people like yourself that make a difference!

Hopefully it the mystery can be solved!

Regards Dean

more options

After reading the links provided...still no success.

Attached are some screen shots.

more options

I also removed all Add Block extensions. Turned off my Kaspersky.

Still unable to play.

more options

Web Console screen shot.

more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.


You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Deleting history and Forget this Site has no affect!

New Profile....nah...not doing that!

However.......

I downgraded to Firefox 62.0.3 ...and Metacritic videos now work!

Have no idea why this previous version works, but it does. Someone better have a look at the 63.0.1 - no beuno for me!

Could someone figure out why?

Not ideal to be using an out of date version!

Regards!

Được chỉnh sửa bởi DeanA320 vào

more options

I can confirm that my wife's computer was able to play the trailers because she was on older Firefox 62.0.3.

After updating to 63.0.1, she was also unable to play the movie trailers.

Seems to be a bug in Firefox 63.

Được chỉnh sửa bởi DeanA320 vào

more options

Did you check the Web Console for media related messages?

more options

Yes...I provided a web console screen shot in my previous posts above.

I don't know how to interpret the console messages...thus I posted a screen shot in my earlier post.

I figured someone looked at it already.

more options

Anyways...since this problem is on two separate computers...we can rule out that the problem is local to a single device and its settings.

Like i said earlier...it works fine in Chrome and Edge as well as older version Firefox 62.0.3.

Được chỉnh sửa bởi DeanA320 vào

more options

I saw there was a Firefox update to 63.0.3.

I did the update...and sorry to report, Metacritic trailers still do not play.

Downgraded to 62.0.3...which works fine.

Will wait for the next update.

Được chỉnh sửa bởi DeanA320 vào

more options

Hi DeanA320

Metacritic is doing something funky with trackers. Firefox 63 blocks some content trackers by default (and Firefox 62 doesn't block those trackers)

I was able to get metacritic to work in Firefox 63.0.3 by turning off the default-new-to-63-content-blocking:

1. about:preferences#privacy 2. Making sure "All Detected Trackers" is not checked 3. and by enabling auto-play: 4. about:config Set media.autoplay.default to 2 and allowing auto-play on metacritic.com <---- this about:config stuff is brittle and might break in a future release

Hope that helps!

....Roland

Được chỉnh sửa bởi Roland Tanglao vào

  1. 1
  2. 2