Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have received a notice from Amazon that my browser does not support modern security standards, but the Mozilla site says I am using the latest Firefox version

  • 7 trả lời
  • 1 gặp vấn đề này
  • 28 lượt xem
  • Trả lời mới nhất được viết bởi James

more options

While accessing Amazon via an email link, I received a notice saying that the browser I was using does not support modern security standards that Amazon and others use to protect customers. I was asked to update my browser to protect my payment information. I went to the Mozilla site and it tells me I am using the latest version of Firefox. What else should I do?

Tất cả các câu trả lời (7)

more options

That's weird...

Thank you for sharing your add-on info, listing Avast. If you haven't already, could you try disabling the Avast WebShield? That is a "man in the middle" of your connection to websites. Even if you have a highly secure connection to the WebShield, Avast controls the connection to the website. So I'd like to rule out that possibility.

This article has information on tracking that down in Avast's controls: How to troubleshoot security error codes on secure websites.

more options

Disabled WebShield completely. Did not change result. The complete 'message' I am getting when I click on the Amazon link in an email is as follows:

The browser or mobile device you use to access the internet does not support modern security standards that Amazon and others use to protect customers. To complete the entry of your payment information, please upgrade or use a different browser or mobile device to ensure that your experience on Amazon will be uninterrupted.

more options

I did further troubleshooting. There are five links in the Amazon email. I tried them all. The 'error message' does not come up if I click on the link for the book that is 'featured' in the email, but does for the 4 additional books that are under the "Recommended for You" heading. Same occurred for several previous Amazon recommendation emails that I went back to and tried again. Perhaps problem is Amazon's

more options

Hmm, do you notice any difference in how the successful and unsuccessful links are routed? Commercial emails usually have heavy tracking on links and you may be redirected over multiple servers before landing on the ultimate destination page. Possibly a privacy-related feature or add-on is modifying the information provided by Firefox to some of those pages, causing the message. But that's just a guess.

more options

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect.

more options

Note that this is probably about supporting TLS 1.3.

You can check your browser.

more options

Actually it may be about using a browser that supports TLS 1.2 as Paypal and Ebay was all about that in June and July before August date.


Firefox has supported TLS 1.2 by default since 27.0 and TLS 1.3 by default since 60.0