Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Chủ đề này đã đóng và được lưu lại. Vui lòng hỏi một câu hỏi mới nếu bạn cần giúp đỡ.

Getting "Secure Connection Failed" message on site that works fine in Chrome and has an A+ from Qualys SSL Labs and Mozilla Observatory

  • 4 trả lời
  • 1 gặp vấn đề này
  • 60 lượt xem
  • Trả lời mới nhất được viết bởi Roland Tanglao

more options

When trying to load my personal Nextcloud instance, I receive the error in the title. I have tested the site every way I can think of, but the site's security is fine. The site loads fine in Chrome and on the Android version of Firefox. When using chrome://pippki/content/exceptionDialog.xul , I received the error "This site attempts to identify itself with invalid information." Only problem is, after looking through the cert, I can't find anything that's invalid. I have attached everything I can think of that's relevant.

I have tried a new profile (same error), Safe Mode (same error), disabling security.ssl.enable_ocsp_stapling in about:config, disabling my antimalware (Windows Defender), and refreshing Firefox. I don't know what else I can do to try and fix this.

Đính kèm ảnh chụp màn hình

Được chỉnh sửa bởi Roland Tanglao vào

Giải pháp được chọn

I have discovered the root of the problem to be the version of lighttpd I was using (1.4.49). A newer version (1.4.51) contains a fix. Other Web servers (nginx tested) do not have this issue.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (4)

more options

Giải pháp được chọn

I have discovered the root of the problem to be the version of lighttpd I was using (1.4.49). A newer version (1.4.51) contains a fix. Other Web servers (nginx tested) do not have this issue.

more options

Hi aveilleux

If the nextcloud site you are referring to is the one in this screenshot:

https://www.flickr.com/gp/roland/8zEY42

then i can load it no problem.

I too am using:

Windows 10, Firefox 63.0.1, Windows Defender, no 3rd party anti-virus or anything custom or any Firefox add-ons of any sort

My suggestion would be to check your DNS, Firewall and ISP

If the website in that flickr url is not your nextcloud site, then please share the URL of a site that can help us debug further!

Cheers!

...Roland p.s. one last thought:

perhaps one or more of the addons is breaking things? e.g. HTTPS Everywhere?!? No idea about the otheradd-ons, i'd try removing them one by one

    Amazon SMILE! 1.3 ({1417a6e0-be73-4358-912c-5dce719b5791})
    HTTPS Everywhere 2018.10.31 (https-everywhere@eff.org)
    Open Frame 7 ({c853c31a-d96d-4394-bff3-da25ba9ab8b9})
    Reddit Enhancement Suite 5.10.3 (jid1-xUfzOsOFlzSOXg@jetpack)
    uBlock Origin 1.17.2 (uBlock0@raymondhill.net)
more options

As I mentioned above, I already traced the root of the problem to a bug in the version of my httpd. If you accessed the site recently, I have already fixed the issue by switching to nginx.

I would also appreciate it if you removed the image from a public host, as I am not intending for that information to be readily available.

more options

Hi aveilleux

Wires got crossed. I loaded your question and didn't refresh before replying so I didn't see your response.

I have deleted the flickr post and your screenshot with the url of your site (the first screenshot).

All's well that ends well!

Cheers!

...Roland

p.s. i will also close this thread, please create a new question if you run into future issues!