X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Browser window missing top header bar

Được đăng

FF recently updated and when it restarted my browser window is now not showing my menu toolbar or bookmarks toolbar even though they are checked to be on. Plus the minimize/maximize buttons are overlapping my tabs at the top. It seems I'm in some different sized view or something that I cannot figure out how to get out of. I am not in "full screen" view (already tried F11 to be sure). And I've tried dragging the sides out but that doesn't fix the top min/max button issue where it overlaps and my toolbars AND my MENU bar still do not show up. I've gone into customize and removed and then re-added the "bookmarks menu" but it only shows up next to the other icons, not in the normal "toolbar" format with my folders, etc. I can view my bookmark toolbar in the SIDEBARS but again it's just the top of my screen that's messed up and I know it has something to do with my min/maximize buttons being overlapped with tabs but can't get out of it.

I've put a screenshot below to show you what I mean. Any help would be greatly appreciated.

FF recently updated and when it restarted my browser window is now not showing my menu toolbar or bookmarks toolbar even though they are checked to be on. Plus the minimize/maximize buttons are overlapping my tabs at the top. It seems I'm in some different sized view or something that I cannot figure out how to get out of. I am not in "full screen" view (already tried F11 to be sure). And I've tried dragging the sides out but that doesn't fix the top min/max button issue where it overlaps and my toolbars AND my MENU bar still do not show up. I've gone into customize and removed and then re-added the "bookmarks menu" but it only shows up next to the other icons, not in the normal "toolbar" format with my folders, etc. I can view my bookmark toolbar in the SIDEBARS but again it's just the top of my screen that's messed up and I know it has something to do with my min/maximize buttons being overlapped with tabs but can't get out of it. I've put a screenshot below to show you what I mean. Any help would be greatly appreciated.

Giải pháp được chọn

"Refresh Firefox" worked for me too. Thanks.

But it is annoying having to do this, then having to find and reinstall all of your add-ons.

Đọc câu trả lời này trong ngữ cảnh 0
jscher2000
  • Top 10 Contributor
8695 giải pháp 71066 câu trả lời
Được đăng

Hi sbledsoe, this sounds quite jumbled (I can't see your image, it might not have uploaded successfully).

Here are two levels of "reset" for the toolbar area:

(1) "Restore Defaults" button

This is at the bottom of the Customize screen: Customize Firefox controls, buttons and toolbars

(2) xulstore.json file

Sometimes the settings file that stores window dimensions and certain aspects of the toolbar layout becomes corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstoreOLD.json. If you see a file named localstore.rdf, you can delete it, it's obsolete.

Start Firefox back up again. Do windows display normally again?

That mini-reset will hide the menu bar and bookmarks toolbar. You can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.

Hi sbledsoe, this sounds quite jumbled (I can't see your image, it might not have uploaded successfully). Here are two levels of "reset" for the toolbar area: (1) "Restore Defaults" button This is at the bottom of the Customize screen: [[Customize Firefox controls, buttons and toolbars]] (2) xulstore.json file Sometimes the settings file that stores window dimensions and certain aspects of the toolbar layout becomes corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > Exit * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''xulstore.json''' to something like xulstoreOLD.json. If you see a file named localstore.rdf, you can delete it, it's obsolete. Start Firefox back up again. Do windows display normally again? ''That mini-reset will hide the menu bar and bookmarks toolbar.'' You can use one of these methods to show the toolbar list and select the desired bars there: * right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button) * (menu bar) View > Toolbars<br><em>On Windows, tap the Alt key to activate the menu bar temporarily.</em> * in Customize mode > Toolbars button (see: [[Customize Firefox controls, buttons and toolbars]]) To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.

Người tạo câu hỏi

Sorry, trying to upload image again. I've reset defaults but that still doesn't fix the menu and bookmarks toolbars or the minimize/maximize buttons as shown in screenshot.

Sorry, trying to upload image again. I've reset defaults but that still doesn't fix the menu and bookmarks toolbars or the minimize/maximize buttons as shown in screenshot.

Người tạo câu hỏi

Tried options but still having the same issue, menu and bookmark toolbars won't show up, min/max boxes are still overlapping my tabs when they shouldn't be so any other ideas based on my uploaded image would be greatly appreciated!

Tried options but still having the same issue, menu and bookmark toolbars won't show up, min/max boxes are still overlapping my tabs when they shouldn't be so any other ideas based on my uploaded image would be greatly appreciated!
jscher2000
  • Top 10 Contributor
8695 giải pháp 71066 câu trả lời
Được đăng

Hi sbledsoe, thank you for the screenshot. It's very odd!

Could you check whether your Firefox is in "full screen" mode? That would explain the missing bars and possibly the weird buttons. You can try these methods:

  • the application menu should have the arrows pointing inwards instead of outwards on the Full Screen button:

  • the F11 function key switches Firefox in and out of full screen mode
  • moving the mouse pointer to the top of the screen just barely to the right of the last tab and right-clicking would give you a short menu with "Exit Full Screen Mode" as an option

Was that it?

Hi sbledsoe, thank you for the screenshot. It's very odd! Could you check whether your Firefox is in "full screen" mode? That would explain the missing bars and possibly the weird buttons. You can try these methods: * the application menu should have the arrows pointing inwards instead of outwards on the Full Screen button:<br><br><img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2018-10-29-12-30-37-db9217.png" width="320"> * the F11 function key switches Firefox in and out of full screen mode * moving the mouse pointer to the top of the screen ''just barely'' to the right of the last tab and right-clicking would give you a short menu with "Exit Full Screen Mode" as an option<br><br><img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2018-10-29-12-35-29-25b543.png" width="320"> Was that it?

Được chỉnh sửa bởi jscher2000 vào

Người tạo câu hỏi

No sorry, that's not it. I'm aware of the full screen mode and already toggled that on and off again and that makes the entire top bar disappear whereas this is something I've never seen before and I just cannot figure out how to get it back to normal since the update happened. Plus that doesn't account for why my menu bar and my bookmarks toolbars are hidden as well (even though both are turned on as my screenshot shows). Any other ideas or are we at a loss at this point?

No sorry, that's not it. I'm aware of the full screen mode and already toggled that on and off again and that makes the entire top bar disappear whereas this is something I've never seen before and I just cannot figure out how to get it back to normal since the update happened. Plus that doesn't account for why my menu bar and my bookmarks toolbars are hidden as well (even though both are turned on as my screenshot shows). Any other ideas or are we at a loss at this point?
cor-el
  • Top 10 Contributor
  • Moderator
17476 giải pháp 157949 câu trả lời
Được đăng

Câu trả lời hữu ích

Does it make a difference if you have the window title bar visible via the customize page?


You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Does it make a difference if you have the window title bar visible via the customize page? ---- You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Câu trả lời hữu ích

I actually tried that also (adding/removing the title bar) but that didn't fix it either. I also tried as suggested above the "restore defaults" options but that didn't fix it either.

HOWEVER....I have good news. I found an article on Support after clicking on one of the links in the most recent answer that had a "refresh firefox" button and they said that it would wipe out everything except saved data like bookmarks and typically will fix issues after an update especially and so I tried that and it worked!!! I'm back to normal now. For anyone else who may have this happen and is looking for an answer click here to use the "refresh firefox" feature. https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Thank you all so much for your ideas and help.

I actually tried that also (adding/removing the title bar) but that didn't fix it either. I also tried as suggested above the "restore defaults" options but that didn't fix it either. HOWEVER....I have good news. I found an article on Support after clicking on one of the links in the most recent answer that had a "refresh firefox" button and they said that it would wipe out everything except saved data like bookmarks and typically will fix issues after an update especially and so I tried that and it worked!!! I'm back to normal now. For anyone else who may have this happen and is looking for an answer click here to use the "refresh firefox" feature. https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings Thank you all so much for your ideas and help.

Được chỉnh sửa bởi sbledsoe vào

FedupwithScripterrors 1 giải pháp 9 câu trả lời
Được đăng

Giải pháp được chọn

"Refresh Firefox" worked for me too. Thanks.

But it is annoying having to do this, then having to find and reinstall all of your add-ons.

"Refresh Firefox" worked for me too. Thanks. But it is annoying having to do this, then having to find and reinstall all of your add-ons.
minalo1 0 giải pháp 1 câu trả lời
Được đăng

Fix: white or blank unclickable top of page of browser (firefox, edge, explorer, chrome)

(As only found on Microsoft help short work around as press F11 been using for months now!) Will also speed up opening Outlook/Office 365 programs

Hello everyone, first time posting here but since this problem was a big deal in my workplace, i wanted to share with you this fix that i've found on reddit. I've been looking for a solution on this problem for quit a long time now and i've finally found a way to solve this issue instantly. It worked for the 2-3 PC's that had the problem in my company. Hope it will help you :

- Right click desktop,

- Go to Intel HD Graphics settings

- Select Display

- Then choose the option Scale Full Screen.

- Make sure the option Override Application Settings has the checkbox marked.

(big thanks to marlon_shibby on https://www.reddit.com/r/sysadmin/comments/8imjva/windows_10_multi_monitor_maximized_window/

Fix: white or blank unclickable top of page of browser (firefox, edge, explorer, chrome) (As only found on Microsoft help short work around as press F11 been using for months now!) Will also speed up opening Outlook/Office 365 programs Hello everyone, first time posting here but since this problem was a big deal in my workplace, i wanted to share with you this fix that i've found on reddit. I've been looking for a solution on this problem for quit a long time now and i've finally found a way to solve this issue instantly. It worked for the 2-3 PC's that had the problem in my company. Hope it will help you : - Right click desktop, - Go to Intel HD Graphics settings - Select Display - Then choose the option '''Scale Full Screen'''. - Make sure the option '''Override Application Settings''' has the checkbox marked. (big thanks to marlon_shibby on https://www.reddit.com/r/sysadmin/comments/8imjva/windows_10_multi_monitor_maximized_window/

Được chỉnh sửa bởi minalo1 vào

cor-el
  • Top 10 Contributor
  • Moderator
17476 giải pháp 157949 câu trả lời
Được đăng

Such issues can also happen if you use a userChrome.css file with code that isn't compatible with the current release.

Such issues can also happen if you use a userChrome.css file with code that isn't compatible with the current release. *https://www.userchrome.org/what-is-userchrome-css.html