Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

My bookmarks are double spaced now with the new update. How can I go back to single space?

  • 6 trả lời
  • 1 gặp vấn đề này
  • 91 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

This new update has double spaced my bookmarks. How can I get them single spaced? Thanks.

Tất cả các câu trả lời (6)

more options

Hi yates535, have you heard of userChrome.css, an optional file you can create to restyle Firefox's user interface?

When you have 10 minutes to focus on it, here's how to set up a custom style rule for the sidebar. It works for me (another Windows 7 user), so hopefully it will work for you.

This assumes you do not already have a userChrome.css file. If you do already have a working userChrome.css file, you just need to add the rule under (A) to your file.

(A) Select and copy the following style rule code

Edited based on feedback from various threads:

/* Minimize height of sidebar items */
.sidebar-placesTreechildren::-moz-tree-row {
    min-height: 18px !important;
    height: 18px !important;
    max-height: 18px !important;

(B) Generate and download a userChrome.css file

Open the following page and paste the above rules into the editor, replacing the sample rule:


Then click "Generate CSS File" and save the userChrome.css file to your computer. (See first attached screenshot)

Use the downloads list on the toolbar to open the downloads folder directly to the new userChrome.css file. (See second attached screenshot)

Minimize that Windows Explorer window for later reference.

(C) Create a new chrome folder in your profile folder

The following article has the detailed steps for that (#1, #2, and I recommend #3)


I have videos for both Windows and Mac in case the steps in the text are not clear.

(D) Move the userChrome.css file you generated in Step B into the chrome folder you created in Step C

The next time you exit Firefox and start it up again, it should discover that file and apply the rules. Third attached screenshot shows how much tighter the spacing should be:


Được chỉnh sửa bởi jscher2000 vào

more options

I've done all of those steps but the double spacing persists.

more options

You can try this code to the userChrome.css file below the default @namespace line.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* Line height for treechildren */
:-moz-any(#bookmarks-view, #historyTree, #editBMPanel_folderTree, #placesList, #placeContent)
treechildren::-moz-tree-row {
  margin-top: -1px !important;
  min-height: 14px !important;
  height: 14px !important;

You need to create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist.

  • use a plain text editor (Windows: Notepad; Mac: Textedit) to create a (new) userChrome.css file in the chrome folder (file name is case sensitive)
  • paste the code in the userChrome.css file in the editor window
  • make sure the userChrome.css file starts with the default @namespace line

If you are on Windows:

  • make sure you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css

Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.css.txt file.

  • make sure you do not have a double .css.css file extension (userChrome.css.css.css) if it is still not working
more options

Hi yates535, I don't know why some users only need a rule to overrule the minimum height of the rows and others need additional rules. I only have hands on my own system here.

You can try the rules posted by cor-el, but I think that spacing is likely to be too tight with typical font sizes so you might change 14 pixels to 18 pixels.

/* Minimize height of sidebar items */
.sidebar-placesTreechildren::-moz-tree-row {
    min-height: 18px !important;
    height: 18px !important;
    max-height: 18px !important;
more options

I appreciate everyone's response, and I've tried each fix but non of them are helping. I don't know what else to do.

more options

Can you confirm that the userChrome.css file is working with other code?