X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Browser does not ask to save and quit anymore even when browser.ShowQuitWarning is set to true, how to fix this?

Được đăng

So there was an issue where my browser stopped automatically restoring my previous session after closing it. I followed some instructions I found online that told me to tick the option for it under Options -> General -> Startup, and this fixed the problem. However, this seemed to have caused my browser to directly close and stop asking me to save and quit even while browser.ShowQuitWarning is set to true in about:config.

If I tick off the option to automatically restore my previous session, however, I do get a warning that tells me I'm about to close my browser, but it only gives me the options to close tabs and cancel closing my browser; the option to save & quit is absent entirely.

That's about everything I know that could be related to this issue.

So there was an issue where my browser stopped automatically restoring my previous session after closing it. I followed some instructions I found online that told me to tick the option for it under Options -> General -> Startup, and this fixed the problem. However, this seemed to have caused my browser to directly close and stop asking me to save and quit even while browser.ShowQuitWarning is set to true in about:config. If I tick off the option to automatically restore my previous session, however, I do get a warning that tells me I'm about to close my browser, but it only gives me the options to close tabs and cancel closing my browser; the option to save & quit is absent entirely. That's about everything I know that could be related to this issue.

Giải pháp được chọn

Firefox 63 doesn't have the browser.showQuitWarning preference any more.

Firefox will automatically save your session.

To restore your session, as you've noted, you can use the menu:

  • menu button > Restore Previous Session
  • (menu bar) History > Restore Previous Session

or you can set the option to restore automatically:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

It's the first checkbox on the page ("General" panel), "Restore previous session".

Is there another scenario you need to cover?

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 27.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Thông tin chi tiết

jscher2000
  • Top 10 Contributor
8758 giải pháp 71658 câu trả lời
Được đăng

Giải pháp được chọn

Firefox 63 doesn't have the browser.showQuitWarning preference any more.

Firefox will automatically save your session.

To restore your session, as you've noted, you can use the menu:

  • menu button > Restore Previous Session
  • (menu bar) History > Restore Previous Session

or you can set the option to restore automatically:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

It's the first checkbox on the page ("General" panel), "Restore previous session".

Is there another scenario you need to cover?

Firefox 63 doesn't have the '''browser.showQuitWarning''' preference any more. Firefox will automatically save your session. To restore your session, as you've noted, you can use the menu: * menu button > Restore Previous Session * (menu bar) History > Restore Previous Session or you can set the option to restore automatically: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it It's the first checkbox on the page ("General" panel), "Restore previous session". Is there another scenario you need to cover?
smcc42 3 giải pháp 41 câu trả lời
Được đăng

I am aware of the Restore Previous Session option but it simply adds another layer to the process. Is there a good reason why the the SaveandQuit has been removed?

I note that the the browser.showQuitWarning no longer exists in preferences but it still appears in about:config. Confusing or what?

I am aware of the Restore Previous Session option but it simply adds another layer to the process. Is there a good reason why the the SaveandQuit has been removed? I note that the the browser.showQuitWarning no longer exists in preferences but it still appears in about:config. Confusing or what?

Được chỉnh sửa bởi smcc42 vào

jscher2000
  • Top 10 Contributor
8758 giải pháp 71658 câu trả lời
Được đăng

I'm sure there's a way to research the "why."

Obsolete preferences that you have customized can linger forever. I probably have some left over from extensions I tried for 5 minutes 10 years ago...

I'm sure there's a way to research the "why." Obsolete preferences that you have customized can linger forever. I probably have some left over from extensions I tried for 5 minutes 10 years ago...
cor-el
  • Top 10 Contributor
  • Moderator
17523 giải pháp 158448 câu trả lời
Được đăng

See also:

  • Bug 1487547 - Config browser.showQuitWarning stopped working - it won't show "Save and quit" dialog

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

See also: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1487547 Bug 1487547] - Config browser.showQuitWarning stopped working - it won't show "Save and quit" dialog (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)
interestingfellow 1 giải pháp 4 câu trả lời
Được đăng

delete this

delete this

Được chỉnh sửa bởi interestingfellow vào