X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox 63 (macOS) lets YouTube videos start automatically in spite of "media.autoplay.enabled" being set to "false."

Được đăng

Firefox 63 (macOS) lets YouTube videos start automatically in spite of "media.autoplay.enabled" being set to "false."

Can that be fixed, please?

I reverted for now to v62.0.3 and the videos do - as before updating to v63 - not automatically start. That hints strongly to v63 being the culprit here.

Firefox 63 (macOS) lets YouTube videos start automatically in spite of "media.autoplay.enabled" being set to "false." Can that be fixed, please? I reverted for now to v62.0.3 and the videos do - as before updating to v63 - not automatically start. That hints strongly to v63 being the culprit here.

Được chỉnh sửa bởi resucami2 vào

Giải pháp được chọn

hi, in firefox 63 the autoplay preferences are reorganised in preparation for this feature shipping out of the box in one of the upcoming versions. in about:config you can set media.autoplay.default to 1 in order to block automatic playback on all pages or set it to 2 to decide on a per domain basis.

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 31.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:62.0) Gecko/20100101 Firefox/62.0

Thông tin chi tiết

philipp
  • Top 25 Contributor
  • Moderator
5304 giải pháp 23419 câu trả lời
Được đăng

Giải pháp được chọn

hi, in firefox 63 the autoplay preferences are reorganised in preparation for this feature shipping out of the box in one of the upcoming versions. in about:config you can set media.autoplay.default to 1 in order to block automatic playback on all pages or set it to 2 to decide on a per domain basis.

hi, in firefox 63 the autoplay preferences are reorganised in preparation for this feature shipping out of the box in one of the upcoming versions. in about:config you can set ''media.autoplay.default'' to 1 in order to block automatic playback on all pages or set it to 2 to decide on a per domain basis.

Người tạo câu hỏi

Thanks for your reply. Setting media.autoplay.default to 1 is indeed putting an end to this idiotic automatic video playback.

The question remains why this is not the default setting. I can not imagine that a majority of people like autoplay. Could it be that Mozilla gets money from "interested parties" for having autoplay by default activated? In that case I could understand it (and would not object).

Thanks for your reply. Setting ''media.autoplay.default'' to 1 is indeed putting an end to this idiotic automatic video playback. The question remains why this is not the default setting. I can not imagine that a majority of people like autoplay. Could it be that Mozilla gets money from "interested parties" for having autoplay by default activated? In that case I could understand it (and would not object).

Người tạo câu hỏi

Philipp - my previous comment was for the most part nonsense as I obviously had not read your answer entirely. Sorry for that. Good to hear that the default for video autoplay will become "disabled" in the future.

Setting media.autoplay.default to 1 works well - until I quit and restart Firefox which sets it back to 0. Any idea why that is happening?

Philipp - my previous comment was for the most part nonsense as I obviously had not read your answer entirely. Sorry for that. Good to hear that the default for video autoplay will become "disabled" in the future. Setting media.autoplay.default to 1 works well - until I quit and restart Firefox which sets it back to 0. Any idea why that is happening?