X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox leaking local data while connected to a VPN

Được đăng

- I'm running Firefox ESR 52.9.0 (64-bit) in Kali Linux. - I have an IKEv2/IPsec VPN tunnel set up to a foreign VPN server with non-local-ISP DNS servers also hard coded in the resolv.conf file. - My local ISP is exercising internet censorship.

When trying to access a website that my local ISP is blocking with a browser other than Firefox, I can reach it fine. When trying via Firefox I get redirected to a page from my local ISP saying "this website is blocked blabla".

So Firefox is somehow leaking data outside of my VPN tunnel. As Firefox is my preferred browser I want to avoid having to ditch it.

Is there a setting in for instance about:config that needs adjusting?

I have been searching all over the web, but have been unsuccessful in finding the solution to this problem.

All suggestions are welcome - if more details are needed, just ask.

Thanks in advance!

- I'm running Firefox ESR 52.9.0 (64-bit) in Kali Linux. - I have an IKEv2/IPsec VPN tunnel set up to a foreign VPN server with non-local-ISP DNS servers also hard coded in the resolv.conf file. - My local ISP is exercising internet censorship. When trying to access a website that my local ISP is blocking with a browser other than Firefox, I can reach it fine. When trying via Firefox I get redirected to a page from my local ISP saying "this website is blocked blabla". So Firefox is somehow leaking data outside of my VPN tunnel. As Firefox is my preferred browser I want to avoid having to ditch it. Is there a setting in for instance about:config that needs adjusting? I have been searching all over the web, but have been unsuccessful in finding the solution to this problem. All suggestions are welcome - if more details are needed, just ask. Thanks in advance!

Giải pháp được chọn

What are your connection/proxy settings (Preferences/Advanced)?

On Windows, the default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".


If WebRTC is involved, see: https://www.reddit.com/r/firefox/comments/8hjh3h/google_voice_psa_if_you_have_been_recently_having/

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • This plugin provides integration with GNOME Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org

Ứng dụng

  • Firefox 52.9.0
  • Chuỗi đại diện người dùng: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/52.9.0/Linux/en-US/

Tiện ích mở rộng

  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.10 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2)
  • adapterDeviceID: Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2)
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • crashGuards: []
  • currentAudioBackend: pulse
  • driverDate:
  • driverVersion: 3.0 Mesa 18.1.4
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}]}
  • info: {u'ApzWheelInput': 1, u'ApzTouchInput': 1, u'CairoUseXRender': 0, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: No; Failed to create H264 decoder
  • webgl2Renderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2)
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
jscher2000
  • Top 10 Contributor
8637 giải pháp 70661 câu trả lời
Được đăng

Giải pháp được chọn

What are your connection/proxy settings (Preferences/Advanced)?

On Windows, the default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".


If WebRTC is involved, see: https://www.reddit.com/r/firefox/comments/8hjh3h/google_voice_psa_if_you_have_been_recently_having/

What are your connection/proxy settings (Preferences/Advanced)? On Windows, the default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy". ---- If WebRTC is involved, see: https://www.reddit.com/r/firefox/comments/8hjh3h/google_voice_psa_if_you_have_been_recently_having/

Người tạo câu hỏi

This is now working, excellent.

I already had "No proxy" set.

The setting that solved it came from the article you posted:

about:config media.peerconnection.ice.proxy_only ---> I set this to TRUE and this solved the problem.

Many thanks !!

This is now working, excellent. I already had "No proxy" set. The setting that solved it came from the article you posted: about:config media.peerconnection.ice.proxy_only ---> I set this to TRUE and this solved the problem. Many thanks !!
Gnojuan 0 giải pháp 2 câu trả lời
Được đăng

Not enough info given, leaving me confused on if I should be concerned.

Not enough info given, leaving me confused on if I should be concerned.
Gnojuan 0 giải pháp 2 câu trả lời
Được đăng

it's annoying, to be asked to survey BEFORE I read the webpage. Why no resize option, so I can answer the survey when I'm done?

it's annoying, to be asked to survey BEFORE I read the webpage. Why no resize option, so I can answer the survey when I'm done?
jscher2000
  • Top 10 Contributor
8637 giải pháp 70661 câu trả lời
Được đăng

Hi Gnojuan, if you have a question, please feel free to post it:

https://support.mozilla.org/questions/new

If none of the suggestions look helpful, keep scrolling down past them to continue submitting your new question.

Tip: To avoid losing your place, open suggested articles/threads in a new tab using any of the usual methods:

  • right-click > Open Link in New Tab
  • Ctrl+click (on Mac, Command+click)
  • "middle click" with the mouse scroll wheel
Hi Gnojuan, if you have a question, please feel free to post it: https://support.mozilla.org/questions/new If none of the suggestions look helpful, keep scrolling down past them to continue submitting your new question. ''Tip: To avoid losing your place, open suggested articles/threads in a new tab using any of the usual methods:'' * right-click > Open Link in New Tab * Ctrl+click (on Mac, Command+click) * "middle click" with the mouse scroll wheel