X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

One website has a menu that doesn't display the font correctly.

Được đăng

I believe I went through the list of prescribed solutions. Safe mode, cache cleaning, history, etc. Browser is up to date Windows is up to date Other browsers seem to display the website (and menu) just fine. Screenshot attached should show extra large menu items following "NEW". https://www.cabelas.ca/

Sorry for being a pain. :)

I believe I went through the list of prescribed solutions. Safe mode, cache cleaning, history, etc. Browser is up to date Windows is up to date Other browsers seem to display the website (and menu) just fine. Screenshot attached should show extra large menu items following "NEW". https://www.cabelas.ca/ Sorry for being a pain. :)
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Firefox uses the downloadable League Gothic Regular font for the menu bar. It is possible that Firefox uses a different font that is wider in your case that causes menu items to overlap (the width of each item is set to a specific value and thus Firefox can't adapt).

You can check in the Inspector to see if there is a message about downloading this font. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

Make sure you allow pages to choose their own fonts.

  • Options/Preferences -> General: Fonts & Colors -> Advanced
    [X] "Allow pages to choose their own fonts, instead of my selections above"

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 31.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:62.0) Gecko/20100101 Firefox/62.0

Thông tin chi tiết

FredMcD
  • Top 10 Contributor
4230 giải pháp 59028 câu trả lời
Được đăng

I had no problem.

Check your zoom controls.

<Control> (Mac=<Command>) + (plus) enlarge - (minus) reduce 0 (zero) restore

I had no problem. Check your zoom controls. <Control> (Mac=<Command>) '''+''' (plus) enlarge '''-''' (minus) reduce '''0''' (zero) restore

Người tạo câu hỏi

I appreciate the help. I did reset the zoom to zero and restarted but to no avail.

I appreciate the help. I did reset the zoom to zero and restarted but to no avail.
FredMcD
  • Top 10 Contributor
4230 giải pháp 59028 câu trả lời
Được đăng

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * '''Cookies; ''' [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * '''Cache; ''' [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}

Người tạo câu hỏi

I really appreciate your recommendations. Sadly, none of them worked. Cache is clear, cookies deleted too, plus I disabled the performance option. Restarted, went to the page, still the text looks oversized and not fitting in the table.

I really appreciate your recommendations. Sadly, none of them worked. Cache is clear, cookies deleted too, plus I disabled the performance option. Restarted, went to the page, still the text looks oversized and not fitting in the table.
FredMcD
  • Top 10 Contributor
4230 giải pháp 59028 câu trả lời
Được đăng

I called for more help. You did try Firefox in Safe Mode?

I called for more help. You did try Firefox in Safe Mode?

Người tạo câu hỏi

Yes I have after each attempt at fixing this issue. I appreciate the help!

Yes I have after each attempt at fixing this issue. I appreciate the help!
cor-el
  • Top 10 Contributor
  • Moderator
17424 giải pháp 157452 câu trả lời
Được đăng

Giải pháp được chọn

Firefox uses the downloadable League Gothic Regular font for the menu bar. It is possible that Firefox uses a different font that is wider in your case that causes menu items to overlap (the width of each item is set to a specific value and thus Firefox can't adapt).

You can check in the Inspector to see if there is a message about downloading this font. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

Make sure you allow pages to choose their own fonts.

  • Options/Preferences -> General: Fonts & Colors -> Advanced
    [X] "Allow pages to choose their own fonts, instead of my selections above"

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox uses the downloadable League Gothic Regular font for the menu bar. It is possible that Firefox uses a different font that is wider in your case that causes menu items to overlap (the width of each item is set to a specific value and thus Firefox can't adapt). You can check in the Inspector to see if there is a message about downloading this font. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Page_Inspector Make sure you allow pages to choose their own fonts. *Options/Preferences -> General: Fonts & Colors -> Advanced<br>[X] "Allow pages to choose their own fonts, instead of my selections above" If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems *https://support.mozilla.org/en-US/kb/tracking-protection-firefox
Pj 42 giải pháp 869 câu trả lời
Được đăng

600-Yards said

...Other browsers seem to display the website (and menu) just fine. Screenshot attached should show extra large menu items following "NEW".
  • Are you offered a pop-up download box if you click on this link?:


~Pj

''600-Yards [[#question-1236953|said]]'' <blockquote> ...Other browsers seem to display the website (and menu) just fine. Screenshot attached should show extra large menu items following "NEW". *https://www.cabelas.ca/ </blockquote> *Are you offered a pop-up download box if you click on this link?: *https://www.cabelas.ca/Themes/CabelasTheme/stylesheets/ResponsiveFonts/leaguegothic-regular-webfont.woff ~Pj

Người tạo câu hỏi

Yes I saved it to my Downloads folder, but when I double click it, it says there is no program to open it. Might this be the issue if Firefox is unable to open it?

Sorry for the delay in responding, I was sleeping. :)

Yes I saved it to my Downloads folder, but when I double click it, it says there is no program to open it. Might this be the issue if Firefox is unable to open it? Sorry for the delay in responding, I was sleeping. :)

Người tạo câu hỏi

Thank you very much, I hadn't seen the "Options/Preferences -> General: Fonts & Colors -> Advanced [X] "Allow pages to choose their own fonts, instead of my selections above", until this morning. As soon as I checked the "X" and reloaded the page it worked! I really appreciate it! Thank you to all who offered their help. You've all been amazing! Have a great weekend!

Thank you very much, I hadn't seen the "Options/Preferences -> General: Fonts & Colors -> Advanced [X] "Allow pages to choose their own fonts, instead of my selections above", until this morning. As soon as I checked the "X" and reloaded the page it worked! I really appreciate it! Thank you to all who offered their help. You've all been amazing! Have a great weekend!