X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

At the top of the Options page it says, "Your organization has disabled the ability to change some options."

Được đăng

At the top of the Options page it says, "Your organization has disabled the ability to change some options." What organization is this referring to? I'm at home, on a computer I bought after I retired that has never shared with anyone.

At the top of the Options page it says, "Your organization has disabled the ability to change some options." What organization is this referring to? I'm at home, on a computer I bought after I retired that has never shared with anyone.

Giải pháp được chọn

Try to remove the Mozilla and Firefox keys in HKEY_LOCAL_MACHINE\SOFTWARE\Policies\

You can export these keys in the Windows Registry to have a backup in case you need to undo steps.

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

OpenH264 Video Codec 1.7.1 Shockwave Flash 31.0.0.108 Widevine 1.4.9.1088

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

Thông tin chi tiết

jscher2000
  • Top 10 Contributor
8794 giải pháp 71946 câu trả lời
Được đăng

Hi BigFrank1, that's interesting, that might be a new message.

The most common way that settings might be "locked" so you can't change them is called an Autoconfig file. This file should never exist on a home system unless you created it for some special purpose, so I would consider it a bit suspicious.

Could you check in these locations (varies for 32-bit / 64-bit) using Windows Explorer (My Computer or hold down the Windows key and tap E to launch it):

  • C:\Program Files\Mozilla Firefox\defaults\pref
  • C:\Program Files (x86)\Mozilla Firefox\defaults\pref

A file named channel-prefs.js is normal. Any other file is suspicious. Remove any such files to a neutral location for further analysis at your leisure, or bury them in the Recycle Bin.

Hi BigFrank1, that's interesting, that might be a new message. The most common way that settings might be "locked" so you can't change them is called an Autoconfig file. This file should never exist on a home system unless you created it for some special purpose, so I would consider it a bit suspicious. Could you check in these locations (varies for 32-bit / 64-bit) using Windows Explorer (My Computer or hold down the Windows key and tap E to launch it): * C:\Program Files\Mozilla Firefox\defaults\pref * C:\Program Files (x86)\Mozilla Firefox\defaults\pref A file named '''channel-prefs.js''' is normal. Any other file is suspicious. Remove any such files to a neutral location for further analysis at your leisure, or bury them in the Recycle Bin.

Người tạo câu hỏi

Thanks for the quick reply. channel.prefs is the only thing in there.

Thanks for the quick reply. channel.prefs is the only thing in there.

Người tạo câu hỏi

That's channel-prefs with a dash, not a dot.

That's channel-prefs with a dash, not a dot.
cor-el
  • Top 10 Contributor
  • Moderator
17580 giải pháp 159053 câu trả lời
Được đăng

See also the about:support page (Help -> Troubleshooting Information) under Application Basics to see whether policies are active.

See also the about:support page (Help -> Troubleshooting Information) under Application Basics to see whether policies are active. *Application Basics -> Enterprise Policies Active *https://support.mozilla.org/en-US/kb/customizing-firefox-using-group-policy *https://support.mozilla.org/en-US/kb/customizing-firefox-using-policiesjson *https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig

Người tạo câu hỏi

I read all that but didn't understand it. I tried to follow along and do what I could, but it wasn't good enough to work, so I deleted the files I made.

I read all that but didn't understand it. I tried to follow along and do what I could, but it wasn't good enough to work, so I deleted the files I made.
cor-el
  • Top 10 Contributor
  • Moderator
17580 giải pháp 159053 câu trả lời
Được đăng

Quote: so I deleted the files I made.

What files is this about and in what location did you create files?

You can check the about:config page for locked preferences.


If necessary then do a clean reinstall and delete the Firefox program folder.

Quote: ''so I deleted the files I made.'' What files is this about and in what location did you create files? You can check the about:config page for locked preferences. ---- If necessary then do a clean reinstall and delete the Firefox program folder. *https://www.mozilla.org/en-US/firefox/all/

Người tạo câu hỏi

The last link said to make some files and put them somewhere. I don't remember the details. But I deleted them before I could mess things up any worse. I never had this problem until the new update Wednesday. It may have been this way a day or 2 before I noticed.

The last link said to make some files and put them somewhere. I don't remember the details. But I deleted them before I could mess things up any worse. I never had this problem until the new update Wednesday. It may have been this way a day or 2 before I noticed.
FFus3r 50 giải pháp 757 câu trả lời
Được đăng

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.
The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information. '''''Note:''' When you use this feature, you will lose any extensions, toolbar customizations, and some preferences.'' See the [[Refresh Firefox - reset add-ons and settings]] article for more information. To Refresh Firefox: # Open the Troubleshooting Information page using one of these methods: #*Click the menu button [[Image:New Fx Menu]], click help [[Image:Help-29]] and select ''Troubleshooting Information''. A new tab containing your troubleshooting information should open. #*If you're unable to access the Help menu, type '''about:support''' in your address bar to bring up the Troubleshooting Information page. #At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it. #Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported. #Click Finish and Firefox will reopen.

Người tạo câu hỏi

No matter how many times I refreshed it, it didn't help. So I completely removed it, downloaded and reinstalled it. I tried Run as administrator when I installed it, without saving any of my prior settings. Before I clicked a single other button, I opened Options and it still said the same thing. I refreshed the new installation a couple of times and it still said the same thing. So I uninstalled it again. Then I just clicked on the installer, clicked Run, and reinstalled it that way, instead of as administrator, again without using any of my prior settings. It still said the same thing, so I refreshed it a couple more times, and it still says the same thing. Then I put my extensions and a theme back in and I have to reset all my preferences. And I ran CCleaner before and after each installation to get rid of any trace of the old internet cache, etc. Whatever is causing my problem seems to be built right into the newest version of Firefox. Either that or my computer is reacting to it differently than it did to any previous version before the last update Wednesday.

No matter how many times I refreshed it, it didn't help. So I completely removed it, downloaded and reinstalled it. I tried Run as administrator when I installed it, without saving any of my prior settings. Before I clicked a single other button, I opened Options and it still said the same thing. I refreshed the new installation a couple of times and it still said the same thing. So I uninstalled it again. Then I just clicked on the installer, clicked Run, and reinstalled it that way, instead of as administrator, again without using any of my prior settings. It still said the same thing, so I refreshed it a couple more times, and it still says the same thing. Then I put my extensions and a theme back in and I have to reset all my preferences. And I ran CCleaner before and after each installation to get rid of any trace of the old internet cache, etc. Whatever is causing my problem seems to be built right into the newest version of Firefox. Either that or my computer is reacting to it differently than it did to any previous version before the last update Wednesday.
McCoy
  • Top 10 Contributor
546 giải pháp 5143 câu trả lời
Được đăng

Hello BigFrank1,

Even though your problem is not related to Sync - would you please take a look at the original post and the Chosen Solution
in this thread :

https://support.mozilla.org/en-US/questions/1229615


To check that preference on the "about:config" page :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

identity.fxaccounts.enabled

Should the value be set to "false", change it to true

Then close and restart Firefox.

Hello BigFrank1, Even though your problem is not related to Sync - would you please take a look at the original post ''and'' the Chosen Solution <BR>in this thread : https://support.mozilla.org/en-US/questions/1229615 ------------------------------------------------------------------------------------------ To check that preference on the "about:config" page : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''identity.fxaccounts.enabled''' Should the value be set to "false", change it to '''true''' Then close and restart Firefox.

Được chỉnh sửa bởi McCoy vào

Người tạo câu hỏi

I read about that sync problem and went to HKEY_CURRENT_USER\Software\Policies\ but Mozilla\Firefox wasn't in there. Google\Chrome was. I looked all up and down the Registry Editor and there was nothing like DisableFirefoxAccounts anywhere that I could see. Maybe there was when I had Firefox 61, but not now in 62.0.3.

And identity.fxaccounts.enabled is already set to true. It always was, because I never touched it. It was worth a try.

I read about that sync problem and went to HKEY_CURRENT_USER\Software\Policies\ but Mozilla\Firefox wasn't in there. Google\Chrome was. I looked all up and down the Registry Editor and there was nothing like DisableFirefoxAccounts anywhere that I could see. Maybe there was when I had Firefox 61, but not now in 62.0.3. And identity.fxaccounts.enabled is already set to true. It always was, because I never touched it. It was worth a try.
cor-el
  • Top 10 Contributor
  • Moderator
17580 giải pháp 159053 câu trả lời
Được đăng

Policies are always global, so a refresh or a new profile will never work.

Policies are defined in HKEY_LOCAL_MACHINE and not in HKEY_CURRENT_USER

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox
Policies are always global, so a refresh or a new profile will never work. Policies are defined in HKEY_LOCAL_MACHINE and not in HKEY_CURRENT_USER *HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox

Người tạo câu hỏi

The only thing in HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox is

Name (Default) and Type REG_SZ and Data is completely blank.

There's also a HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Firefox\LockPref that says the same exact thing.

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Firefox is the same except it has Data (value not set).

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla is exactly the same as that one.

Am I supposed to rename any of those or add a new string value or a new key?

Is HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Firefox\LockPref supposed to be there?

Do I need to delete anything?

The only thing in HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox is Name (Default) and Type REG_SZ and Data is completely blank. There's also a HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Firefox\LockPref that says the same exact thing. HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Firefox is the same except it has Data (value not set). HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla is exactly the same as that one. Am I supposed to rename any of those or add a new string value or a new key? Is HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Firefox\LockPref supposed to be there? Do I need to delete anything?
cor-el
  • Top 10 Contributor
  • Moderator
17580 giải pháp 159053 câu trả lời
Được đăng

Giải pháp được chọn

Try to remove the Mozilla and Firefox keys in HKEY_LOCAL_MACHINE\SOFTWARE\Policies\

You can export these keys in the Windows Registry to have a backup in case you need to undo steps.

Try to remove the Mozilla and Firefox keys in HKEY_LOCAL_MACHINE\SOFTWARE\Policies\ You can export these keys in the Windows Registry to have a backup in case you need to undo steps.

Người tạo câu hỏi

I just went in there and deleted those keys and it worked. Everything is as it should be. I don't know if it actually affected anything, but I'm glad it's fixed. Thank you so very much. I still don't know how it got that way, but it wasn't like that before the last update. It may have something to do with me still having Windows 7. I can't afford a new computer but don't want Windows 10 or anything Apple makes anyway. And to me Linux is just a funny word, so that's not an option. Thanks again to all who replied.

I just went in there and deleted those keys and it worked. Everything is as it should be. I don't know if it actually affected anything, but I'm glad it's fixed. Thank you so very much. I still don't know how it got that way, but it wasn't like that before the last update. It may have something to do with me still having Windows 7. I can't afford a new computer but don't want Windows 10 or anything Apple makes anyway. And to me Linux is just a funny word, so that's not an option. Thanks again to all who replied.

Người tạo câu hỏi

It came back so I ran regedit as administrator and got rid of it again. If it keeps coming back I'll just do that every time.

It came back so I ran regedit as administrator and got rid of it again. If it keeps coming back I'll just do that every time.

Người tạo câu hỏi

I don't think I had any problems when I switched to version 63 and Firefox was working good for at least the last few weeks. I got rid of Norton and I'm using Malwarebytes by itself now. Norton was doing whatever it wanted and wouldn't let me stop its scans or shut of my computer when it wasn't in the mood. Norton was causing problems with CCleaner too and things worked great once I got rid of it.

Then I updated to version 64 and it did the same thing as the update I started the thread about. "Your organization has disabled the ability to change some options." I went through the registry and deleted everything that said firefox or mozilla, including some things I probably shouldn't have. After that everything was back to normal for a day and a half and now it says the same thing again. I haven't changed anything else since the update, just cleaned up the registry, so I don't know why it came back. I still don't know if it's actually affecting anything.

Anyone have an idea for a permanent solution to this? Fiddling about in the registry won't do it unless there's something specific I can add or change the value of.

I don't think I had any problems when I switched to version 63 and Firefox was working good for at least the last few weeks. I got rid of Norton and I'm using Malwarebytes by itself now. Norton was doing whatever it wanted and wouldn't let me stop its scans or shut of my computer when it wasn't in the mood. Norton was causing problems with CCleaner too and things worked great once I got rid of it. Then I updated to version 64 and it did the same thing as the update I started the thread about. "Your organization has disabled the ability to change some options." I went through the registry and deleted '''everything''' that said firefox or mozilla, including some things I probably shouldn't have. After that everything was back to normal for a day and a half and now it says the same thing again. I haven't changed anything else since the update, just cleaned up the registry, so I don't know why it came back. I still don't know if it's actually affecting anything. Anyone have an idea for a permanent solution to this? Fiddling about in the registry won't do it unless there's something specific I can add or change the value of.
cor-el
  • Top 10 Contributor
  • Moderator
17580 giải pháp 159053 câu trả lời
Được đăng

You would have to find out what software modifies the Windows Registry and add these restrictions for Firefox. Then you can contact its creator for support if you can't disable it yourself. Firefox doesn't add such restrictions.

You would have to find out what software modifies the Windows Registry and add these restrictions for Firefox. Then you can contact its creator for support if you can't disable it yourself. Firefox doesn't add such restrictions.

Người tạo câu hỏi

Thanks. I'll try what I did before, then see if I can figure out which program is changing the registry. If I figure it out I'll post back here. The whole "your organization" thing is really puzzling me.

Thanks. I'll try what I did before, then see if I can figure out which program is changing the registry. If I figure it out I'll post back here. The whole "your organization" thing is really puzzling me.

Người tạo câu hỏi

Spybot - Search & Destroy 2 may be the program that's changing things after I use it to immunize my computer. I deleted all of the Mozilla and Firefox registry keys again and everything was okay until that night or the next day. Then it said the same thing. I still haven't figured out if there are any options that I can't change. It seems like I've changed most of them and I haven't had any problems yet. I think I'll just ignore it and see if it goes away with the next version of Firefox like it did before.

Spybot - Search & Destroy 2 may be the program that's changing things after I use it to immunize my computer. I deleted all of the Mozilla and Firefox registry keys again and everything was okay until that night or the next day. Then it said the same thing. I still haven't figured out if there are any options that I can't change. It seems like I've changed most of them and I haven't had any problems yet. I think I'll just ignore it and see if it goes away with the next version of Firefox like it did before.