X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Camara , Microphone permission for localhost

Được đăng

Hi, I try to add permission for camera and microphone in localhost (http) and it always ask to allow evens i already check allow permission

It’s have any to let firefox not ask and always allow ?

Hi, I try to add permission for camera and microphone in localhost (http) and it always ask to allow evens i already check allow permission It’s have any to let firefox not ask and always allow ?

Giải pháp được chọn

Thank for Everyone,

I found about:config -> media.navigator.permission.disabled triggle to true It's useful for me but it's not secure right ?

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (iPhone; CPU iPhone OS 12_0 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) CriOS/69.0.3497.105 Mobile/15E148 Safari/605.1

Thông tin chi tiết

FredMcD
  • Top 10 Contributor
4269 giải pháp 59855 câu trả lời
Được đăng

Go to the web page. Once the page is loading, mouse to the address bar and Left-click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

Uncheck Use Default.

Go to the web page. Once the page is loading, mouse to the address bar and '''Left-click''' the icon. Select '''Permissions. ''' In the menu, Make sure the ones you want to use are set to '''Ask''' or '''Allow. ''' Uncheck '''Use Default.'''

Người tạo câu hỏi

Dear FredMcD,

It Allow on pageload. When I use camera and Microphone it'll ask again every times.

PS. Sorry I'm use FF in Thai language

Dear FredMcD, It Allow on pageload. When I use camera and Microphone it'll ask again every times. PS. Sorry I'm use FF in Thai language
FredMcD
  • Top 10 Contributor
4269 giải pháp 59855 câu trả lời
Được đăng

The options you choose should be saved until you change them.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

The options you choose should be saved until you change them. Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * '''Cookies; ''' [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * '''Cache; ''' [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}
jscher2000
  • Top 10 Contributor
8792 giải pháp 71892 câu trả lời
Được đăng

Câu trả lời hữu ích

Hi TaeCPE, could you cross-check the Permissions panel in the Page Info dialog?

While you are on http://localhost:8080/, you can call that up using:

  • right-click (on mac, Ctrl click) a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Use the Camera" and "Use the Microphone", uncheck the "Use default" box, and then select the permission you prefer.

Does Firefox take the change this way?


How long does Firefox remember the change?

If you lose this permission when you exit Firefox, make sure you aren't clearing the "Site Preferences" data through the "Clear history when Firefox closes" feature.

Hi TaeCPE, could you cross-check the Permissions panel in the Page Info dialog? While you are on http://localhost:8080/, you can call that up using: * right-click (on mac, Ctrl click) a blank area of the page and choose View Page Info > Permissions * (menu bar) Tools menu > Page Info > Permissions * click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions Scroll down to "Use the Camera" and "Use the Microphone", uncheck the "Use default" box, and then select the permission you prefer. Does Firefox take the change this way? ---- '''How long does Firefox remember the change?''' If you lose this permission when you exit Firefox, make sure you aren't clearing the "Site Preferences" data through the "Clear history when Firefox closes" feature.

Giải pháp được chọn

Thank for Everyone,

I found about:config -> media.navigator.permission.disabled triggle to true It's useful for me but it's not secure right ?

Thank for Everyone, I found about:config -> media.navigator.permission.disabled triggle to true It's useful for me but it's not secure right ?

Được chỉnh sửa bởi TaeCPE vào

jscher2000
  • Top 10 Contributor
8792 giải pháp 71892 câu trả lời
Được đăng

TaeCPE said

I found about:config -> media.navigator.permission.disabled triggle to true It's useful for me but it's not secure right ?

Normally this preference is false. You're saying the microphone works if you set this preference to true, or if you set it back to false?

''TaeCPE [[#answer-1160631|said]]'' <blockquote>I found about:config -> media.navigator.permission.disabled triggle to true It's useful for me but it's not secure right ? </blockquote> Normally this preference is false. You're saying the microphone works if you set this preference to true, or if you set it back to false?

Người tạo câu hỏi

Yes it’s work and not ask for permission anymore.

Yes it’s work and not ask for permission anymore.