X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

How to stop FF from running after I DO NOT close it properly before a Win10 Shutdown?

Được đăng

Using FF 62.0.2 with Win10 Pro 64bit.

More often than not I don't bother closing everything before I do a shutdown on my Win10 PC. This never used to be a problem for the majority of my apps, including FF - I'd get a clean startup next time round.

Recently though, I've noticed that if I don't close it beforehand, FF adamantly restarts on next startup and restores the previous session no matter what my Prefs are for restoring the previous sessions are (disabled obviously). I've even got the relevant browser.sessionstore prefs set to false or 0.

I don't see anything relating to FF in my Windows startup nor anything looking inside MSCONFIG.

When I DO a proper close exit before a shutdown, there is no problem - I get a clean startup without FF starting up.

Any ideas?

Using FF 62.0.2 with Win10 Pro 64bit. More often than not I don't bother closing everything before I do a shutdown on my Win10 PC. This never used to be a problem for the majority of my apps, including FF - I'd get a clean startup next time round. Recently though, I've noticed that if I don't close it beforehand, FF adamantly restarts on next startup and restores the previous session no matter what my Prefs are for restoring the previous sessions are (disabled obviously). I've even got the relevant browser.sessionstore prefs set to false or 0. I don't see anything relating to FF in my Windows startup nor anything looking inside MSCONFIG. When I DO a proper close exit before a shutdown, there is no problem - I get a clean startup without FF starting up. Any ideas?

Giải pháp được chọn

Yes, there is a recently rolled out feature to start Firefox with Windows if you left it open when Windows shut down. Please see this article for how to disable that: Firefox starts automatically when I restart Windows.

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 28.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

Thông tin chi tiết

Shadow110 1072 giải pháp 14836 câu trả lời
Được đăng

Separate Security Issue, please update your Flash 28.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html If you use it Reinstall with Flash Player Version: 31.0.0.108 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Hi, obviously shutting down is the preferred way so you do not clip files and create corruption with files as that is what the problem is. The proper way to shut down Firefox is not the X in the corner but from 3 Bar Menu --> Exit or if Menu Bar is running File --> Exit.

So do expect the issue to comeback and also possibly have issues with other programs as well that are running.

Please : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 62.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

'''''Separate''''' Security Issue, please update your Flash 28.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html If you use it Reinstall with Flash Player Version: 31.0.0.108 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only> Hi, obviously shutting down is the preferred way so you do not clip files and create corruption with files as that is what the problem is. The proper way to shut down Firefox is not the X in the corner but from 3 Bar Menu --> Exit or if Menu Bar is running File --> Exit. So do expect the issue to comeback and also possibly have issues with other programs as well that are running. Please : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 62.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance.
jscher2000
  • Top 10 Contributor
8839 giải pháp 72245 câu trả lời
Được đăng

Giải pháp được chọn

Yes, there is a recently rolled out feature to start Firefox with Windows if you left it open when Windows shut down. Please see this article for how to disable that: Firefox starts automatically when I restart Windows.

Yes, there is a recently rolled out feature to start Firefox with Windows if you left it open when Windows shut down. Please see this article for how to disable that: [[Firefox starts automatically when I restart Windows]].

Người tạo câu hỏi

jscher2000 said

Yes, there is a recently rolled out feature to start Firefox with Windows if you left it open when Windows shut down. Please see this article for how to disable that: Firefox starts automatically when I restart Windows.

Exactly what I was looking for, mate. Many thanks.

I knew it was something recently added because I hadn't noticed FF doing this before.

''jscher2000 [[#answer-1157144|said]]'' <blockquote> Yes, there is a recently rolled out feature to start Firefox with Windows if you left it open when Windows shut down. Please see this article for how to disable that: [[Firefox starts automatically when I restart Windows]]. </blockquote> Exactly what I was looking for, mate. Many thanks. I knew it was something recently added because I hadn't noticed FF doing this before.